Fresh-Install von ISPC 3.0.4.3 auf OpenSuse 12.1 nach PerfectSetup mit Apache2.

MBDTeam

Member
Ja, die Statistiken sind alle da. Kann das ganz gut prüfen, weil die Gesamtmenge sich nicht wirklich verändert hat über die letzten Monate. Ich hatte das ganze vorher auf einer SuSE 11.2 laufen, bin dann mit allem auf den neuen Server umgezogen und habe auch die alten Logs mitgenommen. Da kann ich jetzt sehen, das die Gesamtmenge der Zugriffe gleich geblieben ist. Das was da nicht geht, ist die Zeile mit dem vlogger und das gelegentliche hängen des Apache. Ich konnte da bisher auch kein Schema drin erkennen. Ich kann mir auch nicht vorstellen, das der Server überlastet ist.

Michael
 

lufu83

New Member
Hallo alle zusammen,

ich habe ebenfalls eine openSUSE 12.1 Server mit ISPconfig 3.0.4.3 seit einiger Zeit am laufen. Der Server wurde wie in diesem beschrieben HOWTO aufgesetzt, was soweit auch problemlos funktioniert hat.

Nach einiger Zeit verhält sich der Server genauso wie meine Vorredner es schildern:
Der Apache schmiert ab bzw. reagiert nicht mehr auf HTTP Requests, wodurch die gehosteten Webseiten nicht mehr erreichbar sind.

Im globalen ErrorLogfile des Apaches werden im 5 min Takt folgende Einträge generiert:

[Tue Apr 24 11:15:01 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
[Tue Apr 24 11:20:01 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
[Tue Apr 24 11:25:02 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Kurz bevor sich der Apache verabschiedet, steigt die Anzahl der laufenden Prozesse auf etwas über 300 an.
Dabei sind auffällig viele Apache Prozesse dabei:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -D SYSTEMD -k start
Wenn es dann zuviele geworden sind, steigt der Apache entgültig mit dem Fehler aus:
[error] server reached MaxClients setting, consider raising the MaxClients setting
Das erhöhen von "MaxClients" in der Apache Konfiguration war auch nicht zielführend.

Die Userdaten in der vlogger-dbi.conf stimmen bei mir mit denen der config.inc.php überein.
Ein login mit diesen Daten im phpMyAdmin ist auch erfolgreich.

Trafficstatistiken funktionieren bei mir nur mit dem Webalizer. AWstats funktioniert nicht, ist aber auch nicht weiter kriegsentscheidend für mich.

Ich habe mir nun das Apache Modul "server-status" installiert in der Hoffnung einen etwas besseren einblick in den Apache zu bekommen, gerade in dem Zeitraum in dem sich die Apache Prozesse anfangen anzuhäufen.
Wenn es soweit ist werde ich noch einen Auszug aus dem server-status Modul hier nachreichen.

Gibt es zu diesem Problem mittlerweile irgendwelche neuen Erkenntnisse?


Gruß
lufu
 

MBDTeam

Member
Nein leider nicht. Auch bei mir bleibt der Server immer mal wieder hängen. Mit den gleichen Problemen:
Ohne ersichtlichen Grund (keine neue oder andere Logeinträge als vorher auch) nimmt die Anzahl der Apache Threads plötzlich zu, bis die MaxClients Setting erreicht ist. Dann geht nichts mehr. Gestern habe ich nun die aktuellen Patches von Suse eingespielt. Mal sehen ob es besser wird. Das ist glaube ich, seit ich die Maschine aufgesetzt habe auch schon das 2. oder 3. mal das Apache und PHP von Suse gepatched wurden. Vielleicht ist da wirklich ein Problem bei den SuSE Leuten. Ich muss da eventuell noch mal in den SuSE Foren fragen. Das verrückte ist, das der Srever manchmal 2 Wochen läuft ohne auszusteigen-

Gruß
Michael
 

lufu83

New Member
Das auftauchen des Problems ist bei mir auch willkürlich. Mal läuft der Apache mehrere Tage ohne Probleme, andere male muss er fast täglich restarted werden.
Ich habe mittlerweile auch nochmal alle Perl Module gecheckt, daran kann es auch nicht liegen.
Ob es hierzu jemals ein Lösung geben wird?

@MBDTeam
Halte mich bitte auf dem laufenden ob das einspielen der Updates bei dir etwas gebracht hat.
 
Zuletzt bearbeitet:

MBDTeam

Member
Leider nein. Gestern war es mal wieder so weit. Ca. 400 Apaches waren dann wohl zu viel ;-)
Habe jetzt auch mal den mod_status mit angemacht. Mal sehen ob ich was sehe, wenn der Indianer das nächste mal weggrützt.

Gruß
Michael
 

MBDTeam

Member
Auch wenn es ein Selbstgespräch wird, hast Du lufu83 ein CMS auf dem Apache laufen? Wenn ja, welches?

Michael
 
Zuletzt bearbeitet:

Till

Administrator
Als workaround würde ich erstmal mal monin und munit installieren. Damit kannst Du zum einen alle wichtigen Server Parameter überwachen und aufzeichnen und zum anderen den apache daemon und server insgesamt überwachen um z.B. beim ansteigen der Prozessanzahl über eine bestimmte Schwelle automatisch apache restarten.
 

lufu83

New Member
Hallo Michael,

danke erst einmal für die Links.
Ich habe ebenfalls einige Artikel zu diesem Problem gefunden, jedoch ist in keinem eine Lösung zu finden. Die meisten wechseln dann wohl zu Debian, was für mich aber keine Option ist.

Auf dem Server läuft ein CMS (Wordpress), phpBB, und diverse Typo3 Instanzen.

@Till
Danke für den Tipp
Übrigens hat sich da ein kleiner Tippfehler eingeschlichen, es heisst : munin und monit :)

Gruß
lufu
 
Zuletzt bearbeitet:

MBDTeam

Member
@lufu Grund für die Frage war, das ich in einem älteren Thread gefunden hatte, das ein quer schießendes PHP Script die gleichen Auswirkungen auf den Apachen haben kann. Da hatte ich die Hoffnung, das Du eventuell auch das CMSMadeSimple auf dem Server laufen hast. Dann hätte man da eventuel noch mal schauen können. Ich hatte gestern auch noch mal den Apache Benchmark ab2 auf die Kiste losgelassen, war aber ohne "Befund". Selbst 300 gleichzeitige Clients mit 5000 Requests liefen ohne Probleme durch....

Ich werde dann auch mal munin und monit installieren und einrichten. Mal schauen, was es bringt.

Gruß
Michael
 

MBDTeam

Member
Seit 24.04. läuft die Kiste jetzt ohne Auffälligkeiten. Habe auch monit und munin installiert. Wirklich nette Tools. Mal schauen, wie es weitergeht.

Michael
 

lufu83

New Member
Hallo Michael,

bin heute aus dem Urlaub zurück, und höre nun von meinen Kollegen das der Apache in der Zwischenzeit wieder 2 mal hängen geblieben ist.
Leider habe ich auch noch immer keine Gelegenheit gehabt in das "Server-Status" Modul zu schauen, wenn der Apache anfängt sich hochzuschaukeln, daher diesbezüglich auch noch keine neuen Erkenntnisse die ich hier teilen könnte.
Wie schaut es bei dir aus?

Gruß
 

MBDTeam

Member
Hallo lufu,
die Kiste läuft und läuft. Seit dem letzten Absturz keine Probleme mehr (auf Holz klopf..)

Gruß
Michael
 

Till

Administrator
Unter Ubuntu konnte ich den vlogger Fehler jetzt reproduzieren. Es scheint so dass in der aktuellen Perl Version irgend eine Abhängigkeit für libdbi und mysql fehlt die vorher bestandteil des perl libdi Treibers war, so dass perl sich jetzt nicht mehr mit mysql verbinden kann und dadurch stürzt vlogger ab. Ich konnte dies unter Ubuntu 12.04 durch installieren des folgenden Paketes beheben:

apt-get install libclass-dbi-mysql-perl

Unter opensuse sollte es ein ähnliches perl Paket geben, dass den perl dbi mysql Treiber installiert.
 

Till

Administrator
Ich glaube ich war mit meinem Post etwas voreilig, da ich eben den Fehler troz Paketinstallation nochmal hatte. Brauchst es also erstmal nicht bauen.

Stattdessen funktioniert bislang folgendes: In der mysql my.cnf im [mysqld] Bereich folgende Zeilen einfügen:

max_connections = 500
max_user_connections = 500

Ich werde das mal weiter beobachten.
 
Zuletzt bearbeitet:

MBDTeam

Member
Ok, man soll nicht einfach C&P. Mit den richtigen Werten startet der mysql auch wieder :D:
Code:
max_connections = 500
max_user_connections = 500
Da war ein x zu viel ....
 

MBDTeam

Member
Also der vlogger-Fehler scheint tatsächlich nicht mehr zu kommen! Cool.

Merkwürdig ist aber sowieso, das die Maschine, seit dem ich monit und munin drauf habe, völlig problemlos läuft...

Michael
 

Till

Administrator
Ich kann zu dem Problem auch nur sagen dass es irgend was mit der Verbindung zwischen vlogger und mysql zu sein scheint. Da es keine weiteren Fehlermeldungen gibt neben der meldung dass sich vlogger unerwartet beendet hat ist das sehr schwer einzugrenzen. Ich denke dass es entweder etwas mit einer neueren Perl Version oder mysql Version zu tun haben muss oder mit anderen Defaults wie connection settings oder timeouts in den Versionen, denn der Fehler tritt nur auf der neuesten OpenSuSE und neuesten Ubuntu Version auf, auf älteren Versionen der beiden Distributionen und auf Debian und Centos scheint er nicht aufzutreten.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.