Fresh-Install von ISPC 3.0.4.3 auf OpenSuse 12.1 nach PerfectSetup mit Apache2.

MBDTeam

Member
Wie sich mittlerweile raus stellt verabschiedet sich mein Apache auch gerne mal :mad:

Ich muss da wohl doch mal forschen

Umstieg auf Debian ist leider nicht.
 

Till

Administrator
Ist das eine OpenVZ VM? Wenn ja dann ist wahrscheinlich eines der VM Limits zu gering eingestellt. Kannst Du bei OpenVZ mit:

cat /proc/user_beancounters

ansehen,die Letzte Spalte gibt an welche Limits wie oft überschritten wurden.
 

MBDTeam

Member
Nein ist leider keine VM, wenn ich gemeint war.
Was mir beim letzten Absturz aufgefallen ist: Da waren zig Threads des Apachen.
 

Till

Administrator
Schau mal ins globale apache error.log ob da irgendwelche Fehler zu "vlogger" drin stehe. Wenn ja, dann fehlt wahrscheinlich ein Perl Modul, solltest Du mit:

apt-get install vlogger

installieren können.
 

Till

Administrator
Wenn apache ein problem hatte, dann sollte dazu was im error.log stehen. Also check mal das error.log zum Zeitpunkt als apache stehen geblieben ist.
 

MBDTeam

Member
Das ist ja das Problem. Da steht ausser der Zeile mit dem vlogger nichts im Log! Auch in den Logs unter /var/log/ispconfig/http steht nichts. :confused:
 

MBDTeam

Member
Sieht nach wie vor so aus:

Code:
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
 

MBDTeam

Member
Nein lässt sich einwandfrei ausführen. Auch ein echo 'ApacheLogEntry' > auf den vlogger läuft. Das irre ist ja, das die Logs der Webseiten einwandfrei in den entsprechenden Unterverzeichnissen ankommen. Nur der regelmäßige Check von ISPConfig fürht zu dieser Fehlermeldung!
 

MBDTeam

Member
Er hat es wieder getan. Jetzt habe ich aber einen Eintrag im Log:
Code:
[Wed Mar 14 09:54:28 2012] [error] server reached MaxClients setting, consider raising the MaxClients setting
Es waren 303 laufende
Code:
 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -D SYSTEMD -k start
Prozesse. Normal sind nach einem restart des Apachen 23. Ist auch selten mehr. Woran kann das liegen?

Michael
 

Till

Administrator
Das kann z.B. an einem schlecht programmierten Suchmaschinenspider liegen oder aber wenn ein Link auf eine bei Dir gehostete Seite auf einer webseite mit hohem Traffic gepostet wurde.. Hat mit vlogger wie erst vermutet also nichts zu tun. Setze am besten mal die maxclients im apache hoch.
 

MBDTeam

Member
So sieht prefork aus:

Code:
<IfModule prefork.c>
        StartServers         10
        MinSpareServers      10
        MaxSpareServers     20
        ServerLimit        500
        MaxClients         300
        MaxRequestsPerChild  30000
</IfModule>
Die Maschine hat 16 GB

Gruß
Michael
 

Till

Administrator
Versuch bitte mal die Standardwerte:

StartServers 5
MinSpareServers 5
MaxSpareServers 10
MaxClients 150
MaxRequestsPerChild 0

Wenn die Werte zu hoch sind, dann kann dies laut apache Handbuch zu instabilitäten und Abstürzen führen.
 

MBDTeam

Member
Das sind die Werte, mit dem das Problem noch eher Auftritt. Wobei die MaxRequestPerChild auf 0 könnte ich noch mal versuchen.

Michael
 

neurex

Member
Ich frag jetzt mal frei da bei dir auch diese piped vlogger Zeilen auftreten. Funktioniert bei dir trotzdem die Trafficstatistik aktuell noch in ISPConfig?

Ich hatte das mit dem hängendem Apachen auch, hab diesen neu gestartet und dann eine Bilddatei ein paarmal geladen um den Traffic zu prüfen (funktioniert wieder). Davor hab ich ihn aber schonmal neu gestartet, hab nicht gleich etwas geladen und er hat sich dann irgendwann wieder aufgehängt ohne Trafficstatistik... ich steh da auch total auf dem Schlauch aber probiers mal ;)
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.