Fresh-Install von ISPC 3.0.4.3 auf OpenSuse 12.1 nach PerfectSetup mit Apache2.

neurex

Member
@ Till: ISPConfig 3.0.4.3 läuft wunderbar auf openSUSE 12.1, sogar der vlogger ;)

@sandy65: Hast du ein 32-bit oder 64-bit System? Der Fehler sieht mir sehr danach aus als ob der MySQL-Server "hängt". Ist die .sock Datei überhaupt vorhanden?
 

nowayback

Well-Known Member
Hatte das aus Langeweile auch gerade getestet...

Bin nach folgender Anleitung vorgegangen: The Perfect Server - OpenSUSE 12.1 x86_64 With Apache2 [ISPConfig 3] | HowtoForge - Linux Howtos and Tutorials

Hatte nur Quota weggelassen, weil ich es in ner VM getestet hab...


Folgende Änderungen waren notwendig:


Schritt 10
zypper install http://download.opensuse.org/reposi...enSUSE_12.1/x86_64/suphp-0.7.1-3.3.x86_64.rpm
ändern in:
zypper install http://download.opensuse.org/reposi...enSUSE_12.1/x86_64/suphp-0.7.1-4.1.x86_64.rpm


Schritt 11
/usr/lib/mailman/bin/newlist mailman
ändern in:
/usr/lib/mailman/bin/newlist mailman@example.com (deine domain)


Schritt 16
zypper install http://download.opensuse.org/repositories/security/openSUSE_12.1/x86_64/jailkit-2.13-1.1.x86_64.rpm
ändern in:
zypper install http://download.opensuse.org/repositories/security/openSUSE_12.1/x86_64/jailkit-2.13-1.2.x86_64.rpm


folgende Meldungen kamen dann beim installieren von ispconfig:
PHP Notice: Undefined offset: 0 in /tmp/ispconfig3_install/install/install.php on line 116
chmod: Zugriff auf „/etc/dovecot/dovecot-sql.conf~“ nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/lsb_release: Zeile 368: echo: Schreibfehler: Datenübergabe unterbrochen (broken pipe).

System läuft einwandfrei.

Grüße
nwb
 

sandy65

New Member
@ Till: ISPConfig 3.0.4.3 läuft wunderbar auf openSUSE 12.1, sogar der vlogger ;)

@sandy65: Hast du ein 32-bit oder 64-bit System? Der Fehler sieht mir sehr danach aus als ob der MySQL-Server "hängt". Ist die .sock Datei überhaupt vorhanden?
guten morgen!

hab die rechte für /usr/sbin/suexec2 auf 4755 geändert und dann hatte ich wieder zugriff auf die datenbank. *freu*

ich habe ein 32 bit system installiert.

... und der "alte" fehler besteht immer noch. :confused:
 

MBDTeam

Member
Habe das gleiche Problem

Hallo zusammen,
ich habe das gleiche Problem wie der OP:
Code:
[Thu Mar 01 14:25:01 2012] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /srv/www/htdocs/
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Habe auch schon alles aus diesem Thread probiert, aber leider ohne Erfolg.
Gibt es noch eine Idee?

Ach ja das Problem mit suexec2 hatte ich nach dem letzten Zypper update gestern auch. Es schein so zu sein, das die Installation die Schritte
Code:
 chown root:www /usr/sbin/suexec2
chmod 4755 /usr/sbin/suexec2
aus dem PErfect Server Setup wieder rückgängig macht. :mad:

Gruß
Michael
 

Till

Administrator
Habe auch schon alles aus diesem Thread probiert, aber leider ohne Erfolg.
Gibt es noch eine Idee?
Versuch mal apparmor zu deaktivieren, vielleicht blockt das den vlogger.

aus dem PErfect Server Setup wieder rückgängig macht.
Solche Probleme mit yast sind normal, deshalb setze ich auch kein OpenSuSE mehr für Produktive Server ein. Für den Desktop ist OpenSuSE ganz ok, für den Server würde ich aber Debian empfehlen wenn man Wert auf ein dauerhaft funktionierendes System legt.
 

MBDTeam

Member
Hm, der AppArmor ist leider nicht mal installiert :(

Gibt es new Möglichkeit das was da passiert auf der Console nachzustellen? Eventuell sieht man dann ja was passiert, bzw warum das Script aussteigt.

Gruß
Michael
 

Till

Administrator
Du kannst ja mal versuchen eine typische apache Log-Zeile mit vorangestellter Domain an vlogger zu pipen. Könnte so gehen:

Code:
echo 'domain.tld 192.168.0.1 - - [01/Mar/2012:14:21:30 +0000] "GET / HTTP/1.1" 200 9025 "-" "Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)"' | /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd
 

MBDTeam

Member
Geht. Keine Fehlermeldung und die Daten landen in den Logfiles.
Das ist ja noch zusätzlich das Merkwürdige. Die Logs selber funktionieren ja. Das heißt sich habe sowohl Access als auch die Error Logs. Die Fehlermeldung kommt übrigens immer im Abstand von 5 Minuten - und zwar genau um 15:00, 15:05 usw. Das hat hier glaube ich noch keiner geschrieben. Und immer mit der zusätzlichen Meldung:
Code:
[Thu Mar 01 15:10:01 2012] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /srv/www/htdocs/
Michael
 

Till

Administrator
Danke für den Hinweis, das erklärt das Problem oder besser gesagt, dass es kein problem gibt. Denn die Meldung bedeutet dann lediglich dass er den Aufruf von von localhost nicht loggd und sich vlogger beendet.

Versuch mal in /srv/www/htdocs/ eine leere index.html Datei anzulegen.
 

Till

Administrator
Vielleicht kann vlogger bei Dir kein verzeichnis für localhost anlegen. Versuch mal folgendes:

mkdir /var/log/ispconfig/httpd/localhost
 

MBDTeam

Member
Ist es leider auch noch nicht.
Nur um das Prinzip zu verstehen - in die /var/log/apache/access.log gehen alle Meldungen, in die unter /var/log/ispconfig gehen die entsprechenden Domains? Weil die vom Test von ispconfig:
Code:
127.0.0.1 - - [01/Mar/2012:16:25:01 +0100] "GET / HTTP/1.1" 200 - "-" "Mozilla/5.0 (ISPConfig monitor)"
kommt nämlich nirgendwo an.

Michael

Noch mal geschaut kommen doch an unter voller Name des Systems.
 
Zuletzt bearbeitet:

Till

Administrator
/var/log/apache/access.log und /var/log/ispconfig sind zwei unabhängige Dinge, es ist also in Ordnung dass eine Email die an vlogger gesendet wird nicht im globalen access.log ankommt, das darf sie auch garnicht.

Die Datei /var/log/apache/access.log ist die Logdatei der Linux Distribution und wird von ISPConfig nicht verwendet. Du kannst Sie aus performance gründen auch komplett in der apache config deaktivieren.

Vlogger ist ein apache log script welches die Logdaten des Apache via Pipe erhält und in Echtzeit anhand des vhost splittet, in die Unterverzeichnisse in /var/log/ispconfig/httpd/ verteilt und gleichzeitig Traffic Statistiken erstellt und diese periodisch in die mysql Datenbank schreibt.
 

MBDTeam

Member
Ok, werde ich mir merken.
Aber waurm ist jetzt nach Neustart des Apachen Ruhe ????:confused:

Das muss ich nicht verstehen oder??:mad:

Eventuell hat das anlegen der Verzeichnisse und das Anlegen der Index Datei doch was gebracht.;)

Michael
 

Till

Administrator
Es liegt ja kein Problem vor. Du kannst also entweder den code von vlogger debuggen wenn Du genau wissen warum apache den Log Eintrag auf Deinem system schreibt oder aber Du lässt es einfach wie es ist.
 

neurex

Member
Interessant ist das schon. Nachdem sich mein Apache2 in letzter Zeit kommentarlos verabschiedet habe ich die Logs etwas studiert und was finde ich in der apache2 error_log???

piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
irgendwie bekannt... interessant finde ich vielmehr das der WebTraffic in ISPConfig trotzdem gezählt wird... was soll mir diese Fehlermeldung also sagen???
 

sandy65

New Member
Interessant ist das schon. Nachdem sich mein Apache2 in letzter Zeit kommentarlos verabschiedet habe ich die Logs etwas studiert und was finde ich in der apache2 error_log???



irgendwie bekannt... interessant finde ich vielmehr das der WebTraffic in ISPConfig trotzdem gezählt wird... was soll mir diese Fehlermeldung also sagen???
... also ich habs nochmal mit einer kompletten neuistallation versucht und wieder den gleichen fehler bekommen. weil ich's nicht glauben konnte hab ich dann NOCH EINMAL einen versuch gestartet ... wieder das selbe. mittlerweile habe ich die suse version gelassen und bin auf debian umgestiegen ... der server läuft bei mir nun stabil *freude* :)
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.