Quota-Problem

hahni

Active Member
Ubuntu 6.06.1 LTS!

Habe noch einmal nachsehen lassen! Laut Statistik in ISPConfig 27 MB von 50 MB verbraucht! Laut Quota angeblich 51 MB (also 1 MB überschritten)...
 

Till

Administrator
Installier mal bitte die clamav Pakete von Ubuntu. Ich glaube das sind:

apt-get install clamav clamav-daemon clamav-freshclam

dann ruf auf:

which clamdscan

nimm den Pfad der Dir dann angezeigt wird (ich denke es müsste /usr/bin/clamdscan sein) und ersetze den clamscan Pfad in der Datei /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin damit.

bitte beachte den Unterscheid clamscan und clamdscan im obigen text :)

Dann lösche alles was mit clamav anfängt im /tmp Verzeichnis.
 

hahni

Active Member
Ok, probier ich nachher gleich mal aus! Dann läuft quasi clamav als Dienst und wird nicht mehr pro Instanz aufgerufen?

Vermutlich sollte ich aber die Quota noch einmal auf "-1" setzen, damit die Mails des Users zugestellt werden können. Kann es sein, dass die derzeit noch in der postfix-queue hängen?
 

hahni

Active Member
Also, die Pakete sind installiert. Es wurden noch andere empfohlen:
---
root@server:/# apt-get install clamav clamav-daemon clamav-freshclam
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
clamav-base libclamav3 libgmp3c2
Vorgeschlagene Pakete:
unrar lha clamav-docs daemon
Empfohlene Pakete:
arj unzoo
---
Werden die funktionserweiternd benötigt (naja, nicht direkt ;)), oder eher nicht installieren?

Die Änderungen habe ich vorgenommen:
---
# Configure your full path to clamscan or clamdscan
# (If you use clamdscan, see the README for directions)
# CLAMSCAN=/home/admispconfig/ispconfig/tools/clamav/bin/clamscan
CLAMSCAN=/usr/bin/clamdscan
---

Ist ein Neustart von irgendeinem Dienst erforderlich?
 

hahni

Active Member
Huhu Till,

ein sehr sehr guter Tipp. Nach dem Löschen und der Verzeichnisse in "/tmp" und direkt nach der Einbindung als Dienst ist die Quota wieder ok (also auf dem Wert, den auch ISPConfig oder "du" anzeigt)!

Dann war dies die Ursache :D! Vielen herzlichen Dank für deine prompte Mithilfe. Wird der clamav trotzdem aktualisiert? Muss oder soll die ISPConfig-Version deinstalliert werden (was ja dann Sinn macht)?

Wie sieht es bei neuen SW-Ständen von ISPConfig aus? Werden die getroffenen Änderungen dann berücksichtigt?

Viele Grüße

Hahni
 

Till

Administrator
Dann war dies die Ursache :D! Vielen herzlichen Dank für deine prompte Mithilfe. Wird der clamav trotzdem aktualisiert? Muss oder soll die ISPConfig-Version deinstalliert werden (was ja dann Sinn macht)?
Der ClamAV ist jetzt der von Ubuntu 6.06, der von ISPConfig wird nicht mehr verwendet.

Wie sieht es bei neuen SW-Ständen von ISPConfig aus? Werden die getroffenen Änderungen dann berücksichtigt?
Die Änderung in der clamassassin Datei wird überschrieben, Du solltest sie vor einem Update sichern und danach einfach zurück kopieren.
 

hahni

Active Member
Hallo Till,

im Endeffekt liefert quasi ISPConfig immer einen clamav mit, den man gar nicht löschen kann/braucht, weil dieser beim nächsten Update wieder mit dabei ist?

Die Version von Ubuntu wird hoffentlich auch automatisch aktualisiert (Signaturen)?

Dann werde ich gleich mal schauen, ob es sich da um die v0.93 handelt. Kann man das irgendwo auslesen?

Die von Ubuntu vorgeschlagenen Pakete: sollten die auch installiert sein?

Viele Grüße

Hahni
 

Till

Administrator
Ich befürchte, der clamav von Ubuntu 6.06 wird noch ein sehr alter sein, deshalb liefern wir einen aktuelleren bei ISPConfig mit.

Du kannst die Versionsnummer auslesen mit:

clamdscan -V
 

SpY

New Member
wir haben genau das gleiche problem, scheint als wurde einfach nicht ausreichend getestet bevor man eine version als "stable" bezeichnet. wenn man kunden hat, kann solch unsaubere arbeit einem das genick brechen...

es kann keine lösung sein, ispconfig ständig neu zu starten das alle kunden ihre mails bekommen
 

Till

Administrator
wir haben genau das gleiche problem, scheint als wurde einfach nicht ausreichend getestet bevor man eine version als "stable" bezeichnet. wenn man kunden hat, kann solch unsaubere arbeit einem das genick brechen...

es kann keine lösung sein, ispconfig ständig neu zu starten das alle kunden ihre mails bekommen
Bevor Du mit solchen Anschuldigungen um Dich wirfst, solltest Du vielleicht mal überlegen, wie viele ISPConfig Installationen es gibt. Das sind weltweit inzwischen ein paar 10.000 Installationen und es kommen täglich um die 400 Installationen und Updates hinzu. Wenn also 2 Leute solch ein Problem haben, dann ist deine Anschuldigung schon sehr weit hergeholt.

1.) Clamav != ISPConfig, es liegt kein Problem in ISPConfig oder der ISPConfig Quota Anzeige vor. Es ist ein Bug in Clamav der Seit den 0.9x Versionen besteht. Dieser Bug führt dazu, dass ClamAV manchmal "vergißt" seine eigenen temp Dateien zu löschen.

Die Lösung ist sehr einfach und wurde hier schon beschrieben, stelle Dein System auf Clamd um.
 

SpY

New Member
tut mir leid, ich wollte dir / euch weder zu nahe treten noch beleidigen. war halt nur der frust weil das ganze we keine mails zugestellt wurden


sorry nochma :eek:
 

hahni

Active Member
@Till
Ich übrigens habe das nie mit ISPConfig in Zusammenhang gebracht sondern auf die Quota-Tools zurückgeführt. Was ja letztlich auch stimmte (nur dass eben für die Quota-Probleme ClamAV zuständig ist). Ich bin mit dem Support und ISPConfig seit einem 3/4 Jahr sehr zufrieden

:)
 

Blackwolf

New Member
Ich hab da ein "präventives Quota-Problem" ...

Ich habe ISPConfig nach dem "Perfect-Script" aufgesetzt, habe aber offensichtlich nach der Installation mit den Folgeschritten Probleme.

Gehostet wird ein virtueller Server bei Strato. Die /etc/fstab ist relativ leer:

Code:
---- /etc/fstab ---

proc  /proc       proc    defaults    0    0
none  /dev/pts    devpts  rw          0    0
in der /etc/mtab liest sich das so:

Code:
---- /etc/mtab ---
/dev/vzfs / reiserfs rw,usrquota,grpquota 0 0
tmpfs /lib/init/rw tmpfs rw,nosuid 0 0
proc /proc proc rw,nodiratime,nosuid,nodev,noexec 0 0
tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0
devpts /dev/pts devpts rw,nosuid,noexec 0 0
/dev/vzfs wird also als "/" mit quotas belegt .... auf dem Server sind aber die Dateien aquota.user und aquota.group nicht zu finden.

Gewünscht ist, das das Mailverzeichnis sowie das Webverzeichnis des jeweiligen Webs komplett limitiert wird, also /var/www/web10 z.B.

Ebenfalls gewünscht ist, das bei Überschreiten des Limits (Soft) und Beginn der Graceperiod eine Mail an den Admin des Webs abgeht ... möglichst mit individuellem Text.

Muß ich ISPConfig neu aufsetzen oder .... kann ich das nachpfriemeln?

Greetz ...
Blackw:cool:lf
 

Till

Administrator
Ich vermute, dass das ein virtueller server ist? Dann ist das alles ok und sollte so funktionieren, da das Quota auf virtuozzo servern vom haupt node aus gemanagt wird.

Wenn nicht, geh nochmal die Schritte zur Quota Installation durch, die im perfect setup beschrieben sind.

Ebenfalls gewünscht ist, das bei Überschreiten des Limits (Soft) und Beginn der Graceperiod eine Mail an den Admin des Webs abgeht ... möglichst mit individuellem Text.
ISPConfig vershickt einen Quota Report einmal pro Tag an den Admin. Wenn Du mehr benötigst, wirst Du Dir dafür Scripte programmieren müssen.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.