Installation von OpenVZ + Verwaltung von VMs mit ISPConfig 3 (Debian 6.0)

Hier nochmal ein Nachtrag. Anscheinend hat es manuell nun funktioniert. Die IP und der Hostname sind allerdings nicht m it einbezogen.


r
Code:
oot@master:/etc/init.d# vzctl start 101
Container config file does not exist
root@master:/etc/init.d# vi /etc/vz/vz.conf
root@master:/etc/init.d# vzctl create 101 --ostemplate debian-6.0-amd64-minimal
Creating container private area (debian-6.0-amd64-minimal)
Performing postcreate actions
Container private area was created
root@master:/etc/init.d# vzlist -a
      CTID      NPROC STATUS    IP_ADDR         HOSTNAME
       101          - stopped   -               -
root@master:/etc/init.d# vzctl start 101
Starting container ...
Container is mounted
Setting CPU units: 1000
Container start in progress...
root@master:/etc/init.d# vzlist -a
      CTID      NPROC STATUS    IP_ADDR         HOSTNAME
       101          7 running   -               -
Nachtrag: Durch den geänderten Startparameter ( vzctl create 101 --ostemplate debian-6.0-amd64-minimal --ipadd 130.185.109.22 --hostname vs1 ) läuft der vServer nun anscheinend. Allerdings funktionierte der Parameter "--userpasswd user:password" nicht direkt. Erst nachdem ich den Container gestartet habe und dann mittels "vzctl set 101 --userpasswd root:password --save" das passwort zugewiesen habe funktioniert er nun.

Die Frage ist nun, wieso funktioniert das ganze nicht direkt über ISPConfig ?
 
Zuletzt bearbeitet:

Till

Administrator
Die Frage ist nun, wieso funktioniert das ganze nicht direkt über ISPConfig ?
Bei mir laufen die Vserver problemlos auf einigen Debian Servern. Ich hab bei mir aber auch überall das Quota nicht installiert. Wnn Du einen Container manuell anlegts, dann blockierst Du damit die veid, so dass ispconfig dann mit der veid nicht mehr funktionieren kann. Du musst also die manuell erstellete vm erstmal löschen, bevo Du eine in ISPConfig neu erzeugen kannst.
 
Bei mir laufen die Vserver problemlos auf einigen Debian Servern. Ich hab bei mir aber auch überall das Quota nicht installiert. Wnn Du einen Container manuell anlegts, dann blockierst Du damit die veid, so dass ispconfig dann mit der veid nicht mehr funktionieren kann. Du musst also die manuell erstellete vm erstmal löschen, bevo Du eine in ISPConfig neu erzeugen kannst.
Nur legt ISPConfig, den Vserver nicht an. Quota habe ich für Vserver bereits aktiviert. Ist Quota unbedingt notwendig ? Kann ich es im Nachhinein, falls nötig deinstallieren, sodass die vServer auch unter ISPConfig funktionieren?
 
Das Gegenteil ist der Fall, da die vserver nicht funktionieren wenn Du quota installiert hast. Die Linux Quota Pakete sollten nicht installiert und quota sollte auch nicht in /etc/fstab konfiguriert sein.
Ich muss dazu sagen, dass ISPConfig auch bereits installiert war und die vServer auf dem gleichen Server laufen, wo ebend auch der eigentliche Webserver drauf läuft.
Daher ist auch Quota installiert ( Schritt 14 des HowTo ). Wofür ist denn genau Quota ? Kann ich die beiden Pakete einfach ohne Probleme deinstallieren ?

PS: Ich lese gerade "Mit Quota kann der Systemadministrator den verfügbaren Speicherplatz für jeden Benutzer oder Gruppe einschränken." Aber der "Kunde" hat ja eh nur einen begrenzten Speicherplatz. Oder ist genau dafür das Quota da ?
 
Zuletzt bearbeitet:

Till

Administrator
Das VM's und webs auf dem selben Server laufen ist an sich nicht vorgesehen. Das vorgsehene setup findest Du hier:

Installing OpenVZ + Management Of VMs Through ISPConfig 3 (Debian 6.0) | HowtoForge - Linux Howtos and Tutorials

Man installiert also ISPConfig auf dem Host Server und weitere Instanzen von ISPConfig wie z.B. ein webserver laufen in den VM's.

Quota ist für die Begrenzug de sSpeicherplatzes der webseiten da, ohne Quota kann jede Webseite beliegib groß werden. daher macht es nicht viel Sinnw ebseiten und VM's auf dem Host laufen zu haben. Wenn Du keine Größenbeschränkung von Webseiten brauchst, dann kannst Du quota auch mit quotaoff deaktivieren, danach in /etc/fstab entfernen, das Filesystem remounten und danach die quota Pakete deinstallieren. Also alle Schritte aus dem perfect setup, nur in umgekehrter Reihenfolge.
 

Till

Administrator
Ja, das ist der Sinn des Setups. Vorteil ist zum einen die höhere Sicherheit und zum anderen kannst Du die einzelnen VM's dann leicht mit vzdump sichern. Du kannst das ganze auch als ISPConfig Multiserver betreben, also dass Du das ISPConfig in den VM's jeweils an den Master des hosts anbindest.
 

GTB

Member
ich bin auch einer von denen, die openVZ zusätzlich installieren, ohne dafür einen eigenen Server zu verwenden.

Dazu habe ich Quota deaktiviert.

Also der vServer wurde installiert und vzlist -a gibt auch den Server als running aus.

Mein Problem ist aber, ich kann den vServer nun nicht erreichen, dass ich diesen installieren kann.

ein Ping läuft ins Leere.

Muss ich da noch was machen ?

Und ja, der vServer hat eine eigene IP die nur im openVZ Reiter eingtragen ist und nicht in den Server Configs.

Danke.
 

GTB

Member
OK, getestet.

Das funktioniert wunderbar.

Kann ich nun auch noch den vServer per SSH erreichen ?

Danke.
 

Till

Administrator
Stell sicher dass die IP die Du der VM zugewiesen hast nicht in der Netzwerkkarte des Host Servers konfiguriert ist und dass Du den Hostserver wie in der ISPConfig openVZ Anleitung beschrieben konfiguriert hast.
 

GTB

Member
mein Problem ist das Netzwerk.

das ist die config:

Code:
# This configuration file is auto-generated.
# WARNING: Do not edit this file, your changes will be lost.
# Please create/edit /etc/network/interfaces.head and /etc/network/interfaces.tail instead,
# their contents will be inserted at the beginning and at the end
# of this file, respectively.
#
# NOTE: it is NOT guaranteed that the contents of /etc/network/interfaces.tail
# will be at the very end of this file.

# Auto generated lo interface
auto lo
iface lo inet loopback

# Auto generated venet0 interface
auto venet0
iface venet0 inet static
        address 127.0.0.1
        netmask 255.255.255.255
        broadcast 0.0.0.0
        up route add -net 192.0.2.1 netmask 255.255.255.255 dev venet0
auto venet0:0
iface venet0:0 inet static
        address XXX.XXX.XXX.XXX (hier ist die korrekte IP angegeben)
        netmask 255.255.255.255
        broadcast 0.0.0.0
        gateway 192.0.2.1

die IP des vServers ist nicht in der Config des Servers enthalten. Auch in ISP ist sie nur beim vServer eingetragen.

Gruss
 

Till

Administrator
Poste mal:

- Die /etc/sysctl.conf Datei des Hosts
- Die Ausgabe von: uname -a
- Die /etc/network/interfaces des Hosts
- Die Ausgabe von (Host): vzlist -a
 

GTB

Member
Code:
### Hetzner Online AG installimage
# sysctl config
#net.ipv4.ip_forward=1
net.ipv4.conf.all.rp_filter=1
net.ipv4.icmp_echo_ignore_broadcasts=1
net.ipv4.conf.default.forwarding=1
net.ipv4.conf.default.proxy_arp = 0
net.ipv4.ip_forward=1
kernel.sysrq = 1
net.ipv4.conf.default.send_redirects = 1
net.ipv4.conf.all.send_redirects = 0
net.ipv4.conf.eth0.proxy_arp=1
Code:
root@server ~ # uname -a
Linux server.mydomain.tld 2.6.32-5-openvz-amd64 #1 SMP Mon Jan 16 17:49:19 UTC 2012 x86_64 GNU/Linux
Code:
root@server ~ # cat /etc/network/interfaces
### Hetzner Online AG - installimage
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto  eth0
iface eth0 inet static
  address   176.9.140.xxx
  broadcast 176.9.140.127
  netmask   255.255.255.224
  gateway   176.9.140.97

# default route to access subnet
up route add -net 176.9.140.96 netmask 255.255.255.224 gw 176.9.140.97 eth0
Code:
root@server ~ # vzlist -a
      CTID      NPROC STATUS    IP_ADDR         HOSTNAME
       101          6 running   176.9.140.yyy   vm1.server.mydomain.tld
 

GTB

Member
sehr komisch, nach einem erneuten Rebbot (gefühlt der 10te) geht es...

Sorry für die Umstände.

Gruss
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.