Zypper Update / Apache Tod, Ruby Ursache?

Du bekommst auf port 8080 ine it works seite? Die dürfte wenn dann nur auf port 80 oder 443 zu ßehen sein und nicht auf dem ispconfig port. Od hast du aus versehen beim update 80 oder 443 als ispconfig port angegeben?
hallo till,
ich hab das update out of the box durchgeführt.
sprich 8080 war der vorschlag und enter gedrückt.
die webseiten funktionieren (imageinvader zb) nur die 8080 funktioniert nicht ;-/
wo kann man das checken ? in der db find ich nix.
danke lg C
 

Till

Administrator
Schau Dir mal den ispconfig vhost in /etc/apache2/sites-enabled/ an, ob dort der richtige port (8080) in der vhost zeile steht.
 
Poste mal bitte die Ausgabe von:

netstat -tap

und

iptables -L
Code:
junkie:~ # netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:pop3                  *:*                     LISTEN      2203/pop3-login
tcp        0      0 *:imap                  *:*                     LISTEN      2358/dovecot
tcp        0      0 *:ftp                   *:*                     LISTEN      2073/pure-ftpd (SER
tcp        0      0 *:ssh                   *:*                     LISTEN      2072/sshd
tcp        0      0 *:36663                 *:*                     LISTEN      2188/perl
tcp        0      0 localhost:ipp           *:*                     LISTEN      1781/cupsd
tcp        0      0 *:smtp                  *:*                     LISTEN      2471/master
tcp        0      0 *:imaps                 *:*                     LISTEN      2358/dovecot
tcp        0      0 *:pop3s                 *:*                     LISTEN      2203/pop3-login
tcp        0      0 localhost:10024         *:*                     LISTEN      2291/amavisd (maste
tcp        0      0 localhost:10025         *:*                     LISTEN      2471/master
tcp        0      0 *:mysql                 *:*                     LISTEN      2122/mysqld
tcp        0      0 localhost:48252         localhost:mysql         ESTABLISHED 22591/amavisd (ch13
tcp        0      0 junkie:imap             212095007070.publ:34675 ESTABLISHED 18490/imap
tcp        0      0 localhost:ftp           localhost:57812         TIME_WAIT   -
tcp        0      0 localhost:mysql         localhost:48252         ESTABLISHED 2122/mysqld
tcp        0      0 junkie:imap             212095007070.publ:34668 ESTABLISHED 15165/imap
tcp        0   2076 junkie:ssh              77.116.58.142.wir:50341 ESTABLISHED 18998/0
tcp        0      0 localhost:mysql         localhost:50478         ESTABLISHED 2122/mysqld
tcp        0      0 localhost:50478         localhost:mysql         ESTABLISHED 15230/amavisd (ch3-
tcp        0      0 localhost:59170         localhost:www-http      TIME_WAIT   -
tcp        0      0 *:pop3                  *:*                     LISTEN      2203/pop3-login
tcp        0      0 *:imap                  *:*                     LISTEN      2358/dovecot
tcp        0      0 *:http-alt              *:*                     LISTEN      5456/httpd2-prefork
tcp        0      0 *:www-http              *:*                     LISTEN      5456/httpd2-prefork
tcp        0      0 *:sunproxyadmin         *:*                     LISTEN      5456/httpd2-prefork
tcp        0      0 *:ftp                   *:*                     LISTEN      2073/pure-ftpd (SER
tcp        0      0 *:ssh                   *:*                     LISTEN      2072/sshd
tcp        0      0 localhost:ipp           *:*                     LISTEN      1781/cupsd
tcp        0      0 *:smtp                  *:*                     LISTEN      2471/master
tcp        0      0 *:https                 *:*                     LISTEN      5456/httpd2-prefork
tcp        0      0 *:imaps                 *:*                     LISTEN      2358/dovecot
tcp        0      0 *:pop3s                 *:*                     LISTEN      2203/pop3-login
junkie:~ #
Code:
junkie:~ # iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

son nun ist mal der trace da :)
 
info: server nun komplett rebootet - kein änderung

alle webseiten funktionieren - das ISPConfig ist das einzige was nicht funktioniert.

Frage: Wie kann man das ISPConfig motivieren ohne Oberfläche
zu einem ReSync bzw. ReInitialisierung ?
 

Till

Administrator
lade das ispconfig tar.gz runter, entpacke es und starte das update.php script im install verezichnis.
 
Hier das Update:

Code:
junkie:/tmp/ispconfig3_install/install # php -q update.php


--------------------------------------------------------------------------------
 _____ ___________   _____              __ _         ____
|_   _/  ___| ___ \ /  __ \            / _(_)       /__  \
  | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _    _/ /
  | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |  |_ |
 _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| | ___\ \
 \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, | \____/
                                              __/ |
                                             |___/
--------------------------------------------------------------------------------


>> Update

Operating System: openSUSE or compatible, unknown version.

This application will update ISPConfig 3 on your server.

Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:

Creating backup of "/usr/local/ispconfig" directory...
Creating backup of "/etc" directory...
Checking ISPConfig database .. OK
Starting incremental database update.
Reconfigure Permissions in master database? (yes,no) [no]:

Reconfigure Services? (yes,no) [yes]:

Configuring Postfix
Configuring Mailman
Configuring Jailkit
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring MyDNS
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Database
Updating ISPConfig
ISPConfig Port [8080]: 8080

Create new ISPConfig SSL certificate (yes,no) [no]:

ln: failed to create symbolic link `/srv/www/ispconfig/web': File exists
Reconfigure Crontab? (yes,no) [yes]:

Updating Crontab
Restarting services ...
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
/usr/bin/lsb_release: line 368: echo: write error: Broken pipe
redirecting to systemctl
Job failed. See system logs and 'systemctl status' for details.
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
redirecting to systemctl
Update finished.
junkie:/tmp/ispconfig3_install/install #
Ergebnis: das selbe ...



ich weiß hier nicht mehr weiter ...
 
nochwas - anscheinend dürfte mir das update die ispconfig.vhost verbogen haben

apache zeigt mir als documentroot /srv/www/htdocs an
bei dem virtuellen server 8080
im ispconfig.host findet man sowas nicht
Code:
junkie:/etc/apache2/sites-available # cat ispconfig.vhost

######################################################
# This virtual host contains the configuration
# for the ISPConfig controlpanel
######################################################

 Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
  ServerAdmin webmaster@localhost

  <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
  </FilesMatch>

  <IfModule mod_fcgid.c>
    DocumentRoot /srv/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /srv/www/ispconfig/>
      Options -Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /srv/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
    IPCCommTimeout  7200
        MaxRequestLen 15728640
  </IfModule>

  <IfModule mpm_itk_module>
    DocumentRoot /usr/local/ispconfig/interface/web/
        AssignUserId ispconfig ispconfig
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
          php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>

  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off

  <IfModule mod_security2.c>
    SecRuleEngine Off
  </IfModule>

  # SSL Configuration
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
  #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

</VirtualHost>

<Directory /srv/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory /srv/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

junkie:/etc/apache2/sites-available #
danke
 
Die vhost Datei die Du gepostet hats ist k und so wie sie sein soll. Wahrscheinlich fehlen bei Dir apache Module, insbesondere das fcgid Modul.
Ich habe hier nichts geändert. :confused:

Aber das Update hat ...
Wir sind nun nach der Recherge draufgekommen, das ISPConfig schon seit Monaten nicht funktioniert *lol*
es hat keiner auf die Kiste gesehen und der DBCrash war nur der Impakt "Schau doch mal" :D

Hier nun das Feedback:
Also wenn "ITworks" bei ISPConfig steht, dann kann es sein, das fcgid Module im apache nicht geladen ist,
nachdem ich nicht so versiert bin ist mir dies nicht aufgefallen.
Reinladen mit:
$ a2enmod fcgid
und zur sicherheit
$ a2enmod suexec

apache2ctl restart

und et voila - es hat funktioniert!

Danke für den Input, Till - Hat sehr gut geholfen!
 
Zuletzt bearbeitet:

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.