WEBDAV geht nicht

Till

Administrator
Der 500er Fehler müsste im error.log der Webseite stehen. Schau da bite mal nach und poste die Fehlermeldung.
 

Till

Administrator
Hmm, eigentlich sollte er das lesen können.

1) Wie sind die Rechte des Folders webdav?
2) Funktioniert es wenn Du den Eigentümer der Datei auf den apache User änderst?
 

planet_fox

Super-Moderator
Code:
drwxrwx---  4 web65 client2 4,0K 18. Okt 11:19 webdav
Code:
drwxrwx--- 4 web65 client2 4,0K 18. Okt 11:19 .
drwxr-xr-x 7 root  root    4,0K 18. Okt 11:19 ..
drwxrwx--- 2 web65 client2 4,0K 18. Okt 11:19 user
-rwxrw---- 1 root  root      51 18. Okt 11:19 user.htdigest
 

DannYFreSh

New Member
Hallo,

meine Rechte sehen wie folgt aus:

webdav
Eigentümer: web27
Gruppe: client1
chmod: 770

Der entsprechende Ordner der in /webdav angelegt wird hat die gleichen Rechte wie oben.

Die .htdigest jeweils root:root mit 644

Die Module dav_fs & dav sind bei dir aktiviert/installiert ? auth_digest hattest du ja aktiviert

Bei mir läuft es so einwandfrei
 
Zuletzt bearbeitet:

Till

Administrator
Hallo Alex,

schau bitte mal in die /etc/group Datei, ob der User des apache webservers (müsste bei Debian glaube ich 'www-data' sein) auch Mitglied der Gruppe web65 ist.
 

madsam

New Member
Ich habe das selbe Problem mit webdav.

Bei mir wird der webdav Part in der ****.vhost.conf nicht automatisch erstellt.
Oder muss dieser manuell eingepflegt werden?

Ich setzte v 3.0.3 ein.


@planet_fox

Du solltest deine conf umändern in:

<IfModule mod_dav_fs.c>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN

Alias /user /var/www/clients/client2/web65/webdav/user
<Location /user>
DAV On
AuthType Digest
AuthName "user"
AuthUserFile /var/www/clients/client2/web65/webdav/user.htdigest
Require valid-user
Options +Indexes
Order allow,deny
Allow from all
</Location>
# WEBDAV END
</IfModule>

In deiner vhost.conf fehlt einfach das www.

Dann sollte alles klappen.
 
Zuletzt bearbeitet:

Till

Administrator
Oder muss dieser manuell eingepflegt werden?
Nein. Es kann lediglich sein dass der paltzhalter fehlt wenn die website in einer ispconfig version < 3.0.3 erstellt worden ist. In dem Fall einfach irgnd was ändern, wie z.b. quota und auf speichern klicken.

In deiner vhost.conf fehlt einfach das www.
Wenn das www fehlt, dann steht ein falscher pfad unter system > server config > web.
 

omose

New Member
Hallo,

Bei mir sind die Module alle im Apachen geladen, dennoch klappt die Verbindung nicht. Was mich im Log wundert ist, dass er folgenden PFad anführt:

Code:
File does not exist: /var/www/clients/client6/web9/web/webdav
Er schaut unter web nach ?

Code:
    <IfModule mod_dav_fs.c>
      # DO NOT REMOVE THE COMMENTS!
      # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN

      Alias /share /var/www/clients/client6/web9/webdav/share
      <Location /share>
        DAV On
        AuthType Digest
        AuthName "share"
        AuthUserFile /var/www/clients/client6/web9/webdav/share.htdigest
        Require valid-user 
        Options +Indexes 
        Order allow,deny 
        Allow from all 
      </Location> 
      # WEBDAV END
    </IfModule>
 
Zuletzt bearbeitet:
Bei mir klappt's leider auch nicht.
Leider hat es irgendwie keiner mit Problemen gelöst?

Aber für heute ist dann ende ...

lg loisl
 

Till

Administrator
1) Stell sicher dass Du ein aktuelles ispconfig installiert hast (3.0.3.2)
2) Wenn es eine alte website ist, dann fehlen möglicherweise die webdav Instruktionen in der vhost Datei, also irgend was in der webseite ändern und auf speichern klicken, damit sie neu geschrieben wird.
3) Hats Du auch alle notwendigen apache Module installiert und aktiviert?

a2enmod dav_fs dav auth_digest
 

stefanw

New Member
Bei mir geht es nicht. Die vhost Datei scheint ok zu sein

Im access.log steht:

88.217.170.5 - - [20/Jan/2011:12:36:37 +0100] "OPTIONS /webdav HTTP/1.1" 200 0 "-" "Microsoft-WebDAV-MiniRedir/6.1.7600"
88.217.170.5 - - [20/Jan/2011:12:36:39 +0100] "PROPFIND /webdav HTTP/1.1" 405 1892 "-" "Microsoft-WebDAV-MiniRedir/6.1.7600"
88.217.170.5 - - [20/Jan/2011:12:36:41 +0100] "PROPFIND /webdav HTTP/1.1" 405 1892 "-" "Microsoft-WebDAV-MiniRedir/6.1.7600"
88.217.170.5 - - [20/Jan/2011:12:38:08 +0100] "OPTIONS /webdav HTTP/1.1" 200 0 "-" "Microsoft-WebDAV-MiniRedir/6.1.7600"
88.217.170.5 - - [20/Jan/2011:12:38:11 +0100] "PROPFIND /webdav HTTP/1.1" 405 1892 "-" "Microsoft-WebDAV-MiniRedir/6.1.7600"
88.217.170.5 - - [20/Jan/2011:12:38:13 +0100] "PROPFIND /webdav HTTP/1.1" 405 1892 "-" "Microsoft-WebDAV-MiniRedir/6.1.7600"

Im error.log steht nichts.

Die Fehlermeldung beim Client lautet:

"Der eingegebene Ordner ist ungültig. Wählen Sie einen anderen Ordner."

Habt Ihr eine Idee?
 

Laubie

Member
Ich fang zwar mit WebDav grad erst an, aber beim Einrichten des Kontos, musste ich einen Unterordner bestimmen

domain.de/webdav/user

und laut deinem Log versuchst du domain.de/webdav/ aufzurufen ;)
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.