Varnish 4 nachträglich auf ISPConfig 3

microcosmic

New Member
Hallo.

Wie kann ich Varnish 4 nachträglich auf einem ISPConfig 3 Server (Debian 6 x64) einrichten?
Was sollte ich beachten? Welche Dateien muß ich anpassen?

Gruß,

Michael
 

F4RR3LL

Member
Hey Freunde der leichten Unterhaltung,

ich habe gestern einen Server genau so aufgesetzt, wie oben beschrieben. Das funktioniert auch, solange man nur einen vhost hat, so halbwegs zumindest. Sobald man jedoch mehrere vhosts nutzt, spinnt das, bei einem Versuch wurde nur noch eine Domain aufgerufen, egal welche subdomain man ansteuert, laut log hat er immer in /var/www gesucht egal welche subdomain ich getestet habe.

Bei einem anderen Versuch war es selbiges Problem, nur ein anderer Folder. Bin da grade etwas ratlos. Ich habe mich auf der Seite von Varnish schon grob eingelesen.
Doch konnte ich zu meinen Problemen keine Solution finden.

Hat wer einen Tipp für mich, ich vermute ich übersehe grade wieder eine Kleinigkeit.

Debian 7 , Varnish 4, php5-fpm, nginx / apache getestet
Gruß Sven
 

nowayback

Well-Known Member
hast du denn die einzelnen vhosts auch in varnish eingerichtet? gerade in verbindung mit mehreren ips kann man varnish nicht einfach so laufen lassen
 

F4RR3LL

Member
Moin nowayback,

bei dem Testaufbau habe ich erstmal nur den Webserverport umgelegt und auf 127.0.0.1:8082 lauschen lassen. Varnish habe ich auf 80 lauschen lassen und an 127.0.0.1:8082 weiterleiten lassen. Der Server hat nur eine IP, somit laufen alle vhosts auf der selben IP. In ispconfig habe ich diese ip bewusst nicht eingerichtet sondern auf * gelassen. Die einzelnen vhosts lauschen natürlich auch auf 8082.

Gruß Sven
 

nowayback

Well-Known Member
Code:
backend server1 {
    .host = "I.P.1";
    .port = "8080";
}
backend server2 {
    .host = "I.P.2";
    .port = "8080";
}

sub vcl_recv {
    if (server.ip == "I.P.1") {
        set req.backend = server1;
    } else {
        set req.backend = server2;
    }
    restlicher krempel :-)
}
Ist eigentlich ganz einfach und selbsterklärend
 

mcitpsa

New Member
Hallo zusammen,
ich schließe nich hier einmal an....
Ich versuche ebenfalls gerade Varnish zum laufen zu bekommen.
Leider klappt das bei mir absolut nicht ... Varnish läuft zwar, nur bekomme ich lediglich die "ItWorks" seite angezeigt.

Was habe ich bereits versucht:
1. Apache Ports in /etc/apache2/ports.conf abgeändert "Listen 80" geändert in "Listen 8082"
2. Die von Till besagte vhost.conf.master abgeändert und mittels mv nach conf-custom gespeichert
3. Varnisch installiert
4 . Varnisch konfiguriert. Hierzu unter /etc/default/varnish die Option 2 aktiviert und Varnish auf Port 80 lauschen lassen und die option -T auf den Apache port geändert localhost:8082
5. Die /etc/varnish/default.vcl geändert das unter "backend default {.host = 127.0.0.1 und .port = 8082}" steht
6. Apache gestartet und Varnish gestartet
7. in ispconfig mit der sync option die vhosts neu schreiben lassen

Ergebniss ist leider immer wieder die o.g. ItWorks Seite
Wäre nett wenn mir jemand auf die Sprünge helfen könnte.

Viele Grüße
Kai
 

F4RR3LL

Member
Sind deine Seiten über Port 8082 sauber aufrufbar?
Hatte den Fehler nämlich auch und der Fehler lag im Apache.

Gruß Sven
 

mcitpsa

New Member
Das muss ich nochmal nachsehen.
Mit einem wget ließ sich aber auf der console zumindest die Seite "aufrufen"
Das netstat sagte mir das der Apache auf dem Port lauscht ebenso wie varnish auf dem eingestellten port.
 

F4RR3LL

Member
Jo per wget siehste ja nicht ob da evtl auch nur der "it works" ankommt, schau mal bitte rein,
wenn 8082 alle Seiten über den apache sauber ausgeliefert werden kann man weiter debuggen bei varnish.
Sollte aber hier schon nix weiter ausser der it works kommen muss man beim apache ansetzen.
Und beim apache Test auf 8082 auch mehr als eine Domain testen.

Gruß Sven
 

mcitpsa

New Member
Ich werde das mal morgen Nacht wieder angehen... bzw das testsystem mit einem clon des Livesystems neu betanken.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.