"unknown mode" bei http - bei https korrekt

mallmis

New Member
Guten Tag,

habe mir schon einige Threads durchgelesen und komme einfach nicht weiter.

Bei Aufruf meiner Webseite:

https://www.example.com <-- alles ok
https://example.com <-- alles ok Seite wird auf https://www.example.com weitergeleitet

Bei Aufruf von:
http://www.example.com
http://example.com
www.example.com
example.com

erscheint eine weiße Seite mit dem Text: unknown mode

desktop-06-03.png

Meine Einstellungen in der htaccess sahen so aus:

Code:
RewriteEngine On

RewriteCond %{HTTP_HOST} ^example\.com$ [NC]
RewriteRule ^(.*)$ https://www.example.com/$1 [R=301,L]

RewriteCond %{SERVER_PORT} !^443$
RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]
Alle Einstellungen bei ISPConfig sind deaktiviert.

Habe vorher auch dort probiert diese Einstellungen zu setzen, leider ohne Erfolg.

Zum jetzigen Zeitpunkt sind alle Einstellungen, sowohl htaccess als auch ISPConfig deaktiviert.

Habe auch schon mit einer meiner anderen Domains getestet, gleiches Ergebnis, "unknown mode".

Das heißt an meiner Shopsoftware kann es nicht liegen.

Mein Hoster ist IONOS, dort habe ich auch schon nachgefragt, sie haben geprüft ob die Ports 80 und 443 offen sind, Ergebnis: alles ok. Ansonsten konnten sie mir nicht weiter helfen.

Mein ISPConfig:
ISPC_APP_VERSION', '3.2.3'
Ubuntu 20.04.2
Apache

Installiert nach Anleitung:

Ich wende mich an Euch um vielleicht einen nützlichen Tipp von den Experten zu erhalten und freue mich schon jetzt auf viele Anregungen.

Grüßle und vielen Dank,

der Michel
 

Till

Administrator
Schau mal ins access.log und error.log der betroffenen website. Kam das selbe Ergebnis in der website auch bevor Du die shopsoftware installiert ahst? der Fehler sieht eher aus als ob er aus einem script in der website kommt und nicht vom Server selbst.
 

mallmis

New Member
Hallo Till,

vielen Dank für die schnelle Reaktion.

Habe ich in der Vergangenheit schon geprüft und eben noch einmal. Es kommen beim error.log keine Meldungen und bei access.log kommt nur was wenn die Webseite angezeigt wird. Bei unknown mode kein Eintrag.

Habe schon eine andere Domain ohne Shop und ISPConfig Standard Startseite getestet und habe den gleichen Fehler.

Wie schon geschrieben, habe sowohl beim Hoster und beim Shopprogrammierer so gut wie alles ausgeschlossen und jetzt bleibt mir nur noch die Hoffnung das es irgendwo in den Tiefen der ISPConfig Einstellungen eine Lösung gibt....

Vielen Dank und Grüßle,

der Michel
 

Till

Administrator
Es sieht irhendwie so aus als ob der Server kein http kann, also der web server selbst oder irgend was vor dem Server, denn ansonsten müsste eine Meldung im log sein. Dass es an ISPConfig liegt ist nicht sehr wahrscheinlich, habe die Fehlermeldung noch auf keinem ISPConfig System gesehen. Hast Du irgend was in Bezug auf Apache weg gelassen beid er perfect server anleitung oder irgend etwas anders installiert?
 

Till

Administrator
Und irgendwelche Fehler im globalen apache error.log baz. werden die zugriffe bei denen Du unknown mode erhälts vielleicht im globalen apache access.log gelogged?
 

mallmis

New Member
Hallo,

super danke.

Habe alles wie in der Anleitung installiert. Unknown mode sollte heißen das Apache keine http kann, ja das macht wirklich Sinn. Ich teste es später ab 15:00 Uhr.

Melde mich und Grüßlr,

der Michel
 

Till

Administrator
Du kannst auch mal mit:

netstat -ntap

schauen, ob es wirklich apache ist, der auf port 80 lauscht.
 

mallmis

New Member
Ja der Apache2 lauscht an 443 80 und 8080. Habe jetzt festgestellt das ISPConfig Interface bei Eingabe http korrekt auf https umleitet. Wo habt Ihr denn die Einstellungen dafür gemacht? Vielleicht kann ich mir da das korrekte Vorgehen anschauen und klauen?

Die globale apache access.log und error.log zeigen nichts an. Syslog ist nur Mail Cron usw.

Grüßle,

der Michel
 

Till

Administrator
Für eine http zu https Umleitung musst Du einfach nur in ISPConfig die entsprechende checkbox auf dem 'Umleitung' Reiter der jeweiligen Website anhaken.
 

mallmis

New Member
Das habe ich ja im ersten Post geschrieben, beide Methoden, sowohl über ISPConfig als auch über die .htaccess haben nicht funktioniert. Deshalb habe ich mich ja hier gemeldet.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.