Ubuntu 20.04 - Mail-Probleme bei neuer Installation

ereuter

Member
Zuletzt bearbeitet:

Till

Administrator
Ich habe bei der ursprünglichen Installation stable ausgewählt.
aut den von Dir geposteten befehlen hast Du das nicht und daraus resultiert auch das problem, hättest Du stable genommen, dann wäre das Problem nicht aufgetreten. Kannst Du auch ganz einfach verifizieren, lade die stable Datei runter und sich darin nach mysql-virtual_sender-relayhost.cf, es gibt sie dort nicht.
 

ereuter

Member
Ich habe gesehen, dass ihr es auch in der Anleitung korrigiert habt.

Der Satz
We will use the ISPConfig 3.2 nightly builds which contain ISPConfig 3.2 beta 1 at the time of publishing this guide as ISPConfig 3.2 final has not been released yet.
stimmt allerdings nicht mehr - erstens wird ja jetzt stable installiert und die Version 3.2 ist nicht mehr beta - ist aber natürlich nur ein Schönheitsfehler.

Ich habe jetzt die gesamte Installation noch einmal ausgeführt.

Das Mailen funktioniert jetzt auch out of the box - wenn man sich mit einem Mailclient verbindet.

Im Roundcube kommt immer noch der Fehler 250 - den bringt man weg, indem man in der config den Port von 587 auf 25 ändert. Für alle die jetzt diesen Thread nicht lesen, wäre es fein, wenn man das auch in der Anleitung anmerken würde. Nachdem eh schon das mit dem localhost drinnen steht, sollte das kein großer Aufwand sein.

Und vielen Dank für die Hilfe
 

Dominik

New Member
Hallo,

ich habe hier ein ähnliches Problem, habe das auch schon im Englischen teil gepostet.
Was genau war den bei euch die Lösung.

Habe hier 2 Produktive Server die auch schon Mails versendet haben.
Komischerweise habe ich jetzt Fehlermeldungen im Log. Und kann keine Mails mehr versenden.


postfix/smtp[2529651]: error: open database /etc/postfix/sasl_passwd.db: No such file or directory
postfix/smtp[2529653]: warning: 16ADF221826: smtp_sasl_password_maps lookup error
postfix/smtp[2530650]: 5F42E22191A: to=, relay=:25, delay=189573, delays=189573/0.03/0.22/0, dsn=4.3.0, status=deferred (local data error while talking to ...)

postfix/trivial-rewrite[19441]: fatal: proxymap service is not configured for table "mysql:/etc/postfix/mysql-virtual_sender-relayhost.cf".

Danke & Gruss

Dominik
 

Dominik

New Member
Hallo Till,

ich habe jetzt mal die Zeilen auskommentiert:

sender_dependent_relayhost_maps = proxy:mysql:{config_dir}/mysql-virtual_sender-relayhost.cf
smtp_sasl_password_maps = proxy:mysql:{config_dir}/mysql-virtual_sender-relayauth.cf, hash:{config_dir}/sasl_passwd
smtp_sender_dependent_authentication = yes
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous, noplaintext
smtp_sasl_tls_security_options = noanonymous

Ich verstehe aber nicht wie das da rein kam ich habe die Server mit der Stable Variante 3.2.2 installiert.

Gruss
Dominik
 

Till

Administrator
Du hast nicht die stable version installiert sondern eine nightly build, in stable sind die genannten zeilen nicht drin.
 

Dominik

New Member
Hallo Till,
OK das klingt logisch :) was nicht drin is kann nicht auftauchen habs ja oben gelesen. Aber ich hatte im installiert stable ausgewählt. Das ist doch auch der default Wert der gesetzt ist. Den hatte ich nicht angepasst da ich auf einer Produktiv Umgebung keine Nigtlys benutzen würde.
Komisch ist hier auch das das Malen ein paar Tage funktioniert hat. Muss hier mal die Logs genauer anschauen.

Naja dann muss ich mich da wohl vertippt haben auf allen Servern. Dachte ja nur nicht das da beim auswählen was im Code verrutscht ist.
Aber wenn das dann schon die Lösung des Problems war/ist ist es ja halb so wild.

Danke für die schnelle Rückmeldung

Gruss
Dominik
 

ereuter

Member
In der Anleitung war beim Download die falsche Version drinnen, das ist aber mittlerweile korrigiert worden. Wenn du also jetzt das Setup noch einmal ausführst, wird die stable installiert.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.