suPHP & register_globals = ON/OFF

Till

Administrator
Variablem mittels php_admin values kann man bei SuPHP nicht setzen, da das CGI-PHP das nicht versteht.

Den PHP Safe Mode kannst Du aktivieren (in ISPConfig 2.2.21), indem Du die Folgende Zeile in das apache direktiven Feld der Webseite einfügst:

SetEnv php_safe_mode On

Für weitere Variablen müsstest Du ggf. das Wrapper Script anpassen. Es ist das Script, welches in Diesem Thread entwickelt wurde:

http://www.howtoforge.de/forum/showthread.php?t=91

Es liegt in /home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper
 

Feanwulf

Member
Danke sehr! Ich habe das Script dann mal angepasst:

Code:
#!/bin/sh
PATH="/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec"

BASEDIR=`dirname ${DOCUMENT_ROOT}`
TMPDIR=${BASEDIR}/phptmp
SESSDIR=${TMPDIR}

if [ X"${php_safe_mode}" != X"On" ]; then
SAFE_MODE="Off"
else
SAFE_MODE="On"
fi

if [ X"${php_register_globals}" != X"On" ]; then
GLOBALS="Off"
else
GLOBALS="On"
fi

exec php-cgi -d open_basedir=${BASEDIR} -d upload_tmp_dir=${TMPDIR} -d session.save_path=${SESSDIR} -d safe_mode=${SAFE_MODE} -d register_globals=${GLOBALS}
Mit SetEnv php_register_globals On kann ich dann register_globals in dem einen Hosting anpassen ;)
 
Zuletzt bearbeitet:

Feanwulf

Member
Code:
if [ X"${php_memory_limit}" != X"16M" OR X"${php_memory_limit}" != X"0" OR X"${php_memory_limit}" != X"" ]; then
MEMORY="${php_memory_limit}"
else
MEMORY="16M"
fi
Mit obiger IF THEN ELSE Funktion wollte ich mit SetEnv php_memory_limit den verfügbaren Speicher angeben.

Leider scheint es keinen Unterschied zu machen ob ich

SetEnv php_memory_limit 32M
SetEnv php_memory_limit 64M

eintrage. Wo habe ich den Denkfehler?
 

Till

Administrator
Hast Du denn die Variable auch an das php CGI Binary übergeben? Möglicherweise kann man das auch nicht extern setzen, schau ggf. mal in der PHP Doku nach.
 

Feanwulf

Member
Also zumindestens kann ich memory_limit übergeben auch mit dem php-wrapper script.

Aber anscheinend mache ich da einen Fehler wenn ich die Eingabe aus ISPConfig verarbeite ;) Das krieg ich aber bestimmt auch noch hin und dann schreib ich die Lösung hier rein!
 

Werbung

Top