SSL installation scheitert

SyntaX

New Member
Hallo,

wollte gerade nach diesem Tutorial: KLICK SSL Installieren, bekomme aber ab punkt 2, beim erstellen des Zertifikats folgenden Fehler:

Code:
e is 65537 (0x10001)
Enter pass phrase for ispserver.key:
31180:error:28069065:lib(40):UI_set_result:result too small:ui_lib.c:849:You mus                                                                                                                                                             t type in 4 to 8191 characters
Enter pass phrase for ispserver.key:
Verifying - Enter pass phrase for ispserver.key:
31180:error:28069065:lib(40):UI_set_result:result too small:ui_lib.c:849:You mus                                                                                                                                                             t type in 4 to 8191 characters
Enter pass phrase for ispserver.key:
Verifying - Enter pass phrase for ispserver.key:
31180:error:28069065:lib(40):UI_set_result:result too small:ui_lib.c:849:You mus                                                                                                                                                             t type in 4 to 8191 characters
Enter pass phrase for ispserver.key:
Verifying - Enter pass phrase for ispserver.key:
31180:error:28069065:lib(40):UI_set_result:result too small:ui_lib.c:849:You mus                                                                                                                                                             t type in 4 to 8191 characters
Enter pass phrase for ispserver.key:
Verifying - Enter pass phrase for ispserver.key:
31180:error:28069065:lib(40):UI_set_result:result too small:ui_lib.c:849:You mus                                                                                                                                                             t type in 4 to 8191 characters
Enter pass phrase for ispserver.key:
Verifying - Enter pass phrase for ispserver.key:
Verify failure
User interface error
31180:error:0906906F:PEM routines:PEM_ASN1_write_bio:read key:pem_lib.c:331:
work:/etc/apache2/ssl#
Woran kann es liegen?
 

Till

Administrator
Scheint so als ob Du ein SSL Zertifikat erzeugt hst, welches einen key benötigt. Das kann z.B. passieren wenn Du nicht die letzten beiden Befehle ausführst:

mv ispserver.key ispserver.key.secure
mv ispserver.key.insecure ispserver.key


und somit den verschlüsselten key verwendest.
 

SyntaX

New Member
Mache ich doch, ich mach das Tutorial mit per Copy Paste, alle befehle sind eigentlich dabei.

Edit: Hab jetzt noch einmal alles einzeln gemacht, der erste Fehler erscheint nicht mehr, dafür aber folgendes:
Code:
work:/etc/apache2/ssl# openssl x509 -req -days 3650 -in ispserver.csr -signkey i                                                                                                                                                             spserver.key -out ispserver.crt
ispserver.csr: No such file or directory
Dementsprechend, spukt Apache nach einem neustart auch eine Fehlermeldung aus.
 
Zuletzt bearbeitet:

Till

Administrator
Dann ist der vorhergehende Schritt mit einem Fehler fehlgeschlagen, da Du ja laut Fehlermeldung kein .csr File hast. Führe den Schritt zum erzeugen des csr nochmal aus.
 

SyntaX

New Member
Hi Till,

dann kommt folgendes
Code:
work:/etc/apache2/ssl# openssl req -new -key ispserver.key -out ispserver.csr
Enter pass phrase for ispserver.key:
unable to load Private Key
20081:error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt:evp_enc.c:461:
20081:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:425:
work:/etc/apache2/ssl#
 

Till

Administrator
Dann liegt der Fehler also noch vor diesem Befehl, d.h. der Key wurde nicht korrekt erstellt. Dann erstelle jetzt den key neu.
 

SyntaX

New Member
Ok, es funktioniert nun, aber leider nur für die genannten dinge wie ISPConfig, Phpmyadmin und Webmail.

Da ich gerne auch das Wordpress Admin Interface abgesichert haben möchte, habe ich in der
Code:
/etc/apache2/sites-enabled/000-default
folgendes eingetragen:
Code:
        <Directory /var/www/>
               DirectoryIndex index.html index.htm index.php
               AllowOverride Options AuthConfig
        </Directory>
Das bringt nur leider auch nichts, es erscheint weiterhin:
Code:
Fehlercode: ssl_error_rx_record_too_long
 

SyntaX

New Member
Schritt: 3.0 SSL Zertifikate hab ich auch schon gemacht. Funktioniert nicht. Er erstellt mir kein SSL Request.
 

Till

Administrator
Dann hast Du falsche Anagben im SSL Cert gemacht. Ändere sie und erstelle es erneut. Alst tipp, nimm keine Umlaute oder Sonderzeichen.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.