squirrelmail ispconfig3

Turrican72

New Member
Hallo,

ich wollte squirrelmail für alle Domains erreichbar machen. So nach dem Prinzip: http://domain.tld/mail. Ich habe mit der Suche gesehen dass es schon mehrere Probleme damit gegeben hat. Ich habe /usr/share/squirrelmail/config/apache.conf nach /etc/apache2/conf.d/squirrelmail.conf kopiert und die erste Zeile so angepasst:
Code:
Alias /mail /usr/share/squirrelmail
Leider führt das zu dem Nebeneffekt wenn ich http://domain.tld/mail aufrufe folgendes bekomme:
Code:
[B]Warning[/B]: Unknown: open_basedir restriction in effect. File(/usr/share/squirrelmail/index.php) is not within the allowed path(s): (/var/www/clients/client3/web5/web:/var/www/clients/client3/web5/tmp:/var/www/xxxxxxxxxx.de/web:/srv/www/xxxxxxxxxx.de/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in [B]Unknown[/B] on line [B]0[/B]

[B]Warning[/B]:  Unknown: failed to open stream: Operation not permitted in [B]Unknown[/B] on line [B]0[/B]

[B]Fatal error[/B]:  Unknown: Failed opening required '/usr/share/squirrelmail/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in [B]Unknown[/B] on line [B]0[/B]
Diese Probleme hatten wohl schon mehrere. Ich habe nur so Abhilfen gefunden wie die Webmail Software in eine eigene (Sub-)Domain zu packen. Das finde ich aber irgendwie recht unbefriedigend. Gibt es keine "normale" Lösung?

Ich mein mit "normal" wie es in einer normalen Webserver Installation funktioniert?

Gruß
Stefan
 

planet_fox

Super-Moderator
rein theretisch könntest du mal versuchen einen symlink zu machen oder eine weiterleitung sprich

squirrelmail liegt unter domän.local/mail

und unter domän2.local/mail in das Verzeichniss eine Weiterleitung machen.

ansonsten könntes es noch gehn das du einen symlink von squirrelmail in die domain verzeichnisse legst und diese mail nennst.

Bei der sache mit dem alias müsstest du denke ich bei jedem vhost die einstellung hinzufügen damit dies bei allen domains geht.

auch eine möglichkeit würde Url rewrite machen
 

Turrican72

New Member
also du meinst ln -s /usr/share/squirrelmail /var/www/clients/verzeichnisse/web/mail
das hab ich auch schon probiert, gleiches Ergebnis
 

Turrican72

New Member
Jo so hab ich das auch versucht. Ob ich es jetzt in die apache direktiven direkt eintrage oder eine extra Datei in die apache2/conf.d lege bleibt sich wohl gleich. Nur das letzteres praktischer Weise für alle Domains gelten.

Ändert aber nichts an dem Haupt-Problem dass die oben genannte FM erscheinen:
Code:
Warning: Unknown: open_basedir restriction in effect. File(/usr/share/squirrelmail/index.php) is not within the allowed path(s): (/var/www/clients/client3/web5/web:/var/www/clients/client3/web5/tmp:/var/www/xxxxxxxxxx.de/web:/srv/www/xxxxxxxxxx.de/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in Unknown on line 0

Warning:  Unknown: failed to open stream: Operation not permitted in Unknown on line 0

Fatal error:  Unknown: Failed opening required '/usr/share/squirrelmail/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0
Die gleiche Meldung erscheint auch wenn ich phpmyadmin aufrufen will.

Hat jemand eine Idee / Abhilfe?

Danke und Gruß
Stefan
 

planet_fox

Super-Moderator
Schau dir mal mein Howto zu ISPConfig3 und SSL an insbesondere den Ounkt Rewrite Url

Ich mein das sollte ein Lösungsansatz sein.
 

planet_fox

Super-Moderator
Versuch mal folgendes

Code:
RedirectPermanent /mail http://meinhost.de/webmail
RedirectPermanent /datenbank http://meinhost.de/phpmyadmin
Das musst du in die Apache Directiven Eintragen in ISPConfig3 bei den Domains.
 

planet_fox

Super-Moderator
Versuch mal folgendes

Code:
RedirectPermanent /mail http://meinhost.de/webmail
RedirectPermanent /datenbank http://meinhost.de/phpmyadmin
Das musst du in die Apache Directiven Eintragen in ISPConfig3 bei den Domains.
Vorher aber folgendes machen
ln -s /usr/share/squirrelmail /var/www/webmail
ln -s /usr/share/phpmyadmin /var/www/phpmyadmin
 

mascoxx

New Member
Warum verwendest du nicht das Default-Conf File von Squirrelmail und platzierst es unter /etc/apache2/conf.d???

Der Inhalt wäre dann:

Alias /mail /usr/share/squirrelmail
<Directory /usr/share/squirrelmail>
php_flag register_globals off
Options Indexes FollowSymLinks
<IfModule mod_dir.c>
DirectoryIndex index.php
</IfModule>
# access to configtest is limited by default to prevent information leak
<Files configtest.php>
order deny,allow
deny from all
allow from 127.0.0.1
</Files>
</Directory>
 

Mavo460

New Member
Moin,

auch ich wollte für meine vhost den Webmailer so einfach wie möglich einrichten. Also habe ich das von mascoxx beschriebene Standard File genommen, als squirrelmail.conf in das conf.d verzeichnis vom Apachen geschoben und mich gefreut als dann der Squirrelmail unter allen Domains aufrufbar war. Bis auf ISPConfig. Da konnte ich plötzlich keine E-Mail Einstellungen mehr vornehmen. Habe dann in dem Standard-File den Eintrag
Code:
Alias /mail /usr/share/squirrelmail
in
Code:
Alias /webmail /usr/share/squirrelmail
umbenannt und nun geht alles wie es soll :)

Grüße

Marco
 

Till

Administrator
Das geht aber nur solange Du auch in jedem Web php aktiviert hast und sweit ich weiß darfst Du dann auch kein suexec aktivieren. Suexec sollte man aber aus Sicherheitsgründen immer benutzen zusammen mit php-fcgi.
 

Till

Administrator
Das hat mit dem basis setup nichts zu tun. Suexec wird immer nur per webseite aktiviert oder deaktiviert.
 

oxygene

New Member
Hallo,

vielen Dank für den Tip mit der .conf im Apache Verzeichnis. Jetzt funktioniert das Webmail mit den Vhosts. (auch mit fcgi und suexec)

Gruß
Eike
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.