Spamassassin funktioniert nach Neuinstallation nicht mehr

iceget

Member
Hallo liebe ISPConfig Community,

ich habe erst vor zwei Tagen eine frische ISPConfig 2.2.38 Installation durchgeführt. Alles hat problemlos funktioniert, bis auf den Bug (hat Falko zum Bugtracker hinzugefügt) das ISPConfig nicht automatisch beim Systemstart mitstartet.

Ich habe alles auf Debian Squeeze installiert.

Und mein Problem ist das SPAMAssassin nicht funktionert, ...

Ich bekomm extrem viele Spammails, obwohl die Einstellungen von ISPConfig nicht verändert wurden (ISPConfig Datenbank wurde vom alten Server übernommen).

Auf die Ausgabe von If/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin kommt auch nichts zurück (also denk ich das alle Perl Module installiert/geladen wurden).

Wo kann ich nachschauen wo was schief läuft?

Vielen Dank!

glg Markus
 

iceget

Member
Hallo Till,

okay Fehler:
Can't locate LWP/UserAgent.pm in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.10.1 /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 81.
BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 81.

Wie kann ich diesen vermeiden bzw. wie kann ich das Problem lösen?

Das ist wahrscheinlich das Problem warum das nicht funktioniert, oder?

Danke
 

Till

Administrator
Das Perl Modul LWP/UserAgent.pm fehlt und muss nachinstalliert werden. Das gibt es bestimmt als Debian Paket, versuch mal:

apt-get install liblwp-useragent-determined-perl
 

iceget

Member
Re

Vielen Dank Till,

nun funktioniert der Aufruf, ist dies so korrekt?:

Anbei ein Screesnhot von PUTTY.

PS muss ich nun noch etwas aktivieren oder läuft das dann?

Vielen Dank!!
 

Anhänge

Till

Administrator
Das ist ok so. Du kannst jetzt nochmal mit:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint

testen. Wenn dort auch kein fehler ausgegeben wird, dann sollte spamassassin laufen.
 

iceget

Member
Re

Hallo Till,

danke hat perfekt funktioniert!

Ein Frage hätte ich da noch:
gibt es was besseres wie Spamassassin für einen gesamten Mailserver? Auch wenn's was kostet. Was verwendest Du auf den Hostingservern?

Danke und glg Markus
 

Till

Administrator
Nimm einfach ispconfig 3, da ist amavisd integriert. Amavisd sit ein daemon der unter anderem die spamassassin libraries intern verwendet.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.