SMTP server down

olma

New Member
Hi,
durch einen Fehler in courier-imap im aktuellen Debian-Release, welches Fehler beim Abrufen von eMails via IMAP beim Client hervorruft, habe ich versucht das Problem durch Installation von libgamin0 zu beheben. Dadurch wird aber das zuvor installierte libfam0 ersetzt. Seit dem wird der SMTP-Server als "down" angezeigt, was aber nicht stimmt. Der eMail-Transport funktioniert einwandfrei. Wie kann ich das fixen?

Vielen Dank!
 

olma

New Member
Bidde schön:

Code:
tcp        0      0 domains.webhostin:ssmtp *:*                     LISTEN    716/master
tcp        0      0 domains.webhosting:smtp *:*                     LISTEN      716/master
 

Till

Administrator
Postfix muss auch auf "localhost" erreichbar sein, also der IP 127.0.0.1 lauschen. Vermutlich hast Du den Postfix Prozess zur Zeit nur auf die externe IP gebunden.

Oder aber der Eintrag für localhost in /etc/hosts ist falsch.
 

olma

New Member
Hmmmm, ersma vielen Dank für die schnelle Antwort.

Also die hosts enthält:
Code:
127.0.0.1 localhost.localdomain localhost
82.21x.xx.xx host.meinedomain.tld host
und in der main.cf ist
Code:
mydestination=host.meinedomain.tld, host, localhost.localdomain, localhost
mynetworks=127.0.0.0/8 [::1]/128
inet_interface=all
eingetragen.

Habe ich irgendwo was übersehen?
 

Till

Administrator
Das ist soweit ok. Hast Du vielleicht die postfix IP mit smtp_bind_address in der main.cf gesetzt oder die IP in der master.cf für smtp festgelegt?
 

olma

New Member
Also smtp_bind_address habe ich nicht in der main.cf.

Dafür habe ich aber das Folgende in der master.cf gefunden:

Code:
127.0.0.1:10025 inet n - - - - smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks=127.0.0.0/8
        -o strict_rfc821_envelopes=yes
        -o receive_override_options=no_unknown_recipient_checks,no_header_body_$
        -o smtpd_bind_address=127.0.0.1
Sagtest Du Eingangs nicht, das Postfix auch local lauschen muss?
Irgendwie blicke ich's nicht wirklich.
 

olma

New Member
Ich hab's nicht hingekriegt.
Habe einfach meinen Server neu aufgesetzt. Das soll ja üben... ;)

Trotzdem "Dank!" für Deine Hilfe!
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.