PHP5.2 und PHP5.3 Parallel

tuxie

Member
Hallo alle zusammen,

ich habe ein kleines Problemschen.

Nachh dem update von Debian 5 auf Debian 6 ist nun auch PHP5.3 im einsatz, leider gibt es einige Shopsoftwareversionen die noch nicht mit 5.3 laufen. Ich habe um das Porblem zu lösen einfach php5.2 parallel noch mit geändert und lasse das Web als fastcgi laufen. Ich änder dann nur noch die entsprechende Starterdatei des entsprechenden Webs.

*.php-fcgi-starter

Gibt es eine möglichkeit, zwei dieser Config Dateien Parallel aufzusetzen und diese dann im ISPConfig man auswählen kann.

Unter dem Punkt PHP
Fast-CGI 5.2
Fast-CGI 5.3

Ist der aufwand sehr hoch da was einzubauen?

Viele Grüße

Ingo
 

Falcon37

New Member
Habe genau das gleiche Problem und bis heute leider auch keine Lösung gefunden... Wenn ich etwas weiß poste ich es hier, denke das ich in circa einer Woche was hab.
 

tuxie

Member
ja und?

Php52 und PHP53 habe ich doch schon lange Parallel laufen! Das problem ist die Integration ins ISPconfig ohne das man immer Hand anlegen muss.
 

BHD84

New Member
http://www.howtoforge.de/forum/26309-post2.html

Ich persönlich habe es dadurch gelöst, das ich mir nen kleines script für die shell geschrieben habe, wo ich nur noch webID, clientID und domain eintragen muss und er dann alles weitere erledigt. Und dann halt noch in der Webseitenverwaltung Apache Direktiven das nötige eingetragen.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.