Perfect Server Debian 5 Tutorial: lokal installiert http://127.0.0.1 n. erreichbar

pee

New Member
Du kannst Dich wo nicht einloggen? Der ISPConfig Login ist unabhängig von der IP.
Ich kann mich nicht im Administrationsbereich von ISP Config einloggen. Nach der Installation von ISP Config habe ich die ISP Config Datenbank gelöscht und anschließend die ISPC-Datenbank vom Server-Backup eingespielt. Daraufhin konnte ich mich einloggen. Nach einem Rechner-Neustart allerdings nicht mehr.

Ich erhalte nach der Eingabe der Zugangsdaten folgende Meldung:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73
 

Till

Administrator
Das sieht mir eher danach aus, als ob Du auch die "mysql" datenbank überschriebn hast und nicht nur die ISPConfig Datenbank. Denn das was da nicht geht, ist das der mysql User "ispconfig" in der Tabelle "users" der "mysql" datenbank überschrieben wurde.

Um das zu beheben, lade das ispconfig tar.gz runter, ruf das update.php script auf und wähle während des updates dass die Dienste rekonfiguriert werden sollen.
 

pee

New Member
Scheinbar kann ich nun nicht die MySQL-Datenbank neu installieren. Denn als ich die Dienste rekonfigurieren wollte, bekam ISP Config keinen Zugang dazu.

Als ich die Meldung las, dass MySQL nicht beendet werden kann, habe ich mit

die MySQL-Ordner festgestellt und diese daraufhin gelöscht. Anschließend die VM neugestartet. Als ich dann MySQL neu installieren wollte, bekam ich folgende Meldungen:

debian:/home/debian# apt-get --purge remove mysql-server && apt-get --purge remove mysql-server-5.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libsilc-1.1-2 libhtml-template-perl mysql-server-5.0
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
mysql-server*
0 upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
2 not fully installed or removed.
After this operation, 90.1kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 111554 files and directories currently installed.)
Removing mysql-server ...
Setting up mysql-server-5.0 (5.0.51a-24+lenny4) ...
Stopping MySQL database server: mysqld.
/var/lib/dpkg/info/mysql-server-5.0.postinst: line 144: /etc/mysql/conf.d/old_passwords.cnf: No such file or directory
dpkg: error processing mysql-server-5.0 (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
mysql-server-5.0
Bekomme ich jetzt MySQL nicht ohne Neuinstallation des gesamten Systems sauber drauf? Und falls ich das gesamte System neu installieren muss, welche Ordner aus dem /etc- und /var-Ordner darf man nicht überschreiben, wenn man den Server "klonen" möchte?
 

Till

Administrator
Das Löschen der Ordner war keine so gute Idee. Soweit ich weiß kannst Du mysql jetzt noicht ohne weiteres neu installieren.

Und falls ich das gesamte System neu installieren muss, welche Ordner aus dem /etc- und /var-Ordner darf man nicht überschreiben, wenn man den Server "klonen" möchte?
Du solltest da nichts komplett überschreiben, sondern nur selektiv die Daten migrieren. Schau mal hier:

http://www.howtoforge.com/forums/showthread.php?t=42579
 

pee

New Member
1) Install ispconfug 3 on the debian server. It has to be the same version then on the old server.
2) copy all lines of the web* users from /etc/passwd and /etc/shadow to the new server.
3) copy all lines of the client* groups from /etc/group and /etc/gshadow to the new server.
4) Move the directories /var/www and /var/vmail to the new server (with preserved permissions).
5) copy the ispconfig database to the new server.
6) copy the website databases to the new server. Then copy the user and db entrys for the client databases from the mysql.dser and mysql.db database tables to the new system.
In der user-Tabelle der Datenbank, welche "mysql" heißt, besteht bereits der ispconfig-user nach der Installation von ISPConfig. Ich habe diesen gelöscht und den user von meinem server-backup importiert. Anschließend kam beim Login-Versuch die Meldung

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ispconfig'@'localhost' (using password: YES) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 73
Als ich dann ISPConfig (selbe Version wie bisher) heruntergeladen und das Update-Skript mit dem Rekonfigurieren der Dienste ausgeführt habe, habe ich das Gast System neu gestartet. Dann schlug jedoch der erneute Login-Versuch mit der selbigen Meldung wie oben fehl. Woran kann das liegen - und wichtiger: wie kann man diesen Fehler beheben?
 

pee

New Member
Also ich habe nun den Server nochmal neu installiert. Es wird wohl daran gelegen haben, dass ich nicht nur die Web-User, sondern auch die SSH-user etc. in den Config-Files rüberkopiert und in der mysql-Datenbank den bestehenden "ispconfig-user" gelöscht habe.

Jetzt kann ich mich jedenfalls in ISPC einloggen und die Datensätze ansehen. Ich komme allerdings bezgl. dem Testen einer Website nicht weiter. Unter

habe ich die Netzwerk-IP eingetragen, die ich mit

herausgefunden habe:

debian:/home/debian# ifconfig
eth1 Link encap:Ethernet HWaddr 08:00:27:c7:e3:ab
inet addr:10.0.2.15 Bcast:10.0.2.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fec7:e3ab/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:126 errors:0 dropped:0 overruns:0 frame:0
TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:12871 (12.5 KiB) TX bytes:17210 (16.8 KiB)
Interrupt:10 Base address:0xd020
Also die 10.0.2.15. Diese IP-Nummer habe ich auch mit der Broadcast-Adresse (oben Bcast) in /etc/network/interfaces eingetragen:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

iface eth0 inet dhcp
address 10.0.2.15
netmask 255.255.255.0
broadcast 10.0.2.255
Anschließend habe ich die hosts-Datei geändert, wie mir in diesem Thread vorgeschlagen wurde um die Domain lokal zu erreichen:

127.0.0.1 localhost
127.0.1.1 debian
10.0.2.15 TESTDOMAIN.TLD
Wenn ich jetzt allerdings die TESTDOMAIN.TLD im Browser eingebe, lädt der Browser nie fertig. Auch localhost lädt nie fertig. Was habe ich falsch gemacht?

Bedanke mich schonmal für Eure Aufmerksamkeit und warte selbstverständlich gespannt auf Eure Antwort.
 

Laubie

Member
Hi pee.
Kann es sein, dass du VirtualBox nutzt?
Ich hab meine mit der Einstellung "Netzwerkbrücke" eingerichtet. So bekommt der Server eine IP aus deiner normalen IP-Range.

Wieso versuchst du nicht mal von einem anderen Rechner im Netz bzw. von dem Host auf den Server zuzugreifen?

Grüße
Laubie
 

pee

New Member
Hi pee.
Kann es sein, dass du VirtualBox nutzt?
Ja, ich nutze VirtualBox unter Ubuntu. Der Guest ist Debian 5.

Wieso versuchst du nicht mal von einem anderen Rechner im Netz bzw. von dem Host auf den Server zuzugreifen?
Warum sollte ich? Ich will einfach nur testen, ob die Websites im geklonten Server funktionieren. Wieso greift das mit den IP-Einstellungen nicht? Wenn ich DOMAINNAME.TPL in die hosts-Datei mit der Server IP-Eintrage, sollte ja die Eingabe der Domain im Gast auf die Website lenken, die auf dem Testserver ist. Warum haut das nicht hin?
 

Laubie

Member
Hi Pee,

ich kenn mich nicht sooo gut aus mit dem Apache und wie er die vhosts versteht,
aber für normal hat man ja auf nem Webserver kein Desktop.
Ich würde es mal vom Host probieren. Zur Not auch mit der IP des Gastes.
Erst wenn diese funktioniert (it works, oder erstes Web) dann kannst du versuchen die hosts-datei anzupassen.

Grüße Laubie
 

pee

New Member
Till, kannst Du Dich bitte auch nochmal kurz dazu äußern? Ich schreibe ja aus Dankbarkeit eine Beschreibung zu diesem Thema ins ispc-wiki, wenn das geklappt hat.
 

Till

Administrator
Dein Problem scheint mir eher mit dem von die gewählten Setup mit virtualbox als mit ISPConfig zusammen zu hängen. Bring also erstmal Dein Netzwerk setup in Ordnung.

1) Deine VM muss auf briding eingestellt sein.
2) Deine VM benötigt eine IP-Adresse aus Deinem lokalen Netz.
3) Du konfigurierst die Netzwerkkarte in Deiner VM, dass sie auf dieser IP lauscht.
3) Jetzt testest Du, ob das alles auch wirklich funktioniert. Du musst also z.B. bei der Eingabe der IP die "It works" Seite des apache erreichen und Dich über die IP auch mit SSH mit der VM verbinden können.

Wenn das alles funktioniert, dann migrierst Du das setup wie ich es beschrieben habe.

Dein Setup ist inzwischen vermutlich auch schon recht verbastelt, also ggf. nochmal neu aufsetzen und bevore Du ispconfig migrierst sicherstellen, dass die VM auch von extren per netzwerk erreichbar ist.
 

pee

New Member
In den Einstellungen von Virtualbox habe ich jetzt die Netzwerkbrücke-Option aktiviert. Damit kann ich mit der IP des Gastes auf dessen ISPC-Adminpanel zugreifen. Zudem habe ich in die /etc/hosts meines Hosts folgendes eingetragen:

Code:
GAST-IP                   testdomain.de
Wenn ich allerdings testdomain.de im Browser meines Hosts eingebe, so sehe ich nur die "it works!"-Seite vom Apache meines Gastes.
 

Laubie

Member
das hört sich doch schon mal sehr gut an ;)

Jetzt müssen wir nur raus finden, warum der vhost nicht erkannt wird.
Schau noch mal, ob du in deinem ISPConfig auch diese IP eingerichtet hast, und dass die IP der Seite auch damit übereinstimmt.

Grüße
Laubie
 

pee

New Member
Die IP ist in ISPC eingerichtet:


Auch habe ich die IP bei der entsprechenden Domain eingetragen:


Leider kommt weiterhin nur die "it works"-Seite beim Aufruf der Domain.
 

pee

New Member
Unter welchem Pfad finde ich die entsprechende Vhost-Datei? Nur damit ich hierbei sicher gehen kann.
 

Till

Administrator
Das hängt von der verwendetn Linux Distribution ab, bei Debian und Ubuntu ist es /etc/apache2/sites-enabled/
 

pee

New Member
Das hängt von der verwendetn Linux Distribution ab, bei Debian und Ubuntu ist es /etc/apache2/sites-enabled/
Komisch, wenn ich die IP des Gastes im Host-Browser eingebe, öffnet sich meine Testseite so, wie ich es mit der Eingabe der Domain wünschen würde. Wenn ich die Domain eingebe, öffnet sich allerdings nur die "it works"-Seite vom Apache.

Die IP steht in der Vhost-Datei unter /etc/apache2/sites-enabled/:

Code:
<Directory /var/www/test.de>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost 192.168.178.27:80>
      DocumentRoot /var/www/test.de/web
  
    ServerName test.de
    ServerAlias *.test.de 
    ServerAlias blog.test.de 
    ServerAlias pma.test.de 
    ServerAlias webmail.test.de
    ServerAdmin webmaster@test.de

    ErrorLog /var/log/ispconfig/httpd/test.de/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html
    
    <Directory /var/www/test.de/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client2/web3/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@test.de"    
    php_admin_value upload_tmp_dir /var/www/clients/client2/web3/tmp
    php_admin_value session.save_path /var/www/clients/client2/web3/tmp
    php_admin_value open_basedir /var/www/clients/client[client_id]/web3/web:/var/www/clients/client[client_id]/web3/tmp:/var/www/test.de/web:/srv/www/test.de/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin
    
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^blog.test.de [NC]
    RewriteRule   ^/(.*)$ http://test.de$1  [R]
    RewriteCond %{HTTP_HOST}   ^pma.test.de [NC]
    RewriteRule   ^/(.*)$ http://server-adresse.de:8080/pma$1  [R,L]
    RewriteCond %{HTTP_HOST}   ^webmail.test.de [NC]
    RewriteRule   ^/(.*)$ http://server-adresse.de:8080/webmail$1  [R,L]

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web3 client2
    </IfModule>


</VirtualHost>
 

Till

Administrator
Deine Auswahl der Auto Subdomain macht keinen Sinn. Man sollte nie * nehmen, außer du hast ein CMS wie die Mu Variante von Wordpress darin installiert. Denn wenn man autosubdomain * nimmt, darf es keine weiteren Subdomains geben, sonst kann der Apache die Domains nicht mehr richtig zuordnen. Also autosubdomain immer auf www stellen.

Des weiteren nochmal prüfen, ob die Domain und IP wirklich korrekt sind und zusammen passen. Tippfehler suchen!
 

Werbung

Top