Perfect Server Debian 5 Tutorial: lokal installiert http://127.0.0.1 n. erreichbar

Laubie

Member
ach, und schau mal im ISP-Panel, welche IP du für die domein geileseite.de eingestellt hast.
Wenn da nicht 127.0.0.1 steht, dann kann der apache den vhost auch nich zuordnen.
oder eben die lokale ip des gasts angeben.
(muss halt mit der in der hosts-datei übereinstimmen)

Grüße
Laubie
 

pee

New Member
Klar kannst du mydns / bind jederzeit nachinstallieren.
Redest du bisher von nem Multiserver ISPCONFIG Setup wo einer der Server nen DNS Server ist und den willst du nun auf den Hauptserver nehmen.
Oder redest du von nem grundsätzlich anderen DNS Server ?
Ich habe ein Backup von meinem Server-Rechner (laut der Anleitung von ispc-wiki.org) gemacht, der die Websites bereitstellt. Dieser Server-Rechner nutzt einen externen DNS-Server vom Betreiber der Rechenzentrums.

Kann ich jetzt, auf der virtuellen Maschine, wo ich das Backup des Server-Rechners "ohne DNS Server" eingespielt habe, MyDNS einfach so nachinstallieren wie es unter http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3 beschrieben ist und anschließend die hosts-Datei editieren? Oder brauche ich weitere Konfigurationen, weil ja der "Mutter-Server" mit externem DNS Server lief?

Hoffe ich habe mich nun gut verständlich ausgedrückt. :)
 

Burge

Member
Dein produktiv Server hatte doch mit sicherheit im ispconfig ne andere ip eingetragen als 127.0.0.1. Wenn du alles zurück gesichert hast dann musst das auch anpassen sonst steht in der vhost datein doch drin alte_ip:80 und da kann sich auch ne hostdatei dumm und dämlich suchen. Und wenn du das lokal betreibst brauchst du auch kein dns server.

check die Ip gegebenfalls das was in der vhost drin steht editiere das richtig stell sicher das die domain in der hostdatei drin steht und dann geht das auch.
 

pee

New Member
Dein produktiv Server hatte doch mit sicherheit im ispconfig ne andere ip eingetragen als 127.0.0.1. Wenn du alles zurück gesichert hast dann musst das auch anpassen sonst steht in der vhost datein doch drin alte_ip:80 und da kann sich auch ne hostdatei dumm und dämlich suchen. Und wenn du das lokal betreibst brauchst du auch kein dns server.

check die Ip gegebenfalls das was in der vhost drin steht editiere das richtig stell sicher das die domain in der hostdatei drin steht und dann geht das auch.
Ich habe jetzt im ISPC-Administrationsbereich (auf dem lokal zurückgespielen Backup) Einstellungen an folgenden Orten vorgenommen, deren Einstellungen ihr auf den Screenshots seht.

Serverkonfiguration:


Web Domain Konfiguration:


Server IP bearbeiten:


Zudem steht in meiner hosts-Datei eine Zeile mit

Code:
127.0.0.1        MEINE-TESTDOMAIN.DE # = Platzhalter für die echte Domain
Danach habe ich den Apache neu gestartet. Trotzdem kann ich die Testdomain nicht aufrufen, wenn ich sie auf dem Testsystem in die Browseradressleiste eingebe.

Hoffe mir spendet jemand Rat - sobald ich weiß wie man das Backup konkret testet, füge ich meine Vorgehensweise ins ISPC Wiki unter ispc-wiki.org hinzu.

HAND
 

pee

New Member
Nachdem ich den VirtualBox-Gast neu gestartet habe, funktioniert mein Passwort nicht mehr. Folgender Bildschirm erscheint:


Dabei bin ich lediglich ganz genauso vorgegangen, wie auf http://ispc-wiki.org/ispconfig3-anleitung#backup_zuruecksichern

1., Debian mit ISP Config laut dem Howtoforge Tut installiert
2., etc- und var-Ordner aus dem Backup entpackt
3., ISP Config Datenbank gelöscht und alle Datenbanken vom Serversystem importiert (natürlich einschließlich der ISPC-Datenbank vom produktiven Server)

Anschließend konnte ich mich im ISP Config einloggen und alle Daten so sehen, wie sie auf dem produktiven Server sind. Nach dem Neustart des Rechners geht allerdings der Login nicht mehr und wenn ich meine Domain testweise aufrufe, kommt eine Seite mit folgender Meldung:

Forbidden

You don't have permission to access / on this server
 

Laubie

Member
ich würde vermuten, das hängt mit der 127.0.0.1-Geschichte zusammen.
Das ist ja immer die loopback-ip.
Nimm doch mal testweise die ip deines Gastes. also 192.168.0.irgendwas.
Damit funktioniert mein Testsystem hier zuhause schon ewig...

Grüße
Laubie
 

Laubie

Member
Gib deinem Server (also erstes Bild) die feste IP,
dann unter Server-IP bearbeiten auch eintragen.
Und natürlihc in der Seite auch diese IP auswählen.

Zuletzt noch in der hosts datei entsprechend ändern.

Dann nochmal probieren ;)
 

pee

New Member
Also ich soll statt der lokalen IP 127.0.0.1 die Netzwerk-IP des Gastes in die hosts-Datei eintragen?

Zudem habe ich eben auch noch das Problem, dass ich mich mit meinem Passwort nicht mehr bei ISP Config einloggen kann. Ich habe nach der Installation von ISP Config die Datenbank gelöscht und dann die Datenbank vom produktiven Server eingespielt. Anschließend ging der Login. Nur leider nicht mehr nach dem Neustart des Gastes. Vielleicht hängt das auch mit dem Überschreiben der Dateien in /etc und /var zusammen. Das habe ich nach dem Einspielen der Datenbank getan.

Doch Till meinte hier unter http://www.howtoforge.de/forum/showthread.php?t=2774, dass die Vorgehensweise so richtig wäre. Wundert mich also stark, dass das Einspielen eines Backups bei Euch so problemlos funktioniert und bei mir plötzlich nicht. Obwohl ich laut der Doku vorgegangen bin. Zudem habe ich ISP Config das zweite Mal im Gast von Grund auf (selbst das Debian Lenny) neu installiert. Und wieder kann ich mich nach dem Neustart nicht einloggen.

So far..
 

pee

New Member
so funktioniert es bei mir.
Der Gast hat dank Netzwerkbrücke die IP 192.168.1.4
Das hat den Vorteil, dass alle Rechner im Netzwerk auf den Server zugreifen können.

Grüße
Laubie
Laubie, hast Du ein Backup eines bestehenden produktiven Servers auf den Gast rückgesichert oder ISP Config für ein Intranet benutzt?

Ich habe keine Ahnung was ich tun soll. Denn selbst wenn ich die IP ändere, kann ich mich ja trotzdem nicht im ISPC Adminpanel einloggen, nachdem ich den Gast neu gestartet habe.

Wäre dankbar, wenn mir hier jemand einen Wissensschubser verpassen würde. Dann setze ich nämlich meine Erkenntnisse ins ISPC-Wiki.
 

Laubie

Member
Nein, ein Backup habe ich nicht zurückgespielt...
Also was das angeht, müssen andere tipps geben ;)

Ich habe meinen "produktiv-server" 1-zu-1 auch bei mir zu Hause nachgebaut, in einer VM.

Grüße Laubie
 

pee

New Member
Wenn ich ISP Config einfach nur installiere, dann klappt es ja. Aber händisch alle Clients nachtragen, wäre doch zuviel des guten. Schade das das scheinbar nicht so einfach ist.
 

Laubie

Member
kann mir eigentlich nicht vorsetllen, dass das nicht möglich ist.
Ich denke nur, du hast dich da mit den Einstellungen für die IP und den Servernamen etwas verhaspelt.

Denke nicht, dass es gut ist, nen server "localhost" zu nennen.
Und die 127.0.0.1 fand ich auch nich sooo gut ;)

nimm doch mal für den localhost nen namen wie server1.zuhause.loc oder so
 

Laubie

Member
puh... keine ahnung. dafür kenn ich mich bei linux zu wenig aus.
Ich bin mir aber fast sicher, dass diese 127.0.0.1 und localhost reservierte namen/ips sind.

und wenn du diese dann (mit was anderem) belegst... kann aber auch sein, dass ich mich total irre... vielleicht hat hier ja jemand mehr ahnung...
 

Till

Administrator
Da ich hier schon recht lange auf eine diesbezügliche Antwort warte, ist dies scheinbar nicht der Fall. Bin ich hier der einzige, der den Test eines ISP Config Backups laut Doku anstrebt? :confused:
Das ist aber nicht das, was Du gerade machst. Ein backup dient der Wiederherstellung des ursprünglichen Zustands. was Du im Moment machst, ist einen Server zu klonen um ihn dann unter einer anderen konfiguration / IP laufen zu lassen.

Einen Server zu klonen geht auch ohne weiters, Du musst halt nur die IP Adressen in den Netzwerkeinstellungen, in ispconfig unter system und in den Website settings ändern. Als IP kannst Du nicht 127.0.0.1 nehmen, das ist das loopback device. Du musst da schon eine reichtige an die externe Netzwerkkarte gebundene IP nehmen, also enteweder eine offizielle IP vom RIPE wenn es ein Server im Rechenzentrum ist oder aber eine interne IP wie 129.168.0.123 welche aus deinem lokalen netz stammt.
 

Till

Administrator
Nein, 2 Stellen. In Deinen Netzwerk Einstellungen (das ist je nach Linuxdistribution unterschiedlich, bei debian und Ubuntu ist es /etc/network/interfaces) und in ISPConfig unter system > server IP.

Offenbar kann ich mich also wegen der IP-Editierung, die ich bisher durchgeführt habe, nicht einloggen. Wie kann ich jetzt ISPConfig neu installieren?
Du kannst Dich wo nicht einloggen? Der ISPConfig Login ist unabhängig von der IP.
 

Werbung

Top