Outlook 365, ISP Config & Letsencrypt

#1
Folgendes Setup:
Isp Config 3.1 Installation mit Zertifikat (https://www.howtoforge.com/tutorial/securing-ispconfig-3-with-a-free-lets-encrypt-ssl-certificate/)
Outlook365

Einrichtung der Mail Konten im Outlook 365 funktiort super, allerdings wird bei jedem Start von Outlook für jedes Mailkonto ein Zertifikatsfehler angezeigt. Der Fehler lautet immer das der Prinzipialname falsch ist. Ich denke das beruht darauf, dass der Mailserver (dovercot) das Zertifikat der ISP Config Installtion nutzt, aber die Domain die Outlook verwendet ist, ja die des Domain Account ist. Gibt es hier Abhilfe? Früher konnte man ja, den Mailserver ändern, aber mit dem neuen Outlook geht das ja nicht mehr.
 
#2
Das selbe Problem habe ich auch. Ich probiere gerade mit autodiscover herum. Klappt aber noch nicht so ganz. Die autodiscover.xml wird von Outlook zwar gefunden aber er nimmt immer noch den falschen Mailservernamen.
 

nowayback

Well-Known Member
#3
Ich habe keine Probleme damit...

Ich habe eine Verwaltungsdomain, z.B: example.com
Die Kundendomains erhalten als MX Eintrag: mail.example.com

mail.example.com habe ich als Domain im ISPConfig angelegt und via LE ein Zertifikat verpassen lassen. Danach habe ich nur noch die im Postfix angegebenen Symlinks auf die Zertifikate von mail.example.com geändert.

So gab es bisher keine Probleme mit der Einrichtung von Konten - auch nicht Office 365.
 
#4
Ich habe keine Probleme damit...

Ich habe eine Verwaltungsdomain, z.B: example.com
Die Kundendomains erhalten als MX Eintrag: mail.example.com

mail.example.com habe ich als Domain im ISPConfig angelegt und via LE ein Zertifikat verpassen lassen. Danach habe ich nur noch die im Postfix angegebenen Symlinks auf die Zertifikate von mail.example.com geändert.

So gab es bisher keine Probleme mit der Einrichtung von Konten - auch nicht Office 365.
Also setzt du für jede Domain den DNS Eintrag für die MX manuell auf deine Verwaltungsdomain? Bei entsprechend hoher Anzahl der Domains eine nette Aufgabe. Vor allem bei einem schrottreifen Domain Robot.
 

Till

Administrator
#5
Also setzt du für jede Domain den DNS Eintrag für die MX manuell auf deine Verwaltungsdomain? Bei entsprechend hoher Anzahl der Domains eine nette Aufgabe. Vor allem bei einem schrottreifen Domain Robot.
Ändern musst Du ja nur etwas, wenn es vorher falsch eingetragen wurde. Ich setze schon immer den MX Eintrag aller Domains auf den Hostnamen des zuständigen Mail servers, ist an sich die einzig sinnvolle Option wegen SSL. Habe das bei mir auch im DNS template des DNS Wizard entsprecehnd hinterlegt.
 
#6
Also ich hätte eigentlich schon gerne, dass die Kunden ihre eigene Domain als Mailserver Adresse nutzen können. Aber okay, wenn es nicht anders geht.

Damit ich das auch richtig verstanden habe:
Aktuell ist meine Verwaltungsdowmain: isp3.xxx.de
Könnte ich hier jetzt eine Aliasdomain anlegen, welche mail.xxx.de lautet?
Anmerkung: xxxx.de ist auch als Domain im Einsatz.

Bei meinem Domainsetup sieht es aktuell so aus, dass der mx Eintrag auf: 10 mail lautet
mail hat dann einen Eintrag auf die IP des Server.

Vorausgesetzt meine Konifguration ist korrekt, dann würde ich nur den MX Eintrag auf mail.xxx.de ändern und alles würde funktionieren? Oder auf 10 mail.xxx.de ?
 

nowayback

Well-Known Member
#7
10 ist doch nur die "prio". wenn xxx.de deine domain ist unter der du z.b. deine angebote anbietest und isp3.xxx.de für das ispconfig webinterface ist, dann würde ich entweder mail.xxx.de oder mx.xxx.de als mx record setzen. dann natürlich für mail oder mx noch einen a eintrag auf die ip des servers und fertig.
 
#9
Das zweite Thema ist, dass man neuerdings in Outlook die Einstellungen von IMAP und POP3 Postfächern nicht mehr bearbeiten kann.
Unter folgendem Registry Schlüssel:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\setup\
einen DWORD (32-bit) Eintrag mit folgendem Namen erzeugen
DisableOffice365SimplifiedAccountCreation und den Wert auf 1 setzen um ihn zu aktivieren, nach einem Neustart erscheint wieder der alte Assistent und die Einrichtung sollte funktionieren.

Aber erkläre das mal Deinen Anwendern. Im Prinzip ist die Simplifizierung ja auch eine gute Sache.

Ich habe die DNS Einträge wie von Nowayback angedacht jetzt umgesetzt und die User informiert.
Jetzt heißt es abwarten.

Vielen Dank schon mal.
 
Zuletzt bearbeitet:
#10
Also das funktioniert leider nicht. MX DNS lookup funktioniert prima. Also mx eintrag für kundendomain.de zeigt auf mail.verwaltungsdomain.de.

Aber beim Einrichten einer Mail wird als Posteingangserver weiterhin: imap.kundendomain.de und als Post Ausgangsserver smtpauths.kundendomain.de verwendet. Womit ich auf dem Zertifikatsfehler sitzen bleibe.

Wo liegt mein Fehler?
 
#12
Jap, dann geht alles ohne Probleme. Das Zertifikat und die Konfiguration funktionieren an sich also. Nur die automatische Einrichtung sämtlicher E-Mail Client schlägt fehl.
 
#13
Ich habe jetzt einmal Aliasdomains für imap.kundendomain.de und smtpauths.kundendomain.de für die verwaltungsdomain angelegt. Keine Probleme mehr. Allerdings macht mich die Lösung ziemlich unglücklich und zumal das limit von letsencrypt ja irgendwo zwischen 25 und 100 Domains liegen sollte.
 

Werbung

Top