Nach Update von Debian 9 auf 10 wird php im Verzeichnis phpmyadmin nicht aufgeführt

katasun

Member
Guten Tag,

vor einigen Tagen habe ich Debian 9 mit ISPConfig auf Debian 10 aktualisiert. Das lief nach den bestehenden Anleitungen ohne Fehlermeldungen durch. Es gibt als keine Fehlermeldungen in der Benutzung und auch nicht in ISPConfig.

Allerding habe ich auch PHPMyAdmin aktualisiert. Nach dieser Anleitung https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/
Vor dem Update von PhpMyAdmin und auch danach wird php nicht im Verzeichnis /usr/share/phpmyadmin ausgeführt.

Da kommt dann sowas wie :: <?php phpinfo(); ?> anstatt der Infos. Das ist ein Konfigurationsproblem in einem der Apache Directiven. PHP habe ich auf php7.3 aktualisiert und über php -v wird mir das auch in der Konsole bestätigt. Im Verzeichnis /usr/share/phpmyadmin/ aufgerufen.

Wer kann mir denn einen Tipp geben, wo ich suchen muss oder wie man nach diesem Problem an besten sucht. Vielen Dank.

Katasun
 

Till

Administrator
PHPMyAdmin wird an sich über den PHP default Handler von Debian ausgeführt, hast Du mod_php installiert und funktioniert es? Falls Du einen anderen Apache mpm installiert hast wegen http/2 und daher kein mod_php hast, dann musst Du z.B. php-fpm als standard aktivieren (nicht in ISPConfig, sondern in Debian selbst).
 

logifech

Member
Es gibt auch Standardmäsig eine Fallback Config die mit PHP-FPM kommt. Diese bewirkt, dass alles was normalerweise über mod_php ausgeführt wird über FPM läuft wenn mod_php nicht zur Verfügung steht. Zu finden ist die config unter /etc/apache2/conf-available/, weiß grad nicht genau wie die heißt irgendwas mit FPM im Namen lässt sich dann ganz einfach mit a2enconf aktivieren.
 

katasun

Member
Vielen Dank für die Hilfe,
die Antwort von Strontium funktioniert bei mir, wenn ich phpmyadmin in einer Website installiere, die durch ispconfig verwaltet wird.

Mein Problem sind die Einstellungen des Apache auf Debian Ebene. Ich werde mal die Vorschläge von Till und logifech testen. Blöderweise sind da Seiten auf dem Server live und es klappt ja nicht immer alles.

Wenn ich das wieder am laufen habe, melde ich mich. Wahrscheinlich werde ich mal ein Testsystem aufsetzen und dann die Einstellungen vergleichen. Vielen Dank, vorab habe ich phpmyadmin in einer Webseite mitinstalliert, was sofort ohne jegliche Probleme funktionierte.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.