Mailpasswörter mit Sonderzeichen

wemaflo

New Member
Hallo!

Ich habe gestern einen neuen Server (debian) mit ISPConfig aufgesetzt, als Mailserver nutze ich Dovecot. Ich bin bei der Installation nach dem Handbuch vorgegangen.

Nun habe ich ein Problem mit den Passwörtern der E-Mail-Konten: Ich kann sie nach Belieben anlegen, allerdings funktionieren sie nur, wenn keine Sonderzeichen enthalten.

Alle anderen Dienste (MySQL, pure-ftpd) funktionieren problemlos mit allen Passwörtern.

Woran kann das liegen?

Danke schonmal :)
 

Till

Administrator
Die Passwort Routine sind auf ISPConfig Seite für alle Passworte die selbe (crypt + salt). Um welche Sonderzeichen geht es denn?
 

wemaflo

New Member
Hi Till, danke für deine schnelle Antwort!

Ich poste einfach mal ein Beispielpasswort:
6Kt&0345UPLM!OLqG$W%65hFK%übI?VYZUcBN1*pLTH&LÜCgai7N%WhslqNo&Rf

Edit: das Forum zeigt da ein Leerzeichen an, eigentlich ist da natürlich keins.
 

Till

Administrator
Es kann sein dass das Passwort einfach zu lang ist. Nicht für ispconfig sondern für eine Komponenten des Mailsystms (postfix/sassl/dovecot/courier-authdaemon). Versuch mal ein kürzeres Passwort.
 

wemaflo

New Member
Daran dachte ich auch schon, trifft aber nicht zu.
Folgendes Passwort funktioniert nicht:
vRi&sTIbPOU54k%sä$h2oÖf%

Dieses funktioniert aber:
abcdefghijklmnopqrstuvwx

Beide haben 24 Zeichen.
 

Till

Administrator
Ok, ich hab es mal in den Bugtracker aufgenommen. Es betrifft auch nur einige Sonderzeichen, nicht alle & geht z.B. während % nicht geht.
 

wemaflo

New Member
Hallo, sorry fürs pushen, ich wollte nur mal nachfragen, ob die Änderung im letzten Update schon eingepflegt wurde. Im Bugtracker finde ich den Fehler nicht mehr, funktionieren tut es allerdings trotzdem nicht.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.