Keine Änderungen an Webseiten möglich

rokale

New Member
Wenn ich in der Weboberfläche von ISPconfig eine neuen Webseiten für einen Kunden anlege, erscheint sie zwar unter /var/www/clients/clientx/namex.seitex.de mit den Verzeichnissen .ssh, cgi-bin, log, private, ssl, tmp, web, webdav.
Nur im Verzeichnise web gibt es Dateien und Unterverzeichnisse (u. a. eine index.html).
Aber wenn ich die Seite aufrufe, erscheint eine andere, deren Namen im Alphabet vor dem aktuellen Namen kommt (das ist wohl ein bekannter Apache-Bug). In deren access.log steht auch, dass die diese Seite durch auf Aurufen der neuen Seite angezeigt wurde:
172.18.169.0 - - [17/May/2019:17:47:43 +0200] "GET /wp-content/uploads/2019/02/IMG_1324-300x225.jpg HTTP/1.1" 200 20246 "http:///namex.seitex.de/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0"
Diese Seite namex.seitex.de steht nicht als namex.seitex.de.vhost im Rootverzeichnis und es gibt auch keinen Link 100-namex.seitex.de.vhost.
Weder im Verzeichnis /etc/httpd/conf/sites-available/ noch /etc/httpd/conf/sites-enabled/ taucht ein Hinweis auf die neue Seite auf.
Auch bestehende Seite lassen sich nur in der Weboberfläche aktivieren/deaktivieren. Ab das bleibt ohne Wirkung in den Verzeichnissen sites-available und sites-enabled.
 

Till

Administrator
Alle websites müssen entweder * oder die IP im ipv4 feld nutzen, wenn Du das euf einem server mischst, dann bekommen die seiten mit * keinen traffic. Also bei allen seiten * nehmen oder bei allen die IP.

Wenn das ok ist, dann schau mal ob die vhost datei mit .err endung im sites-available verzeichnis ist. Wenn das auch nichtd er fall ist, dann hilft Dir der Debug mode um rauszufinden warum sie nicht geschrieben werden können.
 

rokale

New Member
So sieht es in der Konsole aus:
21.05.2019-15:00 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
21.05.2019-15:00 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

Und in der Weboberfläche steht dasselbe:

Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
und

Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

Ab und zu gibt es auch eine Warnung:

No awstats base config found. Either awstats.conf or awstats.model.conf must exist in /etc/awstats.

Ich habe gerade nochmal eine neue Webseite (Klient 8, Webseite 62) erzeugt aber sie taucht nirgends auf, nicht als Link in /usr/local/ispconfig/server oder /etc/httpd/conf/sites* oder /var/www/clients/client8
 

rokale

New Member
Weboberfläche funktioniert nicht.
Egal welche Änderungen ich in der Weboberfläche mache, es kommt nichts unten im System an
 

Till

Administrator
  1. Hast Du den server.sh cronjob wie beschrieben auskommentiert? wenn nicht, dann kann es sein dass Du beim debugging die Fehler nicht angezeigt bekommst.
  2. ist das single oder multiserver? wenn Multiserver,d ann musst Du server.sh auf dem richtigen zielserver ausführen, nicht auf dem master.
  3. hat der server vorher funktioniert oder ist es ein neuer server bei dem Du vorher noch keine webseiten erfolgreich angelegt hast?
  4. Du hast den server anhand eines der perfect server tutorials von howtoforge installiert?
 

rokale

New Member
Das Problem ist gelöst. Mein Kollege hat den Fehler gefunden. Er war im Menüpunkt Server/Serverkonfiguration/Web
In den Einträgen "vHost Konfigurationsverzeichnis" und "vHost config enabled dir" standen falsche Werte:
/etc/apache2/conf... statt /etc/https/conf...
Wie sie dort hingekommen sind, weiß ich nicht (vielleicht durch ein Update im April?)
Zu den Fragen
  1. ob ich es auskommentiert hatte, bin ich mir nicht sicher
  2. singleserver
  3. Server hat vorher funktioniert
  4. entfällt, da der Server funktioniert hat und ich ihn nicht installiert habe.
Vielen Dank für vielen Hinweise zur Lösung des Problems
 

Werbung

Top