Kein Mailquota [Dovecot + NFS + ISPConfig 3.0.4.3]

Athesis

New Member
Hallo,

Ich habe ein Problem: Bei ISPConfig 3.0.4.3 wird leider der Mailquota nicht mehr angezeigt. Dies hatte bis zum Import einiger Mailadressen einwandfrei funktioniert und ich finde es einfach nicht wo es hängt ...

Der Aufbau sieht wie folgt aus:

ISP-Config Masterserver
|-> Mailserver
| |-> NFS NAS ( verbunden zu /var/vmail auf Mailserver)

Ich sehe keine Fehlermeldungen und die einzige Veränderung sind ca. 400 per API Importierte neue Mailadressen - Seitdem wird der Mailbox Quota (Used-Space unter Mailbox Quota) nicht mehr gezählt. Ich würde mich um jede Hilfe dazu sehr freuen :)!

Edit: Ich habe gerade bemerkt, der Mailbox Datenverkehr wird auch nicht mehr gezählt. Das ganze rennt auf Debian 6.
 
Zuletzt bearbeitet:

Athesis

New Member
Hallo,

Ich hab herausgefunden was warscheinlich den Quota berechnet:

Es wird nach %maildir%/ispconfig_mailsize gesucht, jedoch existiert diese nicht? Ich vermute Dovecot sollte diese erstellen?
 

Till

Administrator
Das Quota wird von Dovecot errechnet. Poste bitte mal Deine dovecot.conf Datei.

Es wird nach %maildir%/ispconfig_mailsize gesucht, jedoch existiert diese nicht? Ich vermute Dovecot sollte diese erstellen?
Die Datei hat mit mailquota nichts zu tun, es ist die traffic statistik Datei für courier Systeme. Bei Dovecot wird sie nicht verwendet und auch nicht erstellt.
 

Athesis

New Member
Hallo,

Hier ist die aktuelle config - Eigentlich unverändert seit ISPconfig Installation.

Code:
## ISPConfig3 Template file.
## This file was installed by ISPConfig3
## It will be replaced if ISPConfig3 is updated.

## Dovecot configuration file
base_dir = /var/run/dovecot/

protocols = imap imaps pop3 pop3s
disable_plaintext_auth = no
log_timestamp = "%Y-%m-%d %H:%M:%S "

# ssl_cert_file = /etc/ssl/_.my-domain.tld/_.my-domain.tld.crt
# ssl_key_file = /etc/ssl/_.my-domain.tld/_.my-domain.tld.key

mail_privileged_group = mail

login_greeting = ISPConfig3 IMAP server ready...

## IMAP specific settings
protocol imap {
  mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/imap
  mail_plugins = quota imap_quota
}

## POP3 specific settings
protocol pop3 {
  mail_executable = /usr/lib/dovecot/rawlog /usr/lib/dovecot/pop3
  pop3_uidl_format = %08Xu%08Xv
  mail_plugins = quota
}

## LDA specific settings
protocol lda {
  # Address to use when sending rejection mails.
  postmaster_address = noc@UnsereDomain.de 

  # Support for dynamically loadable plugins. mail_plugins is a space separated
  # list of plugins to load.
  mail_plugin_dir = /usr/lib/dovecot/modules/lda

  # UNIX socket path to master authentication server to find users.
  auth_socket_path = /var/run/dovecot/auth-master

  # Enabling Sieve plugin for server-side mail filtering
  mail_plugins = quota
}


## Plugin settings
plugin {
  quota = dict:user::file:/var/vmail/%d/%n/.quotausage
  # Because the mail quota is called in the user query 
  # the maildir quota does not need to be set.
  # You do not need: quota = maildir
  #    quota_warning = storage=90%% /usr/local/bin/quota-warning.sh 90 %u
  sieve=/var/vmail/%d/%n/.sieve
}


## Authentication processes

# Executable location
#auth_executable = /usr/lib/dovecot/dovecot-auth
auth default {
  mechanisms = plain login

  # SQL database <doc/wiki/AuthDatabase.SQL.txt>
  passdb sql {
    # Path for SQL configuration file
    args = /etc/dovecot/dovecot-sql.conf
  }

# new quota support:
  userdb prefetch {
  }

  userdb sql {
    args = /etc/dovecot/dovecot-sql.conf
  }


  ## dovecot-lda specific settings
  ##
  socket listen {
    master {
      path = /var/run/dovecot/auth-master
      mode = 0600
      user = vmail # User running Dovecot LDA
      #group = vmail # Or alternatively mode 0660 + LDA user in this group
    }
  client {
          path = /var/spool/postfix/private/auth
          mode = 0660
          user = postfix
          group = postfix
        }
  }

}

mail_location = maildir:/var/vmail/%d/%n/Maildir

mail_uid = 5000
mail_gid = 5000
 

Athesis

New Member
Hallo,

Es wird ganz seltsam:

Die Quotas sind aus dem nichts wieder aufgetaucht gestern - und heute wieder weg. Ich vermute nun einfach mal grob das ISPConfig nicht in die Master-Datenbank schreiben kann ... ? Mit den Zugriffsrechten an sich kann es nichts zu tun haben, wenn ich z.B. neue Mailadressen anlege werden diese übertragen. Problemlos!
 

Till

Administrator
Mit den Zugriffsrechten an sich kann es nichts zu tun haben, wenn ich z.B. neue Mailadressen anlege werden diese übertragen. Problemlos!
Das sind zwei unterschiedliche Dinge, denn Lese und Schreibrechte werden für jede Tabelle der DB getrennt verwaltet. Es kann also durchaus was mit den Rechten zu tun haben.

hast Du gestern irgend ws am Server gemacht, updates eingespielt oder ähnliches?
 

Athesis

New Member
Hallo,

Nein, keine Updates nix - Ich habe lediglich nach etwas schauen wollen und mir ist dabei aufgefallen das die Quotas wieder aufgezeigt werden. Die Server rattern noch brav auf der letzten Version.

Ich hab es nun auch geprüft: Mit den Rechten stimmt alles, für alle notwendigen Tabellen sind die rechte dem Serveruser entsprechend gesetzt. Und zeitweise geht es ja sogar ganz offensichtlich.
 

Till

Administrator
Sind denn die /var/vmail/domain.tld/user/.quotausage Dateien vorhanden und steht da was drin?
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.