ISPConfig3 - Multiserver-Komponenten-Mix

celocore

Member
Hallo zusammen,

ist es möglich in einer Multi-Server-Struktur auf den Slaves andere MySQL und PHP-Versionen zu betreiben, als auf dem Master?

Im Moment sieht es so aus, daß auf dem Master und den bisherigen Slaves MySQL 5.0 und PHP 5.2 läuft. Die Rufe nach MySQL 5.1 und PHP 5.3 werden jedoch lauter :)
 

Burge

Member
Also ich hab im Multiserver Setup einen extra Webserver für php 5.2 und einen für php 5.3 denke das es mit dem mysql genauso klappen sollte.
 

mare

Member
Das spricht imho nichts dagegen. Du kannst ja sogar ein Multisetup mit verschienden OS fahren. Solange ispconfig auf dem Slave läuft und z.B. die Datenbankversionen kompatibel sind sollte es keine Probleme geben.
 

celocore

Member
Hallo mare,

genau da setzt meine Frage an. Ich habe auf dem Master einen MySQL 5.0-Server und will nun auf dem Slave einen MySQL5.1-Server betreiben. Ich weiß, daß MySQL 5.1 nicht unbedingt so abwärts-kompatibel ist. Zumindest gibt es bei dumps von 5.1 nach 5.0 regelmäßig Probleme.
 

Till

Administrator
Das sollte kien Problem sein, da ISPConfig die Daten ja selbst repliztiert und mit allem MySQL Versionen ab 4.1 funktionieren sollte.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.