ISPConfig und Roundcube

fw114

Member
Hallo zusammen,

ich habe ein indirektes Problem mit IPSconfig , hoffe aber dennoch ihr könnt mir helfen.
Zuerst hatte ich gedacht es liegt an Roundcube, liegt aber nicht daran.

Problem:

courier hört auf 993
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 10070/couriertcpd
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 8762/couriertcpd


mache ich nun ein tenlet localhost auf 993 oder 995 kommt:

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

das wars.

jemand eine Idee was es sein könnte, bzw was ich nicht sehe ?

DANKE !
 
Zuletzt bearbeitet:

fw114

Member
OK gerade geprüft mit
openssl s_client -connect localhost:993

er nimmt an und ok

warum kann dann roundcube keine anmeldung durchführen ?
riesen fragezeichen
 

fw114

Member
Hallo,
das problem ist , dass roundcube nicht via 993 auf courier zugreifen kann und ich den grund dafür nicht nicht finde.

bisher geprüft:

imap via telnet 143
OK

imap via 993 getestet mit
openssl s_client -connect localhost:993

SSL zertifikat OK, server wartet auf kommandos

nur roundcube (auf dem gleichen server) sagt: keine verbindung zum anmeldeserver.
auch eine anmeldung ohne SSL ist nicht möglich.

ich finde dazu nichts in den logs
 

fw114

Member
$rcmail_config['default_host'] ='localhost';

// TCP port used for IMAP connections
// $rcmail_config['default_port'] = 143;
$rcmail_config['default_port'] = 993;

// IMAP AUTH type (DIGEST-MD5, CRAM-MD5, LOGIN, PLAIN or empty to use
// best server supported one)
$rcmail_config['imap_auth_type'] = null;

// If you know your imap's folder delimiter, you can specify it here.
// Otherwise it will be determined automatically
$rcmail_config['imap_delimiter'] = null;

// If IMAP server doesn't support NAMESPACE extension, but you're
// using shared folders or personal root folder is non-empty, you'll need to
// set these options. All can be strings or arrays of strings.
// Folders need to be ended with directory separator, e.g. "INBOX."
// (special directory "~" is an exception to this rule)
// These can be used also to overwrite server's namespaces
$rcmail_config['imap_ns_personal'] = null;
$rcmail_config['imap_ns_other'] = null;
$rcmail_config['imap_ns_shared'] = null;

// By default IMAP capabilities are readed after connection to IMAP server
// In some cases, e.g. when using IMAP proxy, there's a need to refresh the list
// after login. Set to True if you've got this case.
$rcmail_config['imap_force_caps'] = false;

// By default list of subscribed folders is determined using LIST-EXTENDED
// extension if available. Some servers (dovecot 1.x) returns wrong results
// for shared namespaces in this case. http://trac.roundcube.net/ticket/1486225
// Enable this option to force LSUB command usage instead.
$rcmail_config['imap_force_lsub'] = false;

// IMAP connection timeout, in seconds. Default: 0 (no limit)
$rcmail_config['imap_timeout'] = 0;

// Optional IMAP authentication identifier to be used as authorization proxy
$rcmail_config['imap_auth_cid'] = null;

// Optional IMAP authentication password to be used for imap_auth_cid
$rcmail_config['imap_auth_pw'] = null;

// Type of IMAP indexes cache. Supported values: 'db', 'apc' and 'memcache'.
$rcmail_config['imap_cache'] = null;

// Enables messages cache. Only 'db' cache is supported.
$rcmail_config['messages_cache'] = false;
 

robotto7831a

Well-Known Member
Irgendetwas muss aber doch im Maillog stehen wenn er sich versucht zu connecten. hast Du mal geschaut was Firebug so anzeigt.
 

Pinguin

New Member
Der Eintrag $rcmail_config['default_host']
sollte 'ssl://localhost' oder 'tls://localhost' sein
Alternativ kannst Du auch
$rcmail_config['default_host'] = 'ssl://localhost:993';
versuchen.

Bei einer localhost Verbindung über das Loopback Device macht tls/ssl jedoch wenig Sinn wenn man nicht befürchtet, dass fremde Anwender oder Programme einen Sniffer auf dem gleichen Server laufen lassen. Bei entfernten Systemen ist es natürlich sinnvoll.
 

fw114

Member
Danke Pinguin, das war es.

Das Problem was ich allerdings habe ist: Nehme ich das ssl weg, kann ich mich via Roundcube nicht mehr anmelden.
Fehlermeldungen wenn ich das ssl wegnehme bekomme ich keine, ich kann mich nur nicht mehr anmelden.
 

JeGr

Member
> Fehlermeldungen wenn ich das ssl wegnehme bekomme ich keine, ich kann mich nur nicht mehr anmelden.
Was auch Sinn macht, denn wenn du auf Port 993 (wie du in der Konfiguration definiert hast) versuchst mit dem Dienst zu sprechen, der auf diesem Port aber SSL/TLS erwartet, wird das nicht hin hauen (und du kannst dich logischerweise nicht anmelden).

Das wäre so, als wenn auf deinem Ticket Lufthansa steht und du zum AirBerlin schalter gehst. Die kann mit dir nichts anfangen ;)
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.