ISPConfig 3 : Änderungen werden nicht übernommen

nofreak

Member
Hallo,

nach erfolgreicher Konfiguration von ispconfig3 wollte ich nun einen weiteren Kunden anlegen und zusätzliche Domainen freischalten.

Was mit dem ersten Kunden/Domäne geklappt hat, sollte nun auch mit weiteren klappen.

Leider nicht.

Zwar habe ich einen neuen Kunden angelegt, FTP User, Domäne, usw. Nur leider tut sich auf dem Server nichts (keine /home/clients/client2, kein vhost usw.)

Woran kann das liegen? Die Cronjobs sind entsprechend angelegt und vorhanden:

crontab -l liefert:
* * * * * /usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log
30 00 * * * /usr/local/ispconfig/server/cron_daily.sh > /dev/null 2>> /var/log/ispconfig/cron.log

Im cron.log ist entsprechend nichts zu finden (Datei ist leer).

Danke für Hinweise...

Gruß
Frank
 

Till

Administrator
1) Stehen die jobs noch in der jobqueue?
2) Irgendwelche Fehlermeldungen oder warnings im system log im ispconfig monitor?
 

nofreak

Member
Ohja, jetzt habe ich es entdeckt. Die Jobwarteschlange ist entsprechend gefüllt.

Aber warum führt er diese nicht aus?

In /var/log/syslog keine Warnings oder Fehler. Das ISPConfig Protokoll ist leer.

Danke

Gruß
Frank
 

nofreak

Member
Davon mal ab, sind in der Warteschlange insgesamt 5 Seiten an Änderungen. Davon möchte ich nicht mehr alle ausführen.

Welche Möglichkeiten habe ich, einzelne Aktionen zu unterbinden? Welche Datenbanktabelle steht denn dahinter...
 

nofreak

Member
/usr/local/ispconfig/server/server.sh hatte ich schon aufgerufen.

Auch wenn ich es jetzt nochmal mache, passiert mit der Job-Warteschlange gar nichts. Auch keinerlei Ausgabe, Warnung, Hinweis.
 

Till

Administrator
Schate mal debugging in ispconfig ein (Details siehe ispconfig faq) und ruf dann das server.sh script nochmal auf.
 

nofreak

Member
Okay. Debugging /lib/config.inc.php auf 0 gesetzt (Debugging).

Erste Mitteilung:
08.03.2010-12:31 - DEBUG - There is already an instance of server.php running. Exiting.

Aha...

Mal genauer nachgeschaut: Prozess ist am 27.02. gestartet, passt ungefähr einher mit der letzten Bearbeitung.

Also Prozess gekillt. (kill -9)

Nächster Anlauf:
08.03.2010-12:33 - DEBUG - There is already a lockfile set. Waiting another 10 seconds...

Haha... echt witzig... danach hat mich die Konsole rausgeworfen.

Ich suche die .ispconfig_lock und stelle fest, dass sie ebenfalls vom 28.02. (00:11) stammt.

Auch diese haue ich mal ins Nirvana.

Melde mich gleich wieder...
 

worryboy

New Member
Hallo

ich weiss das Thema ist alt (sehr alt) aber ich habe gleiches Problen nun auch in 2023 .

Nach einem Upgrade von Ubuntu 20.04 auf 22.04 nach Update the ISPConfig Perfect Server from Ubuntu 20.04 to Ubuntu 22.04 (howtoforge.com) .

Der Server ist inzwischen gewachsen und läuft noch mit mySQL. >> Sehr stabil nur werden ab jetzt die Änderungen nicht übernommen. Im Log ist zu finden.

Bash:
/usr/local/ispconfig/server/server.sh

26.01.2023-20:54 - WARNING - There is already an instance of server.php running with pid 56282.
worker@hans:~$ sudo /usr/local/ispconfig/server/server.sh
26.01.2023-20:54 - WARNING - There is already an instance of server.php running with pid 56282.
worker@hans:~$ sudo /usr/local/ispconfig/server/server.sh
26.01.2023-20:54 - WARNING - There is already an instance of server.php running with pid 56282.
worker@hans:~$ sudo /usr/local/ispconfig/server/server.sh
26.01.2023-20:54 - WARNING - There is already an instance of server.php running with pid 56282.
worker@hans:~$ sudo /usr/local/ispconfig/server/server.sh
26.01.2023-20:54 - WARNING - There is already a lockfile set, but no process running with this pid (56282). Continuing.
Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
^[[APHP Warning:  Undefined array key "mysql" in /usr/local/ispconfig/server/plugins-available/rspamd_plugin.inc.php on line 511
PHP Warning:  Trying to access array offset on value of type null in /usr/local/ispconfig/server/plugins-available/rspamd_plugin.inc.php on line 511
PHP Fatal error:  Uncaught mysqli_sql_exception: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '.server_ip WHERE `server_id` = 1' at line 1 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:302
Stack trace:
#0 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(302): mysqli_query()
#1 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(339): db->_query()
#2 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(395): db->query()
#3 /usr/local/ispconfig/server/plugins-available/rspamd_plugin.inc.php(511): db->queryAllRecords()
#4 /usr/local/ispconfig/server/lib/classes/plugins.inc.php(120): rspamd_plugin->server_update()
#5 /usr/local/ispconfig/server/mods-available/server_module.inc.php(98): plugins->raiseEvent()
#6 /usr/local/ispconfig/server/lib/classes/modules.inc.php(302): server_module->process()
#7 /usr/local/ispconfig/server/lib/classes/modules.inc.php(235): modules->raiseTableHook()
#8 /usr/local/ispconfig/server/server.php(180): modules->processDatalog()
#9 {main}
  thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 302
sonst bis auf php FPM läuft alles.

Mit Gruss
 

Werbung

Top