.htaccess Problem + WoltLab Burning Board Installtion klappt nicht

nedodu

New Member
Hey,

wollte mir eine .htaccess-Datei mit einem 100 % funktionierenden Script für .htaccess erstellen lassen, CHMOD Rechte sind 777, klappt aber nicht, denke mal das liegt an ISPConfig/an PHP den mit Plesk hat's bereits funktioniert :(

Wollte ein WoltLab Burning Board aufsetzen, allerdings stoppte der Installationsprozess hier. Ich weiß ist von WoltLab, denke aber das liegt allgemein an meinen PHP-Einstellungen (die eigentlich unverändert sind) oder/und an ISPConfig. Schätze das mit den Rechten was nicht ganz stimmt, heißt ja "Could not create dir".Das ganze kommt ziemlich umgelegend, wollte ISPConfig nehmlich gerade produktiv einsetzen...

Vielen Dank schon mal.
 

Till

Administrator
Da gibt es 2 Möglichkeiten:

a) Ruf einfach auf:

chmod 777 /srv/www/web2/web

oder b) Stell Deinen Server von mod_php auf suphp um, damit die php scripte unter dem eigentümer des webs laufen.
 

nedodu

New Member
a) Ruf einfach auf:

chmod 777 /srv/www/web2/web
Das funktioniert leider nur halb, wenn ich den Ordner "web" die Rechte 777 gebe, klappt es noch nicht. Wenn ich WCFSetup.tar.gz, install.php 777 gebe auch nicht. Erst wenn dem Ordner "web" 777 Rechte inkl. allen Unterverzeichnissen & Dateien anwende gehts. Das ist mir aber etwas zu unsicher, weil alle Dateien 777...


Stell Deinen Server von mod_php auf suphp um, damit die php scripte unter dem eigentümer des webs laufen.
Danke, aber wie mach ich das korrekt? Wenn ich jetzt drauf los probieren wird das nichts...
 
Zuletzt bearbeitet:

nedodu

New Member
Okay, hab' jetzt alles 100 % wie in dem Tutorial gemacht, jetzt kommt aber nur noch:

[FONT=Helvetica, Arial]Folgender Fehler ist aufgetreten:[/FONT] [FONT=Helvetica, Arial]Beim Aufruf der angegebenen URL ist ein interner Server-Fehler aufgetreten. [/FONT][FONT=Helvetica, Arial]Sollten Sie diese Fehlermeldung öfter erhalten, wenden Sie sich bitte an den Webmaster.[/FONT] [FONT=Verdana, Arial]powered by ISPConfig

-------------------------------------------
Habe alles neu gestartet (Konsole + ISPConfig) geht aber kein PHP mehr? :confused:

Was mir bei der Installation aufgefallen ist das die Datei:
[/FONT]
Bei mir nicht so aussieht wie im Beispiel:
Code:
#<IfModule mod_suphp.c>
#    suPHP_Engine on
#
#    AddType application/x-httpd-php .php
#    AddType application/x-httpd-php .php3
#    AddType application/x-httpd-php .php4
#    AddType application/x-httpd-php .php5
#    AddHandler application/x-httpd-php .php
#
#    DirectoryIndex index.php index.php3 index.php4 index.php5
#
#    <Location />
#        suPHP_AddHandler application/x-httpd-php
#    </Location>
Meine:
Code:
#<IfModule mod_suphp.c>
#    suPHP_Engine on
#
#    AddType application/x-httpd-php .php
#    AddType application/x-httpd-php .php3
#    AddType application/x-httpd-php .php4
#    AddType application/x-httpd-php .php5
#    AddHandler application/x-httpd-php .php
#
#    DirectoryIndex index.php index.php3 index.php4 index.php5
#
#    <Location />
#        suPHP_AddHandler application/x-httpd-php
#    </Location>
#</IfModule>
#
# in your vhost you need:
#<Virtualhost *>
#  suPHP_UserGroup someuser somegroup
#</Virtualhost>
[FONT=Verdana, Arial] Pls help :( :eek::(

Thx.
PS: Wenn ich das ganze rück gängig mache geht alles wieder. Benötige eben aber suphp....
[/FONT]
[FONT=Verdana, Arial][/FONT]
 
Zuletzt bearbeitet:

Till

Administrator
Du musst wie im Tutorial beschrieben das suphp auch in ispconfig aktivieren (in der config.inc.php) und danache eine website in ISPConfig ändern und speichern, damit die Konfigurations dateien neu geschrieben werden.

Und zu der Fehlermeldung: Bei Fehlern sieht man im error.log der Webseite nach, ansonsten kann man da nur raten ;)
 

nedodu

New Member
Thx! LOL hab nur das ändern vergessen, mal sehen obs jetzt echt geht. :D

nachtrag: Tool, es lebt :) htacces funktioniert jetzt auch, jetzt finde ich aber komisch das wenn ich einer datei die Rechte 777 gab, es zum Fehler kam, aber mit den Rechten 644 sah ich die php-Datei im Browser korrekt, dass ist nicht normal oder?

Die ISPConfig Fehlerseiten sind ja ganz nett, aber ich mag die Apache Meldungen mehr, gibts eine einfache Möglichkeit die Meldungen von ISPConfig zu deaktivieren? Sind ja nur die Fehlerseiten ...

thx & rein gehauen ;)
 
Zuletzt bearbeitet:

nedodu

New Member
Habe jetzt Fehlerseiten mit dem korrekten Namen im Ordner /root/ispconfig/isp/conf/customized_templates/ angelegt und neu gestartet, aber immer noch die falschen Fehlerseiten... Was muss ich genau ändern?

Bin bestimmt im falschen Ordner, ich weiß ........
 

Till

Administrator
Der Ordner customized_templates ist nicht für Fehlerseiten. Du musst die bestehenden Fehlersietn in /root/ispconfig/isp/ ändern.
 

nedodu

New Member
Hab ich gemacht (hätte ich wohl erwähnen sollen) :D Geht aber nach neu-Start von Apache auch noch nicht ... Wofür ist customized_templates?
 

nedodu

New Member
Aha, woher soll ich das wissen ;) Das heißt die werden 1 mal beim anlegen eines Webs von /root/ispconfig/isp/ nach /web/error kopiert?
 

nedodu

New Member
Stimmt stimmt, aber eine art "Autoabgleich" für nächste Versionen wäre wünschenswert, da man sonst ja einen relativ hohen Aufwand hat...
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.