[Gelöst] Problem mit ISPConfig und PHP8

Doc Lowy

New Member
Hallo liebe ISPConfig-Benutzer.

Vorab mein ISPCofig Setup:

Linux: Debian 9 (Stretch)
ISPConfig-Installation: installiert via 'The Perfect Server - Debian 9 (Stretch) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1' (https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/)

ISPonfig-Update auf v3.2.2

PHP: v5.6, 7.0, 7.2, 7.4 via 'How to install PHP 5.6 and 7.0 - 7.4 as PHP-FPM & FastCGI for ISPConfig 3.1 with apt on Debian 8 to 10' (https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/)

Das Ganze hat auch gut funktioniert; beim letzten apt Update kam von sury.org die PHP-Version 8.0 auf den Rechner, welches mir das 'phpmyadmin', sowie das 'roundcube' komplett lahm legte; bei beiden Webseiten kommt nun lediglich ein 'HTTP ERROR 500'. Eine vorgeschaltete phpinfo()-Seite zeigt auch bei beiden Seiten die PHP-Version 8.0.

Nach nunmehr 2 Wochen Herumprobieren bin ich nun am Ende meiner bescheidenen Weisheit; auch die Suche im Forum war nicht so recht von Erfolg gekrönt.
Hat hier jemand das gleiche Problem oder eine Lösung dessen? Oder kann mir jemand erklären, wie ich den Apache dazu bringen kann, per Default wieder eine niedrigere PHP-Version zu benutzen?

In allen mir bekannten Konfigurationen sehe ich immer nur die PHP-Version 7.0.

Hier noch der alternatives-Aufruf:
Code:
root@...:~# update-alternatives --config php
Es gibt 5 Auswahlmöglichkeiten für die Alternative php-cgi (welche /usr/bin/php-cgi bereitstellen).

Auswahl Pfad Priorität Status
------------------------------------------------------------
  0 /usr/bin/php.default 100 automatischer Modus
  1 /usr/bin/php.default 100 manueller Modus
* 2 /usr/bin/php7.0 70 manueller Modus
  3 /usr/bin/php7.3 73 manueller Modus
  4 /usr/bin/php7.4 74 manueller Modus
  5 /usr/bin/php8.0 80 manueller Modus

root@...:~# update-alternatives --config php-cgi
Es gibt 5 Auswahlmöglichkeiten für die Alternative php-cgi (welche /usr/bin/php-cgi bereitstellen).

Auswahl Pfad Priorität Status
------------------------------------------------------------
  0 /usr/bin/php-cgi.default 100 automatischer Modus
  1 /usr/bin/php-cgi.default 100 manueller Modus
* 2 /usr/bin/php-cgi7.0 70 manueller Modus
  3 /usr/bin/php-cgi7.3 73 manueller Modus
  4 /usr/bin/php-cgi7.4 74 manueller Modus
  5 /usr/bin/php-cgi8.0 80 manueller Modus
Falls ihr noch mehr LogFiles braucht, sagt bitte Bescheid.


Viele Grüße,
Wolfgang
 

Till

Administrator
Schau mal in die apache /etc/apache2/mods-enabled und /etc/apache2/conf.d bzw. /etc/apache2/conf-enabled Verzeichnisse, ob sury Dir da irgendwo php8 aktiviert hat.
 

Doc Lowy

New Member
OMG! Bin ich blind?? Danke dir, Till.
/etc/apache2/conf-enabled/php8.0-fpm.conf gelöscht und alles funktioniert wieder.

Code:
root@...:/etc/apache2# ls -la /etc/apache2/mods-enabled/php*
lrwxrwxrwx 1 root root 29 Jan 18  2019 /etc/apache2/mods-enabled/php7.0.conf -> ../mods-available/php7.0.conf
lrwxrwxrwx 1 root root 29 Jan 18  2019 /etc/apache2/mods-enabled/php7.0.load -> ../mods-available/php7.0.load

root@...:/etc/apache2# ls -la /etc/apache2/conf-enabled/php*
lrwxrwxrwx 1 root root 33 Mär  6  2019 /etc/apache2/conf-enabled/php7.0-fpm.conf -> ../conf-available/php7.0-fpm.conf
lrwxrwxrwx 1 root root 33 Mär  3  2020 /etc/apache2/conf-enabled/php7.3-fpm.conf -> ../conf-available/php7.3-fpm.conf
lrwxrwxrwx 1 root root 33 Mär  3  2020 /etc/apache2/conf-enabled/php7.4-fpm.conf -> ../conf-available/php7.4-fpm.conf
lrwxrwxrwx 1 root root 33 Feb 21 13:59 /etc/apache2/conf-enabled/php8.0-fpm.conf -> ../conf-available/php8.0-fpm.conf
lrwxrwxrwx 1 root root 33 Jan 19  2019 /etc/apache2/conf-enabled/phpmyadmin.conf -> ../conf-available/phpmyadmin.conf
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.