[erledigt] Wert von "upload_max_filesize" für eine Webseite ändern

  • Ersteller des Themas Deleted member 5906
  • Erstellungsdatum
D

Deleted member 5906

Guest
Hi,
ich muss für eine Webseite die maximale Dateigröße beim Hochladen ändern. Diese läuft mit php-fpm und so habe ich auch entsprechende Werte in der benutzerdefinierten php.ini Datei über das Panel vorgenommen, welche auch übernommen wurden:
Code:
php_admin_value[upload_max_filesize] = 10M
Allerdings zeigt mir phpinfo() an, dass der Wert beim Standardwert von 2M liegt. Die Eingabe ist an sich ja richtig und steht ja so auch in der Datei, nur PHP selbst möchte es nicht übernehmen. Woran könnte es liegen?
 
D

Deleted member 5906

Guest
Ja, habe neben Apache auch php-fpm manuell neugestartet. Aber erfolglos.
 
D

Deleted member 5906

Guest
Nein, in den vHost Dateien steht davon nichts. Ich habe die Parameter lediglich in das Textfeld für PHP-Einstellungen eingetragen. Müssen die etwa auch bei den Apache Direktiven rein? Obwohl ich php-fpm und nicht mod_php nutze?
 

Till

Administrator
Der Eintrag ist falsch, richtig wäre:

upload_max_filesize = 10M

im php.ini Feld in ispconfig.
 
D

Deleted member 5906

Guest
Genau so steht er auch drin. Die Ausgabe war die von der benutzerdefinierten php.ini Datei und sollte nur zeigen, dass die Einstellung übernommen und geschrieben wurde.
 
D

Deleted member 5906

Guest
Nein, nutze nur Apache und daher nichts für nginx drin.
 

logifech

Member
Steht der wert in der dazugehrigen Pool datei von PHP-FPM richtig drinne?? Bei PHP-FPM werden die werte soweit ich weiß dort reingeschrieben und daraus übernommen.
So steht dies z.B. in meiner /opt/php-5.6.1/etc/pool.d/webXX.conf datei
Bei euch varriiert der Ordner wo die pool dateien drinne liegen wahrscheinlich.
Code:
php_admin_value[disable_functions] = pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,dl,highlight_file,show_source,proc_open,popen
php_admin_value[post_max_size] = 100M
php_admin_value[upload_max_filesize] = 100M
php_admin_value[max_execution_time] = 1200
php_admin_value[max_input_time] = 1200
php_admin_flag[magic_quotes_gpc] = Off
php_admin_flag[file_uploads] = Yes
php_admin_value[max_file_uploads] = 20
 
Zuletzt bearbeitet:
D

Deleted member 5906

Guest
Genau so steht der Wert bei mir drin, wie oben bereits erwähnt.

Individuelle php.ini Einstellungen
Code:
...
upload_max_filesize = 10M
post_max_size = 10M
In der /etc/php5/fpm/pool.d/webXXX.conf
Code:
...
php_admin_value[upload_max_filesize] = 10M
php_admin_value[post_max_size] = 10M
phpinfo()
Code:
...
upload_max_filesize 2M
post_max_size 8M
...
Apache und php-fpm wurden bereits auch schon manuell neugestartet. Ohne Erfolg. Alle Einstellungen sind im Panel gemacht worden und ganz sicher auch für die richtige Webseite. Die phpinfo-Datei befindet sich auch im richtigen Verzeichnis, sprich im web-Verzeichnis der Domain.
 
Zuletzt von einem Moderator bearbeitet:

nowayback

Well-Known Member
dann sollten die werte in der entsprechenden webxxx.conf im verzeichnis der zusatzversion (z.b. /opt/php5.6.1/....) stehen
 
D

Deleted member 5906

Guest
und du nutzt ganz sicher apache2 + php-fpm und nicht apache2 + fastcgi?
Ja, auch ganz sicher, dass ich es so nutze. Habe jetzt sogar nochmal extra nachgesehen. Anders würden die Einstellungen ja auch nicht in die Konfigurationsdatei geschrieben werden.
Der Parameter "display_errors" wurde ja exakt so auch eingetragen und funktioniert problemlos. Bloß bei der Sache mit der Dateigröße für den Upload will PHP nicht ganz mitspielen.
 
D

Deleted member 5906

Guest
Also, ich wollte gerade temporär den Wert über die globale php.ini einstellen. Dafür /etc/php5/fpm/php.ini geöffnet und upload_max_filesize umgestellt. Anschließend php-fpm neugestartet. Einen kurzen Blick auf die phpinfo riskiert und dabei festgestellt, dass selbst diese Einstellung nicht übernommen wurde.

Die gleiche Einstellung habe ich dann mal auf /etc/php5/cgi/php.ini angewandt und siehe da: Es funktioniert!
Damit scheint es, als würde die Einstellung von php-fpm bei den Einstellungen für den PHP-Modus ignoriert, da ich dort explizit php-fpm ausgewählt habe.

Ist das jetzt ein Bug oder habe ich irgendetwas übersehen?
 

logifech

Member
Ich werd dies auch mal bei mir testen, aber in der Regel nutze ich nicht die default php version vom OS sondern zusätlich Kompillierte Software. Werde meine erfahrung dann auch mal hier berichten.
 
D

Deleted member 5906

Guest
Danke dir, wäre einfach schön zu wissen woran es jetzt genau liegt.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.