E-Mail Weiterleitung funktioniert nicht

Till

Administrator
Es gibt ja 2 Funktionen der Emailweiterleitung.

1) Ein lokales Postfach das die Emails empfängt, welches es auch ermöglicht zusätzlich eine Kopie der Email an ein weiteres Postfach zu senden.

2) Der Email forward, der die Email nur weiterleitet ohne das sie in einem lokalen Postfach gespeichert wird.

Wenn Du also eine Weiterleitung der Email ohne postfach möchtest, dann legst Du eine Emailweiterleitung und kein postfach an.
 

stefanw

New Member
Servus Till,

das ist mir schon klar, nur es funktioniert nicht. Ich habe hier eine Domain mit 4 Weiterleitungen. Für jede dieser Weiterleitungen wurde ein lokales Postfach angelegt. Ich habe das dann bei einer weiteren Domain auch nochmal ausprobiert und es ist reproduzierbar. Momentan kriege ich das nur gelöst in dem ich eine Mailbox anlege und diese dann mit "Send copy to" versehe. Die reine Weiterleitung funktioniert, zumindest bei mir, nicht (ISPConfig 3.0.3.2 und Debian lenny)

Stefan
 

Till

Administrator
Das klingt mir danach als ob Du einen Domain Alias hast. Entferne den bitte mal. Domain Aliase können in Verbindung mit courier dazu führen, dass mailboxen für eingehende Emails angelegt werden, auch wenn kein Mailbox Account besteht. Satt des Domain Alias verwende besser den Email Alias.

Weiterleitungen funktionieren einwandfrei in ispconfig 3.0.3.2 auf meinen Servern.
 

stefanw

New Member
Nein, ich habe keinen Domain Alias sondern die Domains, in diesem Fall 4 Domains, als richtige E-Mail-Domain angelegt. Jetzt habe ich das sowohl mit E-Mail-Alias, als auch mit Domain Alias auspobiert und es klappt nicht. Sobald eine E-Mail an die Alias-Adresse geschickt wird, wird eine Mailbox dafür angelegt.
 

stefanw

New Member
Ach ja, in dem zweiten Fall gibt es nur eine E-Mail-Domain, auch da hat ja die Weiterleitung nicht funktioniert.
 

Till

Administrator
Welches Tutorial hast Du zur Installation verwendet? Hast Du irgend was selbst an der postfix Konfiguration geändert?
 

stefanw

New Member
Ich habe dieses genommen:
http://www.howtoforge.de/howto/der-perfekte-server-debian-lenny-debian-50-ispconfig-3/

und am Postfix habe ich in der main.cf was verändert, genau dieses:

Code:
smtpd_recipient_restrictions =
    permit_mynetworks,
    permit_sasl_authenticated,
    check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf,
    reject_unauth_destination,
    check_policy_service inet:127.0.0.1:10023,
    reject_non_fqdn_sender,
    reject_non_fqdn_recipient,
    reject_unknown_recipient_domain,
    reject_non_fqdn_hostname,
    reject_invalid_hostname,
    reject_rbl_client ix.dnsbl.manitu.net,
    reject_rbl_client sbl.spamhaus.org
smtpd_helo_restrictions =
        check_client_access hash:/var/lib/pop-before-smtp/hosts,
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_non_fqdn_hostname,
    reject_invalid_hostname,
        permit
aber daran wird es nicht liegen
 

Till

Administrator
Ich vermute mal es liegt an Deinen Änderungen in der main.cf. Ändere bitte mal die recipient_restructions wieder auf den Default zurück:

Code:
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
und kommentier die smtpd_helo_restrictions aus und teste dann nochmal. Denn eine falsche Reihenfolge der Parameter kann in Postfix dazu führen dass er alle Emails annimmt, auch für nicht existente Mailboxen und diese dann automatisch anlegt.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.