stats

Till

Administrator
Die .htpasswd Datei liegt nicht direkt im stats Verzeichnis, sondern im Untersten Verzeichnis der Webseite. Gib bitte mal den folgenden Befehl ein, um den Inhalt der Datei zu erhalten:

cat /home/www/web11/.htpasswd
 

Till

Administrator
Das sieht soweit ok aus. was mich etqas irritiert, ist das erste Zeichen desa Passwortes. Hast Du mal versucht, mit dem htpasswd Befehl manuell ein neues Passwort in der .htpasswd Datei zu setzen?
 

planet_fox

Super-Moderator
Neuigkeiten

mit htpasswd passiert nix. was mir aufgefallen in einem anderen web, alle funktioniert dann änder ich den administrator und das passwort. Keine reaktion obwohl ich im ispconfig auch die tabellen checken lasse. Ich starte Mysql neu und ispconfig, keine reaktion.
 

Till

Administrator
Das mit dem Mailserver ist etwas ganz anderes, da der Mailserver gegen /etc/passwd authentifiziert und die Datei sofort geändert wird.
 

planet_fox

Super-Moderator
So Till ich hab das Passwort manual geändert, geliche reaktion danach.
Aber ich hab mal einfach in einem web die htacess gelöscht so wenn ich dann
www.meinweb.de/stats/ dann kommt auch wieder Fehler Seite ned gefunden. Aber wenn ich nun www.meinweb.de/stats/index.html eingebe dann gehts.
Diese Problem hab ich aber nur in 10 webs circa. Der unterschied zum rest der seiten diese 10 webs waren vorher woanders gehostet, ich find aber weder in den htaccess dateien nen fehler noch benurtzer probleme. Ich glaub ich seh den

 

Till

Administrator
Schau bitte mal in das apache direktiven Feld und falls vorhanden in die .htaccess Datei in Root-Verzeichnis der webseite, da muss irgendwo eine "DirectoryIndex" Direktive drin sein, bei der "index.html" in der Liste fehlt.
 

planet_fox

Super-Moderator
in den apache direktiven von ispconfig bei den webs is index.hml und index.htm drin.

Aber ich was gefunden, alle seiten die dieses Problem haben etwas gemeinsam es sind alle Joomla Seiten, so und da ist über all ein htacess drin habe ich jetzt erst gesehen nachdem du gesagt hast ich soll im root verzeichnis mal schauen. hab mal das ganze mit ls -la durch geschaut und dann ist in dieser .htacess im root verzeichnis folgender inhalt

Code:
<Files .htaccess>
order deny,allow
deny from all
</Files>
# ---------------------------------------
[COLOR=Red]DirectoryIndex index.php [/COLOR]
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]
RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$  [NC]
RewriteRule ^(.*) index.php

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a ********** tag in URL
RewriteCond %{QUERY_STRING} (<|%3C).*script.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits
natürlich muss da dann das rein

Code:
[COLOR=Red][COLOR=Black]DirectoryIndex index.php[/COLOR] index.html[/COLOR]

Ich denke mal die sache ist geschichte, passiert nur bei seiten die seo benutzen.
 

Werbung

Top