RKHunter ist nicht installiert, deshalb gibt es keine Protokolldatei

timur

Member
Hallo zusammen,

einen schönes Wochenende euch allen ich hoffe ihr könnt es schon genießen :)

Leider habe ein kleines Problem weiss nicht woran es hängt aber wie der Titel es schon besagt kriege ich in ispconfig 3 mit debian 10 die Meldung:

RKHunter ist nicht installiert, deshalb gibt es keine Protokolldatei

doch auf dem Server läuft Rkhunter das letzte das ich tat war Phpmyadmin zu upgraden weiss aber nicht ob der Fehler daher resultiert...

Vielen Dank jetzt schonmal wer sich trotz Füsse hochlegen trotzdem die eine oder andere Minute nimmt um mir weiter zu helfen :)
 

Till

Administrator
Ruf rkhunter mal manuell auf um zu sehen ob er irgendwelche fehler ausgibt. Es muss ja einen Grund geben, warum er kein log mehr schreibt, denn das ist es im Grunde was der fehler in ISPConfig besagt.
 

timur

Member
Hallo Till,

danke für die Antwort!

Hätte ich mal dazu schreiben sollen rkhunter läuft ganz normal die logs sind auch vorhanden und keine Auffälligkeiten zu erkennen.
Deswegen verstehe ich das nicht ...

ich kann auch gerne die log mal posten wenn das wünschenswert ist (?)
 

Till

Administrator
Ja, ist richtig. Owner des Logs spielt keine Rolle. Such mal in der Tabelle sys_cron nach dem bzw. deb Einträgen für rkhunter und lösch die mal.
 

timur

Member
Ich wollte dies grad über phpmyadmin machen, nur musste ich festellen das ich dort ein error 500 hab ich schau grad woran es liegt... das hab ich wohl mist gebaut beim upgrade

aber mysql läuft
 

Till

Administrator
Sollte im globalen apache error.log stehen, woran es liegt. Vielleicht PHP Version zu neu für phpmyadmin oder fehlende PHP Module?
 

timur

Member
Da stand folgendes:

Code:
PHP Parse error:  syntax error, unexpected 'const' (T_CONST), expecting variable (T_VARIABLE) in /usr/share/php/PhpMyAdmin/MoTranslator/Translator.php on line 58, referer: https://domain.com:8000/index.php
Dann habe ich gelesen das man bei debian 10 auf php 7.3 umstellen soll also habe ich diese befehle dafür benutzt:

update-alternatives --config php
update-alternatives --config php-cgi


Leider keine Veränderung... :(

PHP 7.3.22-1+0~20200909.67+debian10~1.gbpdd7b72 (cli) (built: Sep 9 2020 06:55:18) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.22, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.3.22-1+0~20200909.67+debian10~1.gbpdd7b72, Copyright (c) 1999-2018, by Zend Technologies
with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans
 

Till

Administrator
Nutzt Du apache mpm_prefork (das wäre der standard)? Wenn ja, dann läuft phpmyadmin sicherlich über mod_php, das heißt Du müsstest das libapache .... modul für PHP 7.3 installieren stattd em für 7.4. Oder aber, Du bleibst bei 7.4 und installierst Dir ein aktuelles phpmyadmin 'von hand' in eine website.
 

timur

Member
Hab es nicht früher geschaft zu antworten..

Also libapache ist aktiviert...


Oder aber, Du bleibst bei 7.4 und installierst Dir ein aktuelles phpmyadmin 'von hand' in eine website.
Ich glaube das hat mir die Lage gebracht in der ich grade stecke.
Ich bin nach dieser weise vorgegangen:

this will update phpMyAdmin to the current latest stable release 4.9.2

Code:
sudo mv /usr/share/phpmyadmin/ /usr/share/phpmyadmin.bak
sudo mkdir /usr/share/phpmyadmin/
cd /usr/share/phpmyadmin/
sudo wget https://files.phpmyadmin.net/phpMyAdmin/4.9.2/phpMyAdmin-4.9.2-all-languages.tar.gz
sudo tar xzf phpMyAdmin-4.9.2-all-languages.tar.gz
sudo mv phpMyAdmin-4.9.2-all-languages/* /usr/share/phpmyadmin
sudo nano /usr/share/phpmyadmin/libraries/vendor_config.php
search for the lines containing TEMP_DIR and CONFIG_DIR and change them to:
Code:
define('TEMP_DIR', '/var/lib/phpmyadmin/tmp/');
define('CONFIG_DIR', '/etc/phpmyadmin/');
save the file, then to clean up:
Code:
sudo rm /usr/share/phpmyadmin/phpMyAdmin-4.9.2-all-languages.tar.gz
sudo rm -rf /usr/share/phpmyadmin/phpMyAdmin-4.9.2-all-languages
then once you've tested phpMyAdmin and are sure everythings ok, you can remove the backup folder:
Quelle: https://www.howtoforge.com/community/threads/solved-update-phpmyadmin-and-mysql-debian-10.83459/

Dann hatte alle funktioniert auch phpmyadmin.
Dann macht man üblicherweise apt-get update && upgrade auf dem Server und da hatte Linux rumgemäckert das phpmyadmin aktualisiert werden muss und darauf hin hatte ich leider irgendeine Seite die ich jetzt nicht mehr weiss was gefunden wo man ein deb quelle hinzufügt und dann einfach über upgrade phpmyadmin aktualisiert

Ich glaube das ist der Grund warum jetzt das ganze nicht funktioniert.
 

timur

Member
Ich möchte wirklich nicht pushen (auch wenn ich es grad mit diesem Beitrag tue).

Ich bräuchte eine Lösung für dieses Problem kannst du da mir ein ein Tipp @Till vielleicht ?

Sollte ich vielleicht phpmyadmin deinstallieren und dann erneut installieren laut Anleitung von Ispconfig ?
 

timur

Member
Update: hab phpmyadmin hinbekommen jetzt zum ursprünglichen Thema und das wäre Rkhunter.
Wieso findet er die Log nicht? Sie ist in /var/log/rkhunter.log ...

@Till meinst du das hier löschen ?

sys_cron.png


Danke!
 
Zuletzt bearbeitet:

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.