Nach Anlegen neuer Domain totales Chaos!

Till

Administrator
Der ISPConfig vhost läuft auf port 8080, der kann garnicht auf andere webseite umleiten, die domain ist sogar komplett egal da der ispconfig vhost sie nicht enthält und unabhängig vom domain namen auf alle aufrufe auf port 8080 hört, Du kannst sogar einfach nur die Ip im browser eingeben mit :8080 am ende. Bist Du denn sicher dass Du die URL mit 8080 am Ende aufrufst und dass Du den vhost nicht manuell geändert hast und port 8080 daraus entfernt hast?
 

Geronino

New Member
So, da man ja nie aufhören kann...
Ich habe in der meine-domain.vhost statt der IP einen Stern in den virtHost gesetzt.
Jetzt ruft er ispconfig.meine-domain.de auf ! aber sagt "Not Found".
Wo definiert er denn jetzt ob er die mit https also verschlüsselt oder unverschlüsselt aufruft.
Er leitet immer um auf https und meckert wieder mal das Zertifikat an!
 

Geronino

New Member
So, ich habe jetzt in der vhosts die "documentRoot" wieder einkommentiert, den PORT auf 8080 gesestzt und er zeigt mir jetzt wenn ich IP:8080 oder ispconf.domain.de:8080 aufrufe den Quelltext: <php? mit dem copyright vom Entwickler!
Aber er jagt es nicht durch den Interpreter?
In ports hatte ich listen 8080 eingetragen, das macht er ja nun. WIe kann ich ihn jetzt noch überreden, die Seite durch den PHP Interpreter zu schicken???
Bzw. in der vhost habe ich einmal den Eintrag Document root /var/www/ispconfig und einmal
<Directory /var/www/isp...
Wenn ich ersteren auskommentiere zeigt er mir die Standardfehlerseite vom Apache an?
Wenn ich beide drinne lasse nur den Code und wenn ich letztere Auskommentiere nur eine weiße Seite.
???
 

Till

Administrator
Dann muss Dein System ja von Anfang an ziemlich verbastelt gewesen sein, wenn es nicht auf Port 8080 funktioniert hat. Ich habe Dir mal das komplette /etc/apache2 von einem sauberen und funktionierenden ISPConfig setup unter Debian 9 angehängt, damit Du es mit Deeinem setup vergleichen kannst.

Ist ein tar.gz nochmal als .zip komprimiert, damit ich es anhängen konnte hier im Forum. also erst entzippen und dann mit tar xfz ..... entpacken.
 

Anhänge

Geronino

New Member
Hallom Till,
das ist ja super cool! Da sage ich nochmals Tausend Dank !!! ;) Echeter Hammer von Dir.
Ein Unglück kommt selten allein.
Ich hatte noch Probleme mit dem Auto erstmal und muss(te) auch noch arbeiten vor den Feierttagen.
Jetzt in der Mittagspause mal wieder kurz Zeit mich zu melden.
Ich hatte ja das update.sh script ausgeführt und dabei hat es wohl auch einige scripte geändert gehabt bzw. Bercehtigungen geändert ??? Ich bin kjetzt erstmal wieder drinne im ispconfig, aber wie Du richtig erkannt hast,
war da wohl von Anfang an der Wurm drinne. Deswegen würde ich es jetzt übner die Feiertage gerne nochmal komplett neu und richtig machen. Also am liebsten über 8080! Bzw. was wäre mit ssl über 443???
Die Seiten laufen gerade alle nicht, weil er die SSL Zertifikate anmeckert!
Er nimmt laut apache error log immer den erstenm virtual host den er finden kann.
Es gibt unter /var/backuüp überigens ein paar backup Dateien/Verzeichnisse.
Also /etc komplett sowie usr/local/ispconfig komplett. Aus dem /etc habe ich mir die vhost Dateien geholt und verglichen.
Irgendetwas passt mit dem Port 8080 nicht. ufw ist offen. Kann das sein dass der Router oder gar mein Provider den Blockt?
Ich schaue mir heute Abend erstmal Dein tar.gz. an. Super ! Vielen, lieben Dank nochmal dafür.
Grüße und schöne Festtage an Alle
Gero
 

Werbung

Top