Mehrere IP's auf einem Server mit einer Netzwerkkarte

SicKk

New Member
Hallo,

ich bin seit tagen Foren am durchforsten und finde keine richtige Lösung.
Ich finde das es gut für viele wäre wenn mal erklärt wäre wie man mehrere IP's auf einer Netzwerkkarte anlegt und wie das ganze mit einem Apache2 Server konfiguration eingestellt werden kann.
Die einfache Art wäre natürlich wenn die IP's so aussehen würden z.B. 10.10.10.200 10.10.10.201 aber was wirklich interessiert ist wenn die IP's so aussehen 10.10.10.200 10.10.99.150.
Die frage stellt sich bei den Leuten die solche Seiten durchforsten,wie mich, was passiert mit der netmask und broadcast Adresse.

Wäre doch eine interessante Angelegenheit es mal durchzunehemen
 

Till

Administrator
Das ist je nach Linux Distribution unterschiedlich, Du müsstest also erstmal sagen, welche Distribution Du benutzt.
 

SicKk

New Member
Das ist je nach Linux Distribution unterschiedlich, Du müsstest also erstmal sagen, welche Distribution Du benutzt.
Das ist klar das es von Distibution zu Distribution unterschiedlich ist. Ich benutze z.B. Ubuntu 8.04 und Debian 6 Server.
Es wäre nützlich solche Howto's für die gängigen Serverdistributionen zu erstellen. Falls ich es in den nächsten Tagen schaffen sollte, werde ich's für Ubuntu 8.04 posten. Aber ich bin darauf gestoßen das es ein Bug sein soll warum es nicht Funktioniert.
 

Falcon37

New Member
Unter Debian:
vi /etc/network/interfaces

so sollte das dann aussehen:

Code:
### p0rn.sux.cc
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto  eth0
iface eth0 inet static
  address   XX.XX.XX.XXX
  broadcast XX.XX.XX.XXX
  netmask   XX.XX.XX.XXX
  gateway   XX.XX.XX.XXX

auto eth0:0
iface eth0:0 inet static
  address XX.XX.XX.XXX
  netmask XX.XX.XX.XXX
  gateway XX.XX.XX.XXX

auto eth0:1
iface eth0:1 inet static
  address XX.XX.XX.XXX
  netmask XX.XX.XX.XXX
  gateway XX.XX.XX.XXX

auto eth0:2
iface eth0:2 inet static
  address XX.XX.XX.XXX
  netmask XX.XX.XX.XXX
  gateway XX.XX.XX.XXX

# usw.
danach Apache neu starten. Im jeweiligen Panel, falls vorhanden, nicht vergessen das dort wenn nötig auch einzutragen. Hab so früher z.B. bei Hetzner ganze Subnetze erfolgreich kofiguriert.
Mein aktueller einer Provider softlayer.com bietet an das diese gleich nach der installation automatisch eingetragen und kofig. werden (auch wenn man wie ich mehr als eine netzwerkarte hat) ist's praktisch, aber keine ahnung wie es bei anderen anbietern mit sowas zur zeit aussieht. netmask und broadcast Adresse kriegt man i. d. R. doch vom Anbieter einfach alles korrekt eintragen, falls nicht mal in der interfaces schauen.
 
Zuletzt bearbeitet:

SicKk

New Member
Unter Debian:
vi /etc/network/interfaces

so sollte das dann aussehen:

Code:
### p0rn.sux.cc
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto  eth0
iface eth0 inet static
  address   XX.XX.XX.XXX
  broadcast XX.XX.XX.XXX
  netmask   XX.XX.XX.XXX
  gateway   XX.XX.XX.XXX

auto eth0:0
iface eth0:0 inet static
  address XX.XX.XX.XXX
  netmask XX.XX.XX.XXX
  gateway XX.XX.XX.XXX

auto eth0:1
iface eth0:1 inet static
  address XX.XX.XX.XXX
  netmask XX.XX.XX.XXX
  gateway XX.XX.XX.XXX

auto eth0:2
iface eth0:2 inet static
  address XX.XX.XX.XXX
  netmask XX.XX.XX.XXX
  gateway XX.XX.XX.XXX

# usw.
danach Apache neu starten. Im jeweiligen Panel, falls vorhanden, nicht vergessen das dort wenn nötig auch einzutragen. Hab so früher z.B. bei Hetzner ganze Subnetze erfolgreich kofiguriert.
Mein aktueller einer Provider softlayer.com bietet an das diese gleich nach der installation automatisch eingetragen und kofig. werden (auch wenn man wie ich mehr als eine netzwerkarte hat) ist's praktisch, aber keine ahnung wie es bei anderen anbietern mit sowas zur zeit aussieht. netmask und broadcast Adresse kriegt man i. d. R. doch vom Anbieter einfach alles korrekt eintragen, falls nicht mal in der interfaces schauen.
und genau diese einstellung funktioniert nicht bei meinen ubuntu server. wenn die ip eingestellt ist, sind die domains die auf der 2. IP eingestellt sind für ca. 5 minuten erreichbar und danach nicht mehr. wenn ich alles umstelle damit beide IP's funktionieren, geht der apache in die knie und dann dauert es eine ewigkeit bis die seiten geladen sind.
 

Falcon37

New Member
haste nen vserver oder ein spezielles setup? meine kofig. richtet sich wirklich nur an debian; unbuntu hatte ich so auch mal ein problem mit ständigen abstürtzen (allerdings im vserver mit 1 gb ram).
 

SicKk

New Member
das ist ein root server mit 16gb ram, ganz normale einstellung alles aus repositories installiert.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.