Mailman: Listen anlegen über ispconfig buggy

larsik78

New Member
Ich bin verwirrt. Ich habe einen funktionsfähig laufenden Mailman installiert und ISPConfig und Server etc. alles nach perfektem Server guideline installiert.

Jetzt zu meinem Problem: wenn ich eine neue Mailingliste für eine Domain anlege, funktioniert erst einmal alles tadellos. Aber im Mailman-Admin Bereich sind manche Menüseiten (Mitgliederlisten) nicht auf die Domain verlinkt - sondern auf die Domainadresse meines Servers... und dann kommt es zum Logout.

Hat irgendjemand eine Idee, was ich falsch gemacht haben könnte?

DANKE vorab.

Aktualisierung: noch ein Fehler: wenn ich die Mailingliste anlege, erhält der Admin die Bestätigungsmail mit der richtigen Adresse, also Mailingliste@domain.de und dem Link auf den richtigen Adminbereich domain.de/cgi-bin/mailman/admin/mailingliste . Wenn dann aber Mitglieder eingetragen werden, erhalten diese Mails, in denen eine andere Domain angegeben ist, also server-domain.de/cgi-bin/mailman/admin/mailingliste ...

Ich bin verwirrt. Freue mich über Hinweise.
 
Zuletzt bearbeitet:

Till

Administrator
Hast Du Dich denn auch über die Adresse Deines servers eingelogged? Denn das mailman interface liegt auf der adresse des servers und nicht auf einer kundendomain. Daher ist es auch völlig richtig das alle Links auf die server domain laufen, denn dort ist es installiert. Ich vermute daher dass Dein Session logout daher rührt, dass Du dich fälschlicherweise über eine andere Domain eingelogged hast und nicht über die server domain.
 

larsik78

New Member
Mmmh... das heißt, wenn Kunden sich eine Mailingliste anlegen, können sie sie trotzdem nur unter meiner Serverdomain administrieren?

Aber die Bestätigungsmail "Willkommen bei deiner Mailingliste" verweist auf die Kundendomain... ??
 

Till

Administrator
Du bist der Provider, also läuft das Mailman System unter Deiner server domain. Die Mailingliste ist für die kunden domain, daher schreibt mailman auch den Domain namen der mailinglisten Domain in den text.
 

larsik78

New Member
Ja aber darauf will ich doch hinaus: in der "Willkommen"-Mail ist die Kundendomain, in der Registrierungsbestätigung für Mitglieder steht jetzt aber die Server-Domain! Und wenn der Kunde sich unter der Kundendomain einloggt, passieren besagte Fehler (ausloggen beim Blättern, weil andere Domain verlinkt ist) - da ist etwas durcheinander geraten und ich weiß nicht wie und warum...
 

larsik78

New Member
Ja aber darauf will ich doch hinaus: in der "Willkommen"-Mail ist die Kundendomain, in der Registrierungsbestätigung für Mitglieder steht jetzt aber die Server-Domain! Und wenn der Kunde sich unter der Kundendomain einloggt, passieren besagte Fehler (ausloggen beim Blättern, weil andere Domain verlinkt ist) - da ist etwas durcheinander geraten und ich weiß nicht wie und warum...
Auf unserem alten Server funktionierte es ja auch - alle Links, Adresse der Mailingliste etc. wurden unter der Kundendomain angegeben. Jetzt ist es aber durcheinander. Any ideas?
 

Till

Administrator
An der Mailman Integration wurde meines Wissens nachs eit Jahren nichts mehr geändert, da es kaum noch jemand einsetzt. Ich setze es selbst auch nicht ein, daher kann ich da nichts weiter zu sagen.
 

Frank77

Member
Frage am Rande: was gibt es für Alternativen zu Mailman, die in ISPconfig integriert oder zumindest integrierbar sind? Wenn Mailman schon lange keiner mehr benutzt, was wird stattdessen benutzt?
 

win_tho

Member
Hallo zusammen,

bin ebenfalls Mailman geplagter Administrator. Grundproblem auf meinen Servern war bislang immer, dass nach einem Anlegen einer Lister über ISPConfig, das Postfix File nicht neu gemapt wurde. Das habe ich immer durch einen Cronjob gelöst:

*/5 * * * * postmap /var/lib/mailman/data/virtual-mailman >> /dev/null 2>&0

Jetzt am Wochenende ging es auf einem neuen Server (Ubuntu 18.04) plötzlich auch ohne diesen Workaround.

Zweites Problem: Das Webinterface: Hier sind oftmals die Einstellungen der Webseite entscheidend. SuExec und PHP-Einbindung hatten bei mir schon Auswirkungen, ob das Mailman Panel erreichbar war oder nicht.

Grundsätzlich finde ich diese Software total veraltet, Problem ist jedoch, dass die Kundschaft sie fordert und ich auch noch keine wirkliche Alternative gefunden habe.

Selbst wenn auf dem eigenen Server alles läuft, gehen die Probleme bei den SPAM-Filtern ja weiter. Sichwort SPF, etc...
 

Laubie

Member

Standard URL für Mailman ändern​

Da ISPConfig zwar in der Lage ist, Mailman-Listen anzulegen, diese dann aber auf der Maildomain auch administriert werden wollen, muss man nach der Installation die url der Mailingliste noch mal anpassen:

/usr/lib/mailman/bin/withlist -l -r fix_url Listen-Name --urlhost=neueURL

Ich nutze auf meinen Produktivrechnern mittlerweile das neue Mailman3, da gibt es diese Probleme nicht mehr. Es kann nur nicht über ISPConfig administriert werden.
 

larsik78

New Member
Ich werde fast verrückt... ich versuche immer wieder in der mm_cfg.py die DEFAULT_URL_PATTERN auf https (anstelle von http) umzustellen... aber irgendein Prozess überschreibt die Datei immer wieder.
Und damit funktionieren die Mailinglisten einfach nicht. Immer wieder Fehlermeldungen, weil keine SSL - Verbindung aufgebaut wird.

Hat irgendjemand eine Idee?? Bitte!
 

Till

Administrator
Du musst das Template der Datei mm_cfg.py.master editieren damit Änderungen erhalten bleiben. Du findest die Datei wie alle anderen config templates auch unter /usr/local/ispconfig/server/conf/ und das geänderte Template muss dann unter /usr/local/ispconfig/server/conf-custom/ gespeichert werden.
 

larsik78

New Member
Danke Dir. Das hilft - aber nur begrenzt. Https:// übernimmt er jetzt. Aber beim Anlegen von neuen Listen für eine bestimmte Domain werden nur Fehler 500 ausgeworfen, wenn ich auf den verschickten Link in der Bestätigungsmail klicke... :-(
 

larsik78

New Member
Da ist leider nichts hilfreiches zu finden. Aber das Problem stellt sich so dar:

die angelegten Listen erreiche ich über eine andere Domain (die erste, unter der ich Mailman je genutzt habe) - aber innerhalb des Admin-Bereichs werden in den Links UNTERSCHIEDLICHE Domains verwendet - z.B. beim Listenarchiv die eigentlich "richtige", bei den Mitgliedern die falsche etc. .

Bin ausreichend verwirrt und haben schon darüber nachgedacht, Mailman nochmal komplett zu deinstallieren und neu aufzusetzen...
(auch ein fix_url mit withlist löst das Problem nicht...)
 

Werbung

Top