ISPConfig Installation

rfnx

New Member
Ich versuche weit einigen Tagen ISPConfig mit dem Autoinstall Script auf meinem Root Server zu installieren und habe da einige Probleme:

Der GPG Key der PHP Rerositories war nicht mehr aktuell:

GPG error: https://packages.sury.org/php buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743

Dies lies sich noch beheben indem ich den aktuellen Key geholt habe mit:

sudo wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg

Nun endet die Installation aber immernoch mit Fehlern, und hier weiss ich nicht mehr weiter:

Error: The following command failed: apt-get -y install hhvm

-----------------------------------------
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
hhvm : Depends: libboost-context1.62.0 but it is not installable
Depends: libboost-filesystem1.62.0 but it is not installable
Depends: libboost-program-options1.62.0 but it is not installable
Depends: libboost-system1.62.0 but it is not installable
Depends: libboost-thread1.62.0 but it is not installable
Depends: libcurl3 (>= 7.28.0) but it is not installable
Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
Depends: libevent-pthreads-2.0-5 (>= 2.0.10-stable) but it is not installable
Depends: libicu57 (>= 57.1-1~) but it is not installable
Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not installable
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not installable
Depends: libonig4 (>= 5.9.5) but it is not installable
Depends: libre2-3 (>= 20160901) but it is not installable
Depends: libsodium18 (>= 1.0.10) but it is not installable
Depends: libvpx4 (>= 1.6.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

HHVM benötige ich weil ich Mediawiki auf einer Domain laufen lasse und kann darauf eigentlich nicht verzichten.

Kann mir da jemand helfen damit ich ISPConfig wieder laufen lassen kann?
 
Zuletzt bearbeitet:

Till

Administrator
Welches Autoinstall script verwendest Du?

Der PHP support in HHVM wurde schon vor längerer Zeit eingestellt und HHVM ist nicht schneller als z.B. PHP 7.4. Zu PHP 5 Zeiten machte HHVM noch Sinn, seit es PHP 7.x gibt aber nicht mehr.

HHVM Support in ISPConfig wurde auch schon lange eingestellt.
 
Zuletzt bearbeitet:

rfnx

New Member
PS hab momentan Debian 10 am laufen. aber auch 11,12 oder 13 wuedern mich nicht stoeren insofern auch alles weiter supported ist. will nebenbei nmoch Guacamole laufen lassen fuer desktop remote support.
 

rfnx

New Member
I found the correct install script, everything is working well now ... Thank you an have a nice time
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.