[GELÖST] Wahrscheinlich DNS Probleme - HELP :(

Hallo liebe Community :)

Also, ich wollte mir lokal einen Testserver aufbauen mit einem Nameservice - ich kriegs aber seit Tagen nicht hin :mad:

Folgendes:
1. Ich habe mit Virtualbox ein Ubuntu 18.04 - darauf ist ISP Config. Sagen wir mal diese virtuelle Maschine, die bridged im lokalen Netzwerk ist, hat die IP 192.168.199.7 und den FQDN webqa1.domain1.local. Das Gerät ist auch im lokalen Router (Fitzbox) sichtbar.

2. Auf dem Gastgebergerät (IP 192.168.199.2) habe ich der Netzwerkconfig 2 DNSserver angegeben: Die Fritzbox (die wiederum DNS des Webproviders nutzt) und den virtuellen Server webqa1.domain1.local.

3. Auf diesem virtuellen Server habe ich nun eine DNS Zone + 1 Webhost angelegt - der 100%ig wunderbar funktioniert. Hier die DNS Records dazu aus ISPC:
Code:
Aktiv     Typ     Name     Daten     Priorität     TTL    
Ja     A     domain1.local.     192.168.199.7     0     3600    
Ja     A     portal     192.168.199.7     0     3600    
Ja     A     sharepoint.portal     192.168.199.7     0     3600    
Ja     A     webqa1.domain1.local.     192.168.199.7     0     3600    
Ja     CNAME     www     domain1.local.     0     3600    
Ja     MX     domain1.local.     webqa1.domain1.local.     10     3600    
Ja     NS     domain1.local.     webqa1.domain1.local.     0     3600    
Ja     PTR     7.199.168.192.in-addr.arpa.     webqa1.domain1.local     0     3600
Und die /etc/hosts des virtuellen Servers:
Code:
27.0.0.1 localhost  webqa1.domain1.local
192.168.199.7 webqa1.domain1.local
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
Funktioniert wunderbar :)

Das Problem:
Die anderen Webseiten funktionieren alle nicht richtig:
1. Wenn ich https://domin2.local aufrufe, wird die Website nicht gefunden.
2. Wenn ich aber https://www.domin2.local aufrufe, kommt die Website. Eigentlich habe ich ein Redirect von nonWWW auf www.

Ich bin sicher daß ich da im DNS alles falsch mache ws man falsch machen kann :( Hier die DNS Records für domain2:
Code:
Aktiv     Typ     Name     Daten     Priorität     TTL    
Ja     A     domain2.local.     192.168.199.7     0     3600    
Ja     A     home2     192.168.199.7     0     3600    
Ja     A     webqa1.domain1.local.     192.168.199.7     0     3600    
Ja     CNAME     www     domain2.local.     0     3600    
Ja     NS     domain2.local.     webqa1.domain1.local.     0     3600
Ich habe da auch alles mögliche herum probiert aber es geht einfach nicht:
1. domain2.local ist nicht abrufbar, kann nicht redirecten....
2. www.domain2.local redirected sauber von http auf https und ist auch sonst sauber abrufbar
3. domain2.local ist auch nicht vom Gastsystem aus pingbar, aber www,domain2.local ist pingbar - die Antwort des Pings ist aber irgendwie komisch:
Code:
# ping auf domain2.local
cis-ws1:/home/nuria # ping -d -v domain2.local
ping: socket: Keine Berechtigung, attempting raw socket...
ping: socket: Keine Berechtigung, attempting raw socket...
#
# ping auf www.domain2.local
ping -d -v www.domain2.local
ping: socket: Keine Berechtigung, attempting raw socket...
ping: socket: Keine Berechtigung, attempting raw socket...
PING domain2.local (192.168.199.7) 56(84) bytes of data.
64 bytes from domain1.local (192.168.199.7): icmp_seq=1 ttl=64 time=0.277 ms
64 bytes from domain1.local (192.168.199.7): icmp_seq=2 ttl=64 time=0.274 ms
64 bytes from domain1.local (192.168.199.7): icmp_seq=3 ttl=64 time=0.280 ms
Anmerkung: Es gibt nur einen Primary DNS Server und keinen secondary, was bei einem lokalen Server aber kein Problem sein dürfte.

Mein Ziel wäre es erstmal, daß auch die anderen Websites sauber funktionieren und nicht nur domain1.local.

Einen Fehler in den Apache Host Configs schließe ich aus, denn ich hatte das vorher über die /etc/host des Gastgeber- Systems gehandhabt, wo alles toll funktioniert hat. Das kann ich aber so nicht mehr machen, weil ich ein paar Sachen mit MX Records, DKIM etc probieren möchte, was man über die lokale Hostdatei ja nicht kann.

Ausserdem möchte ich den DNS Server am Laufen haben.

Vielleicht kann mir ja jemand helfen ?

Lieben Dank :)
 
Danke aber ehrlich gesagt hilft mir das nicht wirklich - in dem Tuturial sind ja mehrere Server mit eigenen IPs im Spiel. Ich habe nur einen mit nur einen IP.

Soll ich jetzt hier nur eine Zonendatei anlegen und da alles rein schreiben - in dem Fall wahrscheinlich immer FQDN nehmen ? Oder lege ich für jede Website eine eigene Zonendatei an mit Verweis auf den einen Nameserver den ich habe ? Bis jetzt ging eigentlich immer garnichts bzgl domain2, wenn ich alles in eine Zonendatei (die von webqa1.domain1.local) einpflege

Auffällig fand ich übrigens, daß ein grep named /var/log/syslog | grep could folgendes ergab:
Code:
Apr 25 00:01:02 webqa1 named[584]: couldn't mkdir '//run/named': Permission denied
Apr 25 00:01:02 webqa1 named[584]: couldn't mkdir '//run/named': Permission denied
Apr 25 00:01:02 webqa1 named[584]: could not create //run/named/session.key
Diese Einträge habe fast im Minutentakt
 
Zuletzt bearbeitet:
Nein... :(
tail -f /var/log/syslog | grep named ergibt:
Code:
Apr 25 20:01:27 webqa1 kernel: [20307.545764] eth0: renamed from veth48f7e23
Apr 25 20:01:29 webqa1 named[16988]: listening on IPv6 interface veth7f5e739, fe80::d0c8:f4ff:febf:cc28%863#53
Apr 25 20:01:29 webqa1 kernel: [20309.576858] veth48f7e23: renamed from eth0
Apr 25 20:01:29 webqa1 named[16988]: no longer listening on fe80::d0c8:f4ff:febf:cc28%863#53
Apr 25 20:02:21 webqa1 kernel: [20362.040848] vethf85dbb7: renamed from eth0
Apr 25 20:02:21 webqa1 named[16988]: no longer listening on fe80::dca8:3aff:febf:6d03%857#53
Apr 25 20:02:23 webqa1 kernel: [20363.306973] eth0: renamed from vethd8e4c11
Apr 25 20:02:24 webqa1 named[16988]: listening on IPv6 interface veth44f4bdf, fe80::c042:3cff:fee1:67d9%865#53
Apr 25 20:02:30 webqa1 kernel: [20370.364276] eth0: renamed from veth8aa351f
Apr 25 20:02:31 webqa1 kernel: [20372.097802] veth8aa351f: renamed from eth0
Dann ein:
Code:
systemctl restart named
tail -f /var/log/syslog | grep named
ja, ergibt nun:
Code:
Apr 25 20:05:23 webqa1 named[137760]: zone 0.in-addr.arpa/IN: loaded serial 1
Apr 25 20:05:23 webqa1 named[137760]: zone 255.in-addr.arpa/IN: loaded serial 1
Apr 25 20:05:23 webqa1 named[137760]: zone localhost/IN: loaded serial 2
Apr 25 20:05:23 webqa1 named[137760]: /etc/bind/pri.domain1.local:17: ignoring out-of-zone data (7.199.168.192.in-addr.arpa)
Apr 25 20:05:23 webqa1 named[137760]: /etc/bind/pri.domain1.local:20: ignoring out-of-zone data (domain2.local)
Apr 25 20:05:23 webqa1 named[137760]: /etc/bind/pri.domain1.local:21: ignoring out-of-zone data (www.domain2.local)
Apr 25 20:05:23 webqa1 named[137760]: zone domain1.local/IN: loaded serial 2021042524
Apr 25 20:05:23 webqa1 named[137760]: all zones loaded
Apr 25 20:05:23 webqa1 named[137760]: running
Apr 25 20:05:23 webqa1 named[137760]: resolver priming query complete
Apr 25 20:05:38 webqa1 kernel: [20558.940882] eth0: renamed from vethc66c8ae
Apr 25 20:05:40 webqa1 named[137760]: listening on IPv6 interface veth960af3b, fe80::bc65:e7ff:fe03:db81%873#53
Apr 25 20:05:40 webqa1 kernel: [20560.851088] vethc66c8ae: renamed from eth0
Apr 25 20:05:40 webqa1 named[137760]: no longer listening on fe80::bc65:e7ff:fe03:db81%873#53
Apr 25 20:06:15 webqa1 kernel: [20596.161436] vethd8e4c11: renamed from eth0
Apr 25 20:06:16 webqa1 named[137760]: no longer listening on fe80::c042:3cff:fee1:67d9%865#53
Apr 25 20:06:17 webqa1 kernel: [20597.408207] eth0: renamed from vetha4f02cc
Apr 25 20:06:18 webqa1 named[137760]: listening on IPv6 interface veth5a341f6, fe80::ac30:93ff:fe6d:97c3%875#53
Apr 25 20:06:41 webqa1 kernel: [20622.131044] eth0: renamed from veth00b6f0c
Apr 25 20:06:43 webqa1 named[137760]: listening on IPv6 interface veth0e85744, fe80::40d:50ff:fe37:12ca%877#53
Apr 25 20:06:44 webqa1 kernel: [20624.451628] veth00b6f0c: renamed from eth0
Apr 25 20:06:44 webqa1 named[137760]: no longer listening on fe80::40d:50ff:fe37:12ca%877#53
Apr 25 20:07:45 webqa1 kernel: [20685.263493] eth0: renamed from veth81ffaae
Apr 25 20:07:46 webqa1 kernel: [20686.903549] veth81ffaae: renamed from eth0
Apr 25 20:08:47 webqa1 kernel: [20747.733096] eth0: renamed from vethcc807e4
Apr 25 20:08:49 webqa1 named[137760]: listening on IPv6 interface vethfcddebe, fe80::8cf5:38ff:fec5:11a2%881#53
Apr 25 20:08:49 webqa1 kernel: [20749.618021] vethcc807e4: renamed from eth0
Apr 25 20:08:49 webqa1 named[137760]: no longer listening on fe80::8cf5:38ff:fec5:11a2%881#53
Offenbar war es doch falsch alles in eine Zone zu schreiben weil:
Code:
pr 25 20:05:23 webqa1 named[137760]: /etc/bind/pri.domain1.local:17: ignoring out-of-zone data (7.199.168.192.in-addr.arpa)
Apr 25 20:05:23 webqa1 named[137760]: /etc/bind/pri.domain1.local:20: ignoring out-of-zone data (domain2.local)
Apr 25 20:05:23 webqa1 named[137760]: /etc/bind/pri.domain1.local:21: ignoring out-of-zone data (www.domain2.local)
Aber das hatte ich anfangs ja nicht gemacht (siehe erstes Posting die Zonendateien)
 
Zuletzt bearbeitet:
So.... Nachdem ich mal wieder die komplette Nacht mit diesem Thema verbracht habe, bin ich immer noch keinen Schritt weiter, habe aber die Frtitzbox in Verdacht:

Wenn ich auf dem VirtualBox- baisierten Server ein hostname -f mache sagt er
Code:
webqa1.fritz.box
Obwohl ich in der /etc/hosts gesagt habe:
Code:
127.0.0.1 localhost webqa1.domain1.local
192.168.199.7 webqa1.domain1.local
Das wird einfach ignoriert ^^

In der /etc/resolv.conf steht
Code:
searchdomain fritz.box
und lässt sich auch nicht entfernen
sogar der wirt, auf dem virtualbox läuft, hat diese fritz.box domain - geht auch nicht weg

Oft geht der Browser hin und ändert Fritz.box in www.fritz.box so daß ich nicht aufd en Router komme (meistens nur noch über die IP)

Wenn ich die Bennenung des Servers dann anpasse und eine DNS für fritz.box anlege, ändert daß auch nichts. Dann hab ich DHCP auf der Fritzbox deaktiviert, den Geräten statische IPs gegeben, dann komme ich nicht mehr über5 SSH auf den Server und kann diesen auch nicht pingen. Hier bin ich nach https://wiki.ubuntuusers.de/Netplan/ vorgegangen...

Das höchste der Gefühle ist, daß www.domain1.local erreichbar ist vie Brtowser aber domain1.local eben nicht. Ohne Subdomains scheint domain1 nicht zu reagieren. Wenn ich auf dem Server einen Ping auf diese Adrtessen mache geht das auch nicht ^^ Der VirtualBox basierte Server ist wie gesagt über Bridged Network im LAN....

Aber vielleicht hat ja jmd noch einen Tip für mich ^^ Ich glaube langsam es ist vlt ein Netzwerkproblem
 
Hallo liebe Community :)

also ich habe das ganze Konstrukt jetzt nochmal neu aufgesetzt, einiges läuft besser aber Probleme habe ich immernoch.

Die DNS Anfragen gehen von dem Client an den Router - dieser ist DNS Server für die Clients. Der Router hat 2 NS Einträge: Den Server den ich gerade aufsetze als Primary und den des DSL Providers als Secondary - sie Grafik:

942





Sauber verarbeitet werden alle URLs:
  • www.domain1.local
  • webqa1.domain1.local (als eigenständige Webseite)
  • portal.domain1.local (als eigenständige Webseite)
  • sharepoint.portal.domain1.local (als weiterleitende Subdomain)

Nicht wirklich sauber verarbeitet wird:
  • domain1.local
domain.local ist eine Webseite mit Auto-Subdomain "www". Laut Webseitenkonfig sollte diese durch ISPConfig wie folgt redirected werden:
  • http -> https
  • non www -> www (R=301,L)
Das Verhalten im Browser ist seltsam:
  1. "domain1.local" und "https://domain1.local" ergibt meistens nach 30 Sekunden ein "Seite nicht gefunden". In ganz seltenen Fällen wird richtig weiter geleitet und die Seite erscheint - aber das dauert sehr lange.
  2. Sofort konfigurationsgerecht verarbeitet wird die URL nur bei angehangenem Trailing Slash oder eingetragenem www, sprich "https://domain1.local/" , "domain1.local/" , "www.domain1.local" sowie "https://www.domain1.local".
  3. Die Joomlaseite die hier lässt die Aktivierung von HTTPS über die WebUI nicht zu. Fehlermeldung:
    1. "Warnung: HTTPS wurde nicht aktiviert, da es auf dem Server nicht verfügbar ist. Der HTTPS-Verbindungstest schlug mit dem folgenden Fehler fehl: Could not resolve host: www.domain1.local".
    2. Und das obwohl im Browser bereits HTTPS aktiv ist...
Die Konfiguration(sdateien) auf dem Server webqa1.domain1.local sind wie folgt geschrieben:

In ISPConfig der verwendete Server:
IP: 192.168.199.7
Server: webqa1.domain1.local

/etc/hosts
Code:
127.0.0.1 localhost.localdomain localhost
127.0.1.1 webqa1.domain1.local webqa1
/etc/hostname
Code:
webqa1
/etc/resolv.conf
  • Diese lässt sich nicht ändern, spätestens nach einem Reboot steht da wieder der folgende Code der sich nicht nachhaltig ändern lässt
Code:
nameserver 127.0.0.53
options edns0 trust-ad
search fritz.box
/etc/netplan/50-cloud-init.yaml
Code:
# network: {config: disabled}
network:
    ethernets:
        enp0s3:
         #dhcp6: true
            dhcp4: true
    version: 2
DNS Einträge in ISP Config:
1. Zonendatei - SOA "domain1.local." / NS: "webqa1.domain1.local.":
Code:
A     domain1.local.     192.168.199.7     0     3600   
A     portal     192.168.199.7     0     3600   
A     webqa1     192.168.199.7     0     3600   
A     www     192.168.199.7     0     3600   
CNAME     sharepoint.portal     domain1.local.     0     3600   
MX     domain1.local.     webqa1.domain1.local.     10     3600   
NS     domain1.local.     webqa1.domain1.local.     0     3600   
TXT     domain1.local.     v=spf1 mx a ~all     0     3600
2. Reversezonendatei - SOA "199.168.192.in-addr.arpa." / NS: "webqa1.domain1.local.":
Code:
NS     199.168.192.in-addr.arpa.     webqa1.domain1.local     0     3600   
PTR     7     webqa1.domain1.local     0     3600
3. Weitere 2 Zonen zur Zeit erstmal deaktiviert - derren zugehörigen Websites auch deaktiviert

Analyse von Seiten des zugreifenden Clients miracle.domain1.local:
ping domain1.local
Code:
ping: domain1.local: Der Name oder der Dienst ist nicht bekannt
ping www.domain1.local
Code:
PING www.domain1.local (192.168.199.7) 56(84) bytes of data.
64 bytes from webqa1.domain1.local.199.168.192.in-addr.arpa (192.168.199.7): icmp_seq=1 ttl=64 time=0.349 ms
dig domain1.local
Code:
; <<>> DiG 9.16.6 <<>> domain1.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1750
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: 08b9116d37cd3cee01000000608e6099bd4c9858b1343bdb (good)
;; QUESTION SECTION:
;domain1.local.     IN      A

;; ANSWER SECTION:
domain1.local. 3600 IN      A       192.168.199.7

;; Query time: 4 msec
;; SERVER: 192.168.199.7#53(192.168.199.7)
;; WHEN: So Mai 02 10:19:37 CEST 2021
;; MSG SIZE  rcvd: 98
host domain1.local
Code:
domain1.local has address 192.168.199.7
domain1.local mail is handled by 10 webqa1.domain1.local.
nslookup domain1.local
Code:
Server:         192.168.199.7
Address:        192.168.199.7#53
Name:   domain1.local
Address: 192.168.199.7
nslookup 192.168.199.7
Code:
7.188.168.192.in-addr.arpa      name = webqa1.domain1.local.188.168.192.in-addr.arpa.
dig domain1.local
Code:
; <<>> DiG 9.16.6 <<>> domain1.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5961
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: d6255cb2d589286e01000000608e61c093c3a572f1cc618a (good)
;; QUESTION SECTION:
;domain1.local.     IN      A

;; ANSWER SECTION:
domain1.local. 3600 IN      A       192.168.199.7

;; Query time: 4 msec
;; SERVER: 192.168.199.7#53(192.168.199.7)
;; WHEN: So Mai 02 10:24:32 CEST 2021
;; MSG SIZE  rcvd: 98
 
Zuletzt bearbeitet:
Fortführung des Threads darüber (zu viele Zeichen geschrieben)

Analyse von Seiten des Servers webqa1.domain1.local:
Hier lässt sich keine einzige dieser hosts oder Domains anpingen, auch die andren Tools geben für alle Hosts/Domains ein ServerFail zurück:

ping www.domain1.local
Code:
ping: www.domain1.local: Temporary failure in name resolution
ping domain1.local
Code:
ping: domain1.local: Temporary failure in name resolution
host domain1.local
Code:
Host domain1.local not found: 2(SERVFAIL)
host www.domain1.local
Code:
Host www.domain1.local not found: 2(SERVFAIL)
nslookup www.domain1.local
Code:
Server:         127.0.0.53
Address:        127.0.0.53#53

** server can't find www.domain1.local: SERVFAIL
nslookup domain1.local
Code:
Server:         127.0.0.53
Address:        127.0.0.53#53

** server can't find domain1.local: SERVFAIL
dig domain1.local
Code:
; <<>> DiG 9.16.1-Ubuntu <<>> domain1.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 28088
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;domain1.local.     IN      A

;; Query time: 0 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: So Mai 02 10:40:39 CEST 2021
;; MSG SIZE  rcvd: 54
dig www.domain1.local
Code:
; <<>> DiG 9.16.1-Ubuntu <<>> www.domain1.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 58607
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;www.domain1.local. IN      A

;; Query time: 0 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: So Mai 02 10:41:05 CEST 2021
;; MSG SIZE  rcvd: 58
Auch finde ich die Menge an Dateien unter /etc/bind recht hoch - ein "ls /etc/bind -all" ergibt:
Code:
 drwxr-sr-x   3 root bind  4096 Mai  2 10:11 .
drwxr-xr-x 155 root root 12288 Mai  2 10:43 ..
-rw-r--r--   1 root root  1991 Feb 18 04:28 bind.keys
-rw-r--r--   1 root root   237 Sep 30  2019 db.0
-rw-r--r--   1 root root   271 Sep 30  2019 db.127
-rw-r--r--   1 root root   237 Sep 30  2019 db.255
-rw-r--r--   1 root root   353 Sep 30  2019 db.empty
-rw-r--r--   1 root root   270 Sep 30  2019 db.local
-rw-r--r--   1 root root  3171 Sep 30  2019 db.root
-rw-r--r--   1 root bind   109 Mai  2 10:11 dsset-199.168.192.in-addr.arpa.
-rw-r--r--   1 root bind   110 Mai  2 10:09 dsset-domain1.local.
-rw-r--r--   1 root bind    95 Mai  1 04:39 dsset-fritz.box.
-rw-r--r--   1 root bind   368 Mai  1 19:09 K199.168.192.in-addr.arpa.+013+35123.key
-rw-------   1 root bind   187 Mai  1 19:09 K199.168.192.in-addr.arpa.+013+35123.private
-rw-r--r--   1 root bind   367 Mai  1 19:09 K199.168.192.in-addr.arpa.+013+62495.key
-rw-------   1 root bind   187 Mai  1 19:09 K199.168.192.in-addr.arpa.+013+62495.private
-rw-r--r--   1 root bind   369 Mai  1 19:49 Kdomain1.local.+013+44909.key
-rw-------   1 root bind   187 Mai  1 19:49 Kdomain1.local.+013+44909.private
-rw-r--r--   1 root bind   370 Mai  1 19:49 Kdomain1.local.+013+55116.key
-rw-------   1 root bind   187 Mai  1 19:49 Kdomain1.local.+013+55116.private
-rw-r--r--   1 root bind   337 Mai  1 04:32 Kfritz.box.+013+51723.key
-rw-------   1 root bind   187 Mai  1 04:32 Kfritz.box.+013+51723.private
-rw-r--r--   1 root bind   338 Mai  1 04:32 Kfritz.box.+013+51886.key
-rw-------   1 root bind   187 Mai  1 04:32 Kfritz.box.+013+51886.private
-rw-------   1 root bind 12288 Mai  1 11:58 .Kfritz.box.+013+51886.private.swp
-rw-r--r--   1 root bind   463 Sep 30  2019 named.conf
-rw-r--r--   1 root bind   498 Dez 17  2019 named.conf.default-zones
-rw-r--r--   1 root bind   243 Mai  2 10:11 named.conf.local
-rw-r--r--   1 root bind   976 Apr  1 20:54 named.conf.options
-rw-r--r--   1 root bind   846 Dez 17  2019 named.conf.options.dpkg-dist
-rw-r--r--   1 root bind   677 Mai  2 10:11 pri.199.168.192.in-addr.arpa
-rw-r--r--   1 root bind  2898 Mai  2 10:11 pri.199.168.192.in-addr.arpa.signed
-rw-r--r--   1 root bind  1063 Mai  1 01:21 pri.domain2.local
-rw-r--r--   1 root bind  1022 Mai  2 10:09 pri.domain1.local
-rw-r--r--   1 root bind  5491 Mai  2 10:09 pri.domain1.local.signed
-rw-r--r--   1 root bind  2837 Mai  1 04:39 pri.fritz.box.signed
-rw-r--r--   1 root bind   790 Mai  1 01:16 pri.domain3.local
-rw-r-----   1 bind bind    77 Feb 22  2020 rndc.key
drwxrws---   3 root bind  4096 Mai  1 04:45 slave
-rw-r--r--   1 root root  1317 Sep 30  2019 zones.rfc1918
domain2+domain3 sind gewollt aber erstmal in ISPConfig deaktiviert.
domain1 ist ja das aktuelle Sorgenkind.

So....

Wenn ich nun auf dem Server ein "systemctl restart named" mache gefolgt von einem "tail -f /var/log/syslog | grep named" bekomme ich das hier und sehe keinen Fehler - 'wundere mich aber bissel über die genannten IPV6 Adressen:
Code:
May  2 10:51:56 webqa1 named[316415]: command channel listening on ::1#953
May  2 10:51:56 webqa1 named[316415]: managed-keys-zone: loaded serial 3
May  2 10:51:56 webqa1 named[316415]: zone 0.in-addr.arpa/IN: loaded serial 1
May  2 10:51:56 webqa1 named[316415]: zone 127.in-addr.arpa/IN: loaded serial 1
May  2 10:51:56 webqa1 named[316415]: zone 255.in-addr.arpa/IN: loaded serial 1
May  2 10:51:56 webqa1 named[316415]: zone domain1.local/IN: loaded serial 2021050202 (DNSSEC signed)
May  2 10:51:56 webqa1 named[316415]: zone 199.168.192.in-addr.arpa/IN: loaded serial 2021050202 (DNSSEC signed)
May  2 10:51:56 webqa1 named[316415]: zone localhost/IN: loaded serial 2
May  2 10:51:56 webqa1 named[316415]: all zones loaded
May  2 10:51:56 webqa1 named[316415]: running
May  2 10:51:59 webqa1 named[316415]: resolver priming query complete
May  2 10:52:41 webqa1 kernel: [48348.587487] eth0: renamed from vethe5d1a7a
May  2 10:52:43 webqa1 named[316415]: listening on IPv6 interface veth6fae7b8, fe80::5cf8:c4ff:fe74:bd9b%2007#53
May  2 10:52:43 webqa1 kernel: [48350.531795] vethe5d1a7a: renamed from eth0
May  2 10:52:43 webqa1 named[316415]: no longer listening on fe80::5cf8:c4ff:fe74:bd9b%2007#53
May  2 10:53:44 webqa1 kernel: [48411.489066] eth0: renamed from vethd8debc8
May  2 10:53:45 webqa1 named[316415]: listening on IPv6 interface vethcaa9dcf, fe80::30fa:67ff:fee7:3823%2009#53
May  2 10:53:46 webqa1 kernel: [48413.626485] vethd8debc8: renamed from eth0
May  2 10:53:46 webqa1 named[316415]: no longer listening on fe80::30fa:67ff:fee7:3823%2009#53
May  2 10:54:29 webqa1 kernel: [48456.998630] veth05796f2: renamed from eth0
May  2 10:54:30 webqa1 named[316415]: no longer listening on fe80::14d9:4bff:fea2:9c43%2003#53
May  2 10:54:31 webqa1 kernel: [48458.287709] eth0: renamed from vethb895423
May  2 10:54:32 webqa1 named[316415]: listening on IPv6 interface veth0e6c779, fe80::bc54:b4ff:fe15:dd02%2011#53
May  2 10:54:47 webqa1 kernel: [48474.813996] eth0: renamed from veth4734a14
May  2 10:54:49 webqa1 named[316415]: listening on IPv6 interface veth7359dbd, fe80::8cc9:10ff:febf:88f5%2013#53
May  2 10:54:50 webqa1 kernel: [48477.158224] veth4734a14: renamed from eth0
May  2 10:54:50 webqa1 named[316415]: no longer listening on fe80::8cc9:10ff:febf:88f5%2013#53
Vielleicht hat ja jemand noch eine Idee. Ich hoffe ja daß es nur ein kleiner Fehler ist, die dieses ungewünschte Verhalten verursacht :(

Liebe Grüße und Danke

PS: sorry für den Doppelthread, ich hab die Maximalzeichen überschritten ^^
 
Zuletzt bearbeitet:

Strontium

Member
hosts-Datei brauchst du nicht und die resolv.conf ändert man nicht manuell. Wie man das tut steht bei man resolved.conf
 
hosts-Datei brauchst du nicht und die resolv.conf ändert man nicht manuell. Wie man das tut steht bei man resolved.conf
Doch, in meinem Fall wohl schon. Bevor ich die hosts-Datei angepasst hatte, hat die Fritzbox den FQDN des Geräts beeinflusst, weil ein hostname -f ergab:
Code:
webqa1.fritz.box
Und da waren die Probleme noch deutlich größer...
Erst mit Anpassung der Datei gibt der Befehl den richtigen Hostname inkl. richtiger FQDN aus.

man resolved.conf guck ich mir mal an die Tage, Danke
 
TL;DR:
Soweit ich das sehen konnte, läuft die Anfrage zuerst bei der Fritz.box auf. Diese wiederrum fragt wohl nicht beim lokalen DNS zuerst nach.

Ich habe eine ähnlichen Konstrukt. Bei mir läuft auf der Gastgebermaschine dnsmasq und löst mein gesamtes Netzwerk auf. Inkl. DHCP für die angeschlossenen Clients. Erst danach wird die Fritzbox für die DNS-Auflösung angefragt. DHCP ist auf der FB abgeschaltet.
 
TL;DR:
Soweit ich das sehen konnte, läuft die Anfrage zuerst bei der Fritz.box auf. Diese wiederrum fragt wohl nicht beim lokalen DNS zuerst nach.

Ich habe eine ähnlichen Konstrukt. Bei mir läuft auf der Gastgebermaschine dnsmasq und löst mein gesamtes Netzwerk auf. Inkl. DHCP für die angeschlossenen Clients. Erst danach wird die Fritzbox für die DNS-Auflösung angefragt. DHCP ist auf der FB abgeschaltet.
Naja, es werden ja Webseiten dargestellt...

portal.domain1.local
webqa1.domain1.local

Also muss der lokale DNS Server ja angesprochen werden ^^

Aber domain1.local irgendwie nicht und seit heute www.domain1.local auch nicht mehr ^^ So langsam geht mir auch wirklich an die Laune ^^
 

Strontium

Member
Gib doch mal am Server nslookup ein, dann in der Shell localhost und sieh nach was bei Address steht. Wenn dort nicht der richtige Nameserver steht hast du den Fehler gefunden.
 
Na liebe Community ,

.... Mittlerweile läufts :)

Ich muss sagen daß mir u.a. die Fritzbox hier wirklich voll gemeine Streiche gespielt hat :(

1. Einige Filter, die entsprechend Menüführung eigentlich für Verbindungen von der Wolke gedacht sind, haben die Funktion eingeschränkt. Stealth Modus etc ist nun deaktiviert (Fritzbox -> Internet -> Filter ->Listen -> Globale Filtereinstellungen). Muss mal sehen was ich davon vlt wieder aktivieren kann ^^

2.Fritzbox -> Netzwerk -> Netzwerkeinstellungen -> DNS-Rebind-Schutz: Hier musst Du alle FQDN-Hosts eintragen, die im LAN DNS-Antworten von anderen LAN-Mitgliedern erhalten sollen :eek: Dann die Fritzbox neu starten.

3. Auch versucht die Fritzbox stur ihre eigene DNS durchzusetzen, womit bei "Fritz.Box" enden würdest...
3a. Hier kann man aber bei allen zugreifenden Clients die DHCP-Config im Networkmanager anpassen: DCCP-Client auf "Automatisch - nur Adressen" stellen und dann für IPV4 + IPV6 ergänzende IP Adressen im Feld "DNS Server" eintragen: Immer zuerst die des loikalen DNS und als sekundäre die IP der Fritzbox (sonst kein Internet mehr)
3b. Auf dem Server dann in /etc/netplan/ ein höherwertiges Gegenstück zur Datei 50-cloud-init.yaml anlegen. Dort die Anpassungen rein und mit dem Befehl "netplan apply" die resolv.conf entsprechend den gemachten Einträgen anpassen, zB: cat /etc/netplan/75-cloud-init.yaml

Code:
network:
    ethernets:
        enp0s3:
            dhcp4: true
            dhcp6: true
            nameservers:
                    addresses: [192.168.199.7, 192.168.199.1]
                    addresses: [xxxx:xxx:xxx:xxxx:axx:27xx:fxx5:xxxx]
                    search: [domain1.local, domain2.local, domain3.local, fritz.box]
3d Auf der Fritzbox unter Internet -> Zugangsdaten -> DNS Server dann individuelle DNS Einträge setzen für IPV4+IPV6+ - Bevorzugter IP der lokale Server / Sekundäre IP dann die des DSL Providers

4.
Auf dem Server dann in der /etc/hosts die IP Adressen mit dem gewünschten FQDN versehen, um den Domainnamen "Frtitz.box" los zu werden - cat /etc/hosts:

Code:
127.0.0.1 localhost.localdomain localhost
127.0.2.1 webqa1.domain1.local webqa1
192.168.199.7 webqa1.domain1.local
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ipv6-allhosts
xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx webqa1.domain1.local
5. Auf den zugreifenden Clients ebenfalls die Server-IPs mit dem gewünschten FQDN eintragen -
cat /etc/hosts
Code:
127.0.0.1 localhost.localdomain localhost
127.0.2.1 miracle.domain1.local miracle
192.168.199.7 webqa1.domain1.local webqa1

# special IPv6 addresses                                                                                               

::1     localhost ipv6-localhost ipv6-loopback
fe00::0 ipv6-localnet
ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx webqa1.domain1.local webqa1
6. Da der Server in meinem Fall ein VirtualBox Gerät ist, habe ich VirtualBox noch aktualisiert den Gast an die Umgebung des Wirten (OpenSuse) besser angepasst:
  • System -> Paravirtualisierung: KVM
  • Netzwerk -> Adaptertyp: Paravirtualisiertes Netzwerk (Virtio Net)
Und siehe da - plötzlich ist alles abrufbar, pingbar, auflösbar und so wie es sein soll. Weia, hab ich mich gefreut :p

Nur die Reverse-DNS Lookups vom Client aus zum Server klappen nicht auf IPV6 - nur auf IPV4 klappen die, aber da kann ich mit Leben. Ich brauch die ja sowieso nicht, wollte die aber der Vollständigkeit halber auch mal aufsetzen.

Das DNS Problem hatte also eher weniger mit den DNS Records als solche zu tun :oops:

Ein ganz liebes Dankeschön an alle die mich hier mit Tipps unterstützt haben <3

GLG
DarkTrinity
 
wenn du auf allen clients die fqdn's in die hosts einträgst, wozu brauchst du dann noch dns?
Nur die FQDN des Nameservers habe ich dort eingetragen.

Alle Webseiten + Maildomains werden von dem aufgelöst. Es ist ein Testgerät. Zuvor hatte ich wirklich jede Website in den /etc/hosts eintragen müssen - schon deutlich aufwändiger.

Auch geht es mir darum andere Mailserver- Konfigurationen auszuprobieren, spätestens das wäre dann über hosts Dateien schon nicht mehr machbar...
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.