Fehler 500 beim Upload von Dateien

Paul

Member
Hallo.
Seit kurzem habe ich ein Problem beim Upload von Dateien.
Wenn in das phpBB-Forum Fotos oder PDF-Dateien hochgeladen werden sollen, erhält man meistens die ISPConfig „Fehlermeldung 500 – Interner Serverfehler! - Beim Aufruf der angegebenen URL ist ein interner Serverfehler aufgetreten.“
Das Problem tritt sowohl bei dem Forum als auch bei der CRM-Software Vtiger auf. Aber nicht immer. Z.B. kleine jpg-Fotos können hochgeladen werden.
Leider ist es mir nicht gelungen in den Logs aussagekräftige Fehlermeldungen zu finden. Vor ca. 6 Wochen war es noch kein Problem auch größere Dateien und Fotos hochzuladen.

Das System: Debian 6 mit ISPConfig 3.

Meine Vermutung: Nach einem System-Upgrade müssen Werte in der php.ini oder der suhosin.ini angepasst werden. Hat jemand eine Idee?
 

Paul

Member
Mit den Antworten geht das aber Ruckzuck. Fast wie beim Chatten.
Ich habe mich schnell einmal in VTiger angemeldet und einen Upload versucht. Das Error-Log notiert dazu folgendes:

[Wed Nov 16 10:36:57 2011] [warn] [client 87.155.159.183] mod_fcgid: HTTP request length 138414 (so far) exceeds MaxRequestLen (131072), referer: https://www.website.de/vtigercrm/index.php?module=Contacts&action=EditView&record=106&return_module=Accounts&return_action=CallRelatedList&return_id=99&parenttab=Marketing&return_viewname= [Wed Nov 16 10:37:47 2011] [error] [client 87.155.159.183] File does not exist: /var/www/website.de/web/vtigercrm/themes/softed/images/vtbusy.gif, referer: https://www.website.de/vtigercrm/index.php?action=CallRelatedList&module=Accounts&parenttab=Marketing&record=99&activity_mode=&viewname=0&start= [Wed Nov 16 10:37:47 2011] [error] [client 87.155.159.183] File does not exist: /var/www/website.de/web/vtigercrm/themes/softed/images/vtbusy.gif, referer: https://www.website.de/vtigercrm/index.php?action=CallRelatedList&module=Accounts&parenttab=Marketing&record=99&activity_mode=&viewname=0&start= [Wed Nov 16 11:06:14 2011] [error] [client 87.106.100.144] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:) [Wed Nov 16 11:36:45 2011] [error] [client 87.155.159.183] File does not exist: /var/www/website.de/web/vtigercrm/themes/softed/images/vtbusy.gif, referer: https://www.website.de/vtigercrm/index.php?action=CallRelatedList&module=Accounts&record=99&parenttab=Marketing&selected_header=Contacts&relation_id=1 [Wed Nov 16 11:36:45 2011] [error] [client 87.155.159.183] File does not exist: /var/www/website.de/web/vtigercrm/themes/softed/images/vtbusy.gif, referer: https://www.website.de/vtigercrm/index.php?action=CallRelatedList&module=Accounts&record=99&parenttab=Marketing&selected_header=Contacts&relation_id=1 [Wed Nov 16 11:37:07 2011] [warn] [client 87.155.159.183] mod_fcgid: HTTP request length 138413 (so far) exceeds MaxRequestLen (131072), referer: https://www.website.de/vtigercrm/index.php?module=Contacts&action=EditView&record=106&return_module=Accounts&return_action=CallRelatedList&return_id=99&parenttab=Marketing&return_viewname=
 

Paul

Member
Schönen Dank für den Tipp doch noch mal genauer ins Error-Log zu schauen.
In der Tat steht ja ganz genau drin, was der Fehler ist.
Zwischenzeitlich habe ich gegoogelt und die Lösung hier gefunden:
[fix] mod_fcgid: HTTP request length xyz (so far) exceeds MaxRequestLen (131072) » Philipp Klaus's Computing Blog

In der /etc/apache2/mods-available/fcgid.conf folgende Zeile einfügen:
MaxRequestLen 15728640

Dann klappt's auch wieder mit dem Hochladen von Dateien.
Schönen Dank noch mal für die schnelle Hilfe!
 

nowayback

Well-Known Member
Moinsen

mod_fcgid - Apache HTTP Server

Parameter stand früher bei 1GB. Wurde dann im Laufe der Updates geändert.

Trag einfach einen Wert der zu deiner restlichen Config (upload_max_filesize, post_max_filesize) in den entsprechenden Block mit ein:

<IfModule mod_fcgid.c>
...
FcgidMaxRequestLen 67108864
...
</IfModule>
Das sollten, wenn ich mich nicht verrechnet hab, 64 MB sein


*** Edit: Schön das du es selbst gefunden hast und ich nun umsonst getippt habe :p ***

Grüße
nwb
 

Werbung

Top