client email Einstellungen

tomdf

New Member
Hallo,

ich habe probleme bei ISPconfig 3 keine Emails empfangen und senden zu können.
folgende Daten habe ich eingegeben:

server: server1.cl-i.tld (hostname)
username: info@rooms-tenerife.tld (email adresse)
Port 993
Encrypt: StartTLS

sending email:
server: siehe oben
port 465

leider geht weder der empfang noch das versenden von email.

hat jemand einen Tipp für mich?

vielen Dank.

Tom
 

Till

Administrator
Zum senden nimmt man normalerweise port 587 mit TLS. Da Du abera uch nicht empfangen kannst solltest Du erstmal mit 'netstat -tap' schauen ob die Mail Dienste überhaupt gestartet sind.
 

tomdf

New Member
Hi Till,

vielen Dank für Deine Antwort.

also so sieht netstat -tap aus und ich würde mal sagen die Dienste laufen einwandfrei.
Kann es auch an dem MX Eintrag liegen?

habe ich den hostnamen richtig eingegeben?
besten Gruß
Tom

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:10024 0.0.0.0:* LISTEN 29159/amavisd-new (
tcp 0 0 localhost:10025 0.0.0.0:* LISTEN 29130/master
tcp 0 0 localhost:10026 0.0.0.0:* LISTEN 29159/amavisd-new (
tcp 0 0 localhost:mysql 0.0.0.0:* LISTEN 28931/mysqld
tcp 0 0 localhost:10027 0.0.0.0:* LISTEN 29130/master
tcp 0 0 localhost:11211 0.0.0.0:* LISTEN 24015/memcached
tcp 0 0 0.0.0.0:pop3 0.0.0.0:* LISTEN 29168/dovecot
tcp 0 0 0.0.0.0:imap2 0.0.0.0:* LISTEN 29168/dovecot
tcp 0 0 0.0.0.0:http-alt 0.0.0.0:* LISTEN 12981/apache2
tcp 0 0 0.0.0.0:http 0.0.0.0:* LISTEN 12981/apache2
tcp 0 0 0.0.0.0:tproxy 0.0.0.0:* LISTEN 12981/apache2
tcp 0 0 server1.cl-i.net:domain 0.0.0.0:* LISTEN 29222/named
tcp 0 0 localhost:domain 0.0.0.0:* LISTEN 29222/named
tcp 0 0 0.0.0.0:ftp 0.0.0.0:* LISTEN 29216/pure-ftpd (SE
tcp 0 0 localhost:domain 0.0.0.0:* LISTEN 387/systemd-resolve
tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN 479/sshd
tcp 0 0 localhost:953 0.0.0.0:* LISTEN 29222/named
tcp 0 0 0.0.0.0:smtp 0.0.0.0:* LISTEN 21797/smtpd
tcp 0 0 0.0.0.0:https 0.0.0.0:* LISTEN 12981/apache2
tcp 0 0 0.0.0.0:imaps 0.0.0.0:* LISTEN 29168/dovecot
tcp 0 0 0.0.0.0:pop3s 0.0.0.0:* LISTEN 29168/dovecot
tcp 0 0 server1.cl-i.n:http-alt 243.red-83-32-70.:36064 ESTABLISHED 12990/apache2
tcp 0 0 server1.cl-i.net:smtp 74.115.13.4:14666 ESTABLISHED 21797/smtpd
tcp 0 232 server1.cl-i.net:ssh 243.red-83-32-70.:56814 ESTABLISHED 22770/sshd: root@pt
tcp 53 0 localhost:43954 localhost:10025 CLOSE_WAIT 29270/amavisd-new (
tcp 0 0 server1.cl-i.net:imap2 243.red-83-32-70.:42690 ESTABLISHED 21613/dovecot/imap
tcp 0 0 server1.cl-i.net:imap2 243.red-83-32-70.:38098 ESTABLISHED 19131/dovecot/imap
tcp 0 0 server1.cl-i.net:ssh 58.242.82.13:20988 ESTABLISHED 22851/sshd: root [p
tcp 53 0 localhost:57424 localhost:10025 CLOSE_WAIT 29269/amavisd-new (
tcp 0 0 server1.cl-i.n:http-alt 243.red-83-32-70.:35974 TIME_WAIT -
tcp 0 0 server1.cl-i.n:http-alt 243.red-83-32-70.:36016 TIME_WAIT -
tcp 0 0 server1.cl-i.n:http-alt 243.red-83-32-70.:35742 TIME_WAIT -
tcp 1 0 localhost:39212 localhost:mysql CLOSE_WAIT 29270/amavisd-new (
tcp6 0 0 [::]:pop3 [::]:* LISTEN 29168/dovecot
tcp6 0 0 [::]:imap2 [::]:* LISTEN 29168/dovecot
tcp6 0 0 [::]:domain [::]:* LISTEN 29222/named
tcp6 0 0 [::]:ftp [::]:* LISTEN 29216/pure-ftpd (SE
tcp6 0 0 [::]:ssh [::]:* LISTEN 479/sshd
tcp6 0 0 [::]:smtp [::]:* LISTEN 21797/smtpd
tcp6 0 0 [::]:imaps [::]:* LISTEN 29168/dovecot
tcp6 0 0 [::]:pop3s [::]:* LISTEN 29168/dovecot
 

Till

Administrator
Es kann an eine Menge Sachen liegen, als erstes würde ich das Mailsystem mal lokal testen. Logge Dich in roundcube webmail auf dem server ein und sende eine email an die selbe adresse, mit der Du Dich an Roundcube angemeldet hast, die Mail müsste nach ein paar Sekunden im Posteingang wieder ankommen. Wenn das geht, dann ist das mailsystem ok. dann kann es am DNS liegen oder einer Firewall oder der provider der den zugang zum server bereitstellt hat die mail ports blockiert.

In dem netstat output fehlen mir beim postfix ein paar ports, poste bitte mal die Postfix master.cf Datei.
 

tomdf

New Member
ich habe mich über roundcube angemeldet und ein versenden der email ist nicht möglich es wird versucht die email zu senden aber keine Rückmeldung.

ich habe mit telnet die ports gecheckt: 25, 995 , 993 kann man connecten 465 und 587 unable to connect
im mail.log kann man sehen wenn roundcube sich verbindet

doveadm user info@rooms-tenerife.com
field value
uid 5000
gid 5000
home /var/vmail/rooms-tenerife.com/info
mail maildir:/var/vmail/rooms-tenerife.com/info/Maildir
quota_rule *:storage=0B

mit dem user ist auch alles ok denke ich

Hier der auszug aus der master.cf

------
#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master" or
# on-line: http://www.postfix.org/master.5.html).
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (no) (never) (100)
# ==========================================================================
smtp inet n - y - - smtpd
#smtp inet n - y - 1 postscreen
#smtpd pass - - y - - smtpd
#dnsblog unix - - y - 0 dnsblog
#tlsproxy unix - - y - 0 tlsproxy
#submission inet n - y - - smtpd
-o syslog_name=postfix/submission
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
^M -o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o smtpd_tls_auth_only=yes
# -o smtpd_reject_unlisted_recipient=no
# -o smtpd_client_restrictions=$mua_client_restrictions
# -o smtpd_helo_restrictions=$mua_helo_restrictions
# -o smtpd_sender_restrictions=$mua_sender_restrictions
# -o smtpd_recipient_restrictions=
# -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
#smtps inet n - y - - smtpd
-o syslog_name=postfix/smtps
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
^M -o smtpd_client_restrictions=permit_sasl_authenticated,reject
:

# -o smtpd_reject_unlisted_recipient=no
# -o smtpd_client_restrictions=$mua_client_restrictions
# -o smtpd_helo_restrictions=$mua_helo_restrictions
# -o smtpd_sender_restrictions=$mua_sender_restrictions
# -o smtpd_recipient_restrictions=
# -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
#628 inet n - y - - qmqpd
pickup unix n - y 60 1 pickup
cleanup unix n - y - 0 cleanup
qmgr unix n - n 300 1 qmgr
#qmgr unix n - n 300 1 oqmgr
tlsmgr unix - - y 1000? 1 tlsmgr
rewrite unix - - y - - trivial-rewrite
bounce unix - - y - 0 bounce
defer unix - - y - 0 bounce
trace unix - - y - 0 bounce
verify unix - - y - 1 verify
flush unix n - y 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - y - - smtp
relay unix - - y - - smtp
-o syslog_name=postfix/$service_name
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - y - - showq
error unix - - y - - error
retry unix - - y - - error
discard unix - - y - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - y - - lmtp
anvil unix - - y - 1 anvil
scache unix - - y - 1 scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
#
# ====================================================================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
# lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4

#
# Specify in main.cf one or more of the following:
# mailbox_transport = lmtp:inet:localhost
# virtual_transport = lmtp:inet:localhost
#
# ====================================================================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus unix - n n - - pipe
# user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ====================================================================
# Old example of delivery via Cyrus.
#
#old-cyrus unix - n n - - pipe
# flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ====================================================================
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#

#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}

dovecot unix - n n - - pipe
flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${nexthop}

amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes
-o smtp_bind_address=


127.0.0.1:10025 inet n - n - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,reject
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
-o smtp_send_xforward_command=yes
:



127.0.0.1:10027 inet n - n - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,reject
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
-o smtp_send_xforward_command=yes
-o milter_default_action=accept
-o milter_macro_daemon_name=ORIGINATING
-o disable_dns_lookups=yes
 
Zuletzt bearbeitet:

florian030

Active Member
#submission inet n - y - - smtpd
-o syslog_name=postfix/submission
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
^M -o smtpd_client_restrictions=permit_sasl_authenticated,reject

das ist falsch. # vor submission raus und ^M auch weg. dann postfix neu starten
 

Till

Administrator
Und das # vor der zeile smtps ....... auch weg und wenn die zeile in der nur ein ":" steht ao in der datei existiert und kein fehler beim kopieren ins Forum ist, dann die zeile löschen.
 

tomdf

New Member
Hallo Till, Hallo Florian,
vielen Dank für Eure Antwort.
Dank Eurer Hilfe klappt jetzt schon mal das Empfangen und Versenden von Emails per Roundcube.

Mein Mailprogramm allerdings, ich nutze Evolution empfängt keine Emails und ich fürchte es ist ein Problem mit meinen Client einstellungen.

Die Namerserver einstellungen sind wie folgt:

;; ANSWER SECTION:
rooms-tenerife.tld. 86400 IN MX 10 mail.rooms-tenerife.tld.

;; ADDITIONAL SECTION:
mail.rooms-tenerife.tld. 86400 IN A 173.249.25.125

Meine Einstellungen im Client habe ich versucht wie folgt:

Mails empfangen:

Server: mail.rooms-tenerife.tld oder auch den Hostname server1.cl-i.tld
Port: 993
Start SSL

ich habe mit telnet die ports gecheckt: 25, 995 , 993 kann man connecten 465 und 587 unable to connect

Es wäre toll, wenn Ihr mich aufklären könntet wo die Probleme liegen

Danke vorab für Eure tolle Hilfe

besten Gruß

Tom
 

tomdf

New Member
Der Server ist im rechenzentrum.
Update: ich kann emails empfangen über Port 143 aber wenn ich Port 993 angebe klappt das nicht.
Zudem: ich gebe den Servernamen ein, dann geht das also server1.cl-i.tld gerne würde ich aber die Domain eingeben weil das für meinen Kunden ja besser klingt, geht es, dass man statt dem Hostnamen auch den Domain Namen eingeben kann, wie wären die einstellungen dazu.

Das Versenden über meinen Mail Client geht leider auch nicht ich bekomme ein Socket I/O timeout.
als port habe ich 465 angegeben.

Sorry für so viele Fragen...
und danke für Deine Antwort ;)
 

Till

Administrator
Sende port mit TLS ist 587, 465 nutzt man an sich nicht mehr. Welche Fehler bekommst Du denn im mail.log bei verwendung der TLS ports. Möglicherweise ist Dein SSL zertifikat defekt.
 

tomdf

New Member
Das Versenden der Email klappt.
Vielen Dank für die tolle Hilfe.
Ich hatte vergessen das SSL Zertifikat anzulegen übrigens, das habe ich nachgeholt jetzt.
Das Empfangen über port 993 geht jetzt auch. Ich hatte nicht angegeben TLS on a dedicated port sondern StartTLS after connecting.

Jetzt klappt alles.

Hast Du noch einen Tipp für mich, wo ich mehr über webserver troubleshooting lernen kann?

Vielen Dank Till für Deine tolle Hilfe, ich bin überglücklich, den Server jetzt am Laufen zu haben.
 
Zuletzt bearbeitet:

tomdf

New Member
Ich hätte noch eine Frage, wie kann ich den server namen server1.cl-i.net bei dem Email client ersetzen durch den Domain Namen mail.meinedomain.de ?
danke vorab für die antwort.
 

Till

Administrator
Würde ich nicht machen, außer Du hast nur eine Domain. Denn ansonsten bekommst Du SSL fehler wegen eiens ungültigen Zertifikates.
 

tomdf

New Member
Hallo Till,

vielen Dank für die Antwort.
Ich lasse alles so wie es ist.
Danke dass Du mir so gut geholfen hast.
 

Werbung

Top