Backup ausschalten

ereuter

Member
Hallo,

ich würde gerne das Backup ins Verzeichnis /var/backup ausschalten, weil mir das gerade die Festplatte hat volllaufen lassen, und so wesentlich mehr Schaden als Nutzen angerichtet hat.

Aber da gibt es keine entsprechende Option unter System -> Serverkonfiguration

Wie mache ich das also?

Beste Grüße

Elisabeth
 

vikozo

Member
Hallo Elisabeth

eventuell hilft dies

im Backend
- Sites anwählen

dann wählst du eine Homepage aus (Web Domain)
da unter Backup

kannst du die Menge an Kopien einstellen, eventuell reicht es auch einfach weniger kopien zu erstellen. oder am Intervall was anderes einzustellen.

keine Kopie zu haben scheint mir nicht klug. wobei ich ja nur ein kleiner User bin.

gruss
vinc
 

ereuter

Member
Vielen Dank für den Hinweis - damit kann ich das Problem einigermaßen umgehen, ganz lösen kann ich es jedoch nicht, weil ja der Kunde jederzeit wieder das Backup aktivieren kann.

Das Problem dabei ist, dass auf dem Server recht wenig Platz ist, weil er eben mit SSDs betrieben wird. Und nachdem ich ohnehin täglich ein Backup auf einen Backupserver mache, ist es auch noch unnötig.

Beste Grüße

Elisabeth
 

florian030

Active Member
Du kannst die Backups für Kunden abschalten. Grds. würde ich Backups eh nicht lokal auf dem Server speichern, sondern direkt extern.
 

timur

Member
hallo

ich schließe mich mal hier an um kein neues thema dafür aufzumachen..


wie kann ich die backups denn extern auf einer festplatte speichern ? habe eine wd mycloud und dort ist es mir möglich http downloads einzurichten mit url und login aber weiss nicht ganz wie ich es gescheit umsetzte

ich danke für lösungen oder die richtigen links hab leider nichts gefunden was mir weiter half
 

nowayback

Well-Known Member
via scp abholen. keine Ahnung ob deine wd mycloud das kann, aber via http würde ich die nicht unbedingt bereitstellen. wenn es nicht anders geht, dann einen eigenen vhost anlegen dafür
 

timur

Member
also meine wd mycloud jedenfalls das model das ich hab unterstützt das nicht ich kann wie gesagt nur über http download das übergeben bzw. anlegen.


jetzt meine frage wenn ich es über vhost mache wie stelle ich das genau an ? gibs da zufällig eine ähnliche anleitung oder so etwas dafür wäre ich sehr dankbar
 

timur

Member
ich hab mal geschaut und ich kann an meiner cloud ein nfs zugriff einrichten und kriege den pfad angezeigt kann ich diesen in ispconfig einfach einbinden?
 

Till

Administrator
Di kannst jedes netzwerk filesystem verwenden als backup storage. ISPConfig bietet ja die möglichkeit ein mount und unmount script für das backup storage automatisch auszuführen.
 

Till

Administrator
Erstelle 2 shell scripte:

/usr/local/ispconfig/server/scripts/backup_dir_mount.sh
/usr/local/ispconfig/server/scripts/backup_dir_umount.sh

welche die Befehle zum mounten bzw. unmounten des backup drive enthalten, vergiß nicht die scripte ausführbar zu machen. ISPConfig führt die script dann vor bzw. nach dem Backup aus sowie wenn ein Backup bereitgestellt werden soll.

Dann System > server config > Backup directory is a mount? anhaken.
 

timur

Member
Ok erstellen ist nicht schwer nur was muss rein hab das noch nie gemacht weiss nicht wie die Shells aussehen müssen :)
 

Till

Administrator
Da rin muss in die erste Zeile :

#!/bin/bash

und danach in einer neuen Zeile der Befehl den Du benutzt um das Verzeichnis zu mounten bzw. um es zu unmounten.
 

timur

Member
so weit so gut irgendein fehler mache ich
meine cloud sagt mir:
Bereitstellungspunkt: nfs://192.168.168.9/nfs/Backups

meine /usr/local/ispconfig/server/scripts/backup_dir_mount.sh
Code:
#!/bin/bash
mount -t nfs 192.168.168.9:/nfs/Backups /var/backup
meine /usr/local/ispconfig/server/scripts/backup_dir_unmount.sh
Code:
#!/bin/bash
unmount -t nfs 192.168.168.9:/nfs/Backups /var/backup
aso ja und hab als root chmod +x also ausführbar gemacht

wenn ich nun ./backup_dir_mount.sh versuche kommt die meldung:

mount: wrong fs type, bad option, bad superblock on 192.168.168.9/nfs/Backups,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)

In some cases useful info is found in syslog - try
dmesg | tail or so.

ispconfig ist hacken bei mount drinne was hab ich falsch gemacht ?
 
Zuletzt bearbeitet:

timur

Member
ok hab die fehlermeldung wegbekommen durch
sudo apt install nfs-common

jetzt kommt auch keine fehlermeldung mehr erstmal gut :)

aber wenn ich das script ausführe manuell müsste ja eigentlich alles auf der clound abspeichern hab es überprüft aber nichts hat sich verändert ...
 

Werbung

Top