apache2 "It Works" lässt sich nicht deaktivieren

conradt

New Member
Hallo,
ich habe ein aktuelles Debian 6.0.0 aufgesetzt mit apache2 2.2.22
Die “It Works”-Seite muß ich deaktivieren, da ich den Port 127.0.0.1:80 für eigene Dienste brauche.


Ich habe den Link 000-default unter sites-enabled gelöscht, ich habe alle Konfigurationen aus sites-* entfernt, aber es ist völlig egal was ich mache, die It Works-Seite bleibt. Wer kann mir da helfen ?
 

conradt

New Member
Natürlich, natürlich habe ich den Apache neu gestartet.
Ich habe auch den Server inzwischen mehrmals neu gestartet.

Wie gesagt, es gibt weder in der apache2.conf, noch in den sites irgend einen sichtbaren Rest von der "It Works" Seite.
Sie wird aber immer angezeigt.
(Nein, es ist auch nicht der Browser Cache)
 

conradt

New Member
soweit ich sehen kann gibt es bei apache2 kein httpd.conf mehr.

Ich habe nochmal fleissig gesucht, u.a. in /etc/default/apache2 ,... bin aber wirklich nicht fündig geworden.
Ich habe alles unter /etc mit greps überzogen, den Pfad gibt es nirgens.

Im Moment bin ich der Überzeugung, der Pfad ist fest in die apache2 Binary kompiliert. zumindest steht er in der Binary drin, was sich mit
strings /usr/sbin/apache2 | grep var/www belegen lässt.
 

Till

Administrator
Zum deaktivierend der It works Seite Seite muss an sich nur nur der default vhost deaktiviert werden:

a2dissite default

und dann apache neu gestartet werden.
 

conradt

New Member
Der Befehl "a2dissite default" führt lediglich zu einem

"ERROR: Site default does not exist!"

Das ist ja das merkwürdige. Diese Site gibt es einfach nicht mehr.
 

Till

Administrator
Und Du bist sicher dass Du beim testen auf den richtigen Server zugreifst? Nicht der servername in einer hosts Datei umgebogen ist oder ähnliches. Ich weiß, ist eine blöde Frage ist aber alles schon vorgekommen :) GGF mal apache stoppen um zu verifizieren dass er dann wirklich off ist.
 

conradt

New Member
Ich bin sicher, auf dem richtigen Server zu sein, habe es gerade nochmal ausprobiert:
Auf der Gnome-Oberfläche Iceweasel und eine root-Shell gestartet.
Die It Works-Seite mit HowtoForge Linux Tutorials aufgerufen.
In der root-Shell apachectl stop gemacht.
Aktualisieren in Iceweasel: "Fehler die Verbindung zu dem Server konnte nicht hergestellt werden"
apachectl start und die Seite erscheint wieder.

Das gleiche kann mit einem Internet Explorer auf einem anderen PC beobachtet werden.

Die Seite kommt immer, egal ob in /etc/apache2/sites-enabled Einträge drin stehen, oder ob das Verzeichnis komplett leer ist.

Mein einziger Trost ist, daß sich beide Debian Wheezy-System hier identisch verhalten.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.