nach Serverupgrade Debian 10->11 ist ispconfig-Panel kastriert?!

speedy8

Member
Hallo,
hatte die Tage schon einmal geschrieben, dass ich meinen Server von Debian 10 auf Debian 11 upgraded habe. Der Server läuft auch prima, alle Webseiten funktionieren und auch der Mailserver.

Problem, was ich aktuell habe, ist zum einen, dass ich phpmyadmin nicht starten kann.
Fehlermeldung:
PHP 7.1.3+ is required.
Currently installed version is: 5.6.40-0+deb8u5

Im Forum hatte ich einen Beitrag gefunden, dass die Domain für phpmyadmin ggf. mit der falschen PHP-Version eingestellt ist. Den Fehler finde ich merkwürdig, da ich ja laut Anleitung PHP7.4 als Standard definiert habe!

Und bei der Forschung zu diesem Problem bin ich auf das viel gravierendere (laut Threat-Titel) gestoßen. Egal, ob ich mich als ADMIN oder sonstiger Nutzer im ispconfig-Backend einlogge, es fehlen mir relevante Reiter.

Als Admin habe ich nur
Übersicht | Kunden | Überwachung | Support | Einstellungen | System

Es fehlt komplett der Reiter bzgl. Sites, Web, Databases etc.

Ich habe noch einmal ein "ispconfig_update.sh --force" drüberlaufen lassen, aber keine Änderung.

Hat hier jemand eine schlaue Idee zur Problemlösung?!

Danke!
Mfg
 

Till

Administrator
Ein Debian Update kann das meines Erachtens mal nicht verursacht haben und auch ein ISPConfig Update kann das nicht verursachen. Schau unter System > CP benutzer den user admin an, dort müssen alle Module aktiviert sein.
 

speedy8

Member
Hallo,
nein, das Debian-Update hat dieses Problem nicht verursacht. Dein Hinweis zu den angeschalteten/abgeschalteten Modulen war auch nicht die Lösung, denn dort waren alle relevaten Module angeschaltet. Nein, der Fehler bestand darin, dass unter "PHP open_basedir" noch ein falscher Eintrag vorhanden war, nämlich auf eine alte nicht mehr vorhandene PHP-Version. Das habe ich geändert auf allgemein ".../usr/share/php..." ... und siehe da, die Module erschienen wieder.
Vielen dank aber dennoch.
 

speedy8

Member
So, jetzt läuft der cpanel in ispconfig wieder korrekt mit allen Modulen.
Nun wollte ich noch das phpmyadmin ans Laufen bekommen. Um Fragen zum System vorzubeugen habe ich mal das Skript mit dem htf_report laufen lassen, und da gibt es folgende Ausgabe:
Bash:
##### SERVER #####
IP-address (as per hostname): ***.***.***.***
[WARN] could not determine server's ip address by ifconfig
[INFO] OS version is Debian GNU/Linux 11 (bullseye)
 
[INFO] uptime:  21:58:50 up  5:10,  1 user,  load average: 0,41, 0,19, 0,16
 
[INFO] memory:
              gesamt       benutzt     frei      gemns.  Puffer/Cache verfügbar
Speicher:      8,0Gi       1,9Gi       9,0Mi       117Mi       6,1Gi       6,0Gi
Swap:          1,0Gi       109Mi       914Mi
 
[INFO] ISPConfig is installed.

##### ISPCONFIG #####
ISPConfig version is 3.2.8p1


##### VERSION CHECK #####

[INFO] php (cli) version is 7.4.29
[INFO] php-cgi (used for cgi php in default vhost!) is version 7.4.29

##### PORT CHECK #####

[WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
[WARN] Port 22 (SSH server) seems NOT to be listening

##### MAIL SERVER CHECK #####

##### RUNNING SERVER PROCESSES #####

[INFO] I found the following web server(s):
    Apache 2 (PID 525)
[INFO] I found the following mail server(s):
    Postfix (PID 784)
[INFO] I found the following pop3 server(s):
    Dovecot (PID 274)
[INFO] I found the following imap server(s):
    Dovecot (PID 274)
[INFO] I found the following ftp server(s):
    PureFTP (PID 769)

##### LISTENING PORTS #####
Server)         ()
Local           (Address)
[localhost]:10023               (582/postgrey)
[localhost]:10024               (406/amavisd-new)
[localhost]:10025               (784/master)
[localhost]:10026               (406/amavisd-new)
[localhost]:10027               (784/master)
[anywhere]:587          (784/master)
[localhost]:11211               (277/memcached)
[anywhere]:110          (274/dovecot)
[anywhere]:143          (274/dovecot)
[anywhere]:111          (1/init)
[anywhere]:8080         (525/apache2)
[anywhere]:80           (525/apache2)
[anywhere]:465          (784/master)
[anywhere]:21           (769/pure-ftpd)
***.***.***.***:53              (279/named)
***.***.***.***:53              (279/named)
[localhost]:53          (279/named)
[localhost]:53          (279/named)
[anywhere]:2232         (320/sshd:)
[anywhere]:25           (784/master)
[localhost]:953         (279/named)
[anywhere]:443          (525/apache2)
[anywhere]:993          (274/dovecot)
[anywhere]:995          (274/dovecot)
*:*:*:*::*:10023                (582/postgrey)
*:*:*:*::*:3306         (647/mariadbd)
*:*:*:*::*:587          (784/master)
[localhost]10           (274/dovecot)
[localhost]43           (274/dovecot)
[localhost]11           (1/init)
*:*:*:*::*:465          (784/master)
*:*:*:*::*:21           (769/pure-ftpd)
*:*:*:*::*:4949         (319/perl)
*:*:*:*::*:53           (279/named)
*:*:*:*::*:53           (279/named)
*:*:*:*::*:2232         (320/sshd:)
*:*:*:*::*:25           (784/master)
*:*:*:*::*:953          (279/named)
*:*:*:*::*:993          (274/dovecot)
*:*:*:*::*:995          (274/dovecot)
##### IPTABLES #####




##### LET'S ENCRYPT #####
[WARN] You have both certbot and acme.sh installed. This can lead to problems.
Certbot: /root/.local/share/letsencrypt/bin/letsencrypt
acme.sh: /root/.acme.sh/acme.sh
Zudem habe ich manuell über das Skript in der Anleitung "Upgrade Debian 10 to 11" die aktuellste Version von phpmyadmin runtergeladen und auch einen Cronjob für die Aktualisierung erstellt.
Wenn ich jetzt die Seite https://www.meinserver.de/phpmyadmin aufrufe, dann erhalte ich eine leere Seite.

Dann hatte ich gelesen, dass die Seite/URL möglicherweise mit einer falschen PHP-Version gestartet wird. Also habe ich ins Verzeichnis von phpmyadmin eine Datei php-info.php gelegt, und die zeigt mir dann ein PHP8.1.6 an.

Der Datenbankserver mariadb läuft ebenfalls korrekt, da ich ja sowohl ispconfig als auch alle auf dem Server laufenden CMS korrekt bedienen kann.

An welcher Stellschraube kann ich denn hier noch drehen, damit ich phpmyadmin wieder zum Laufen bekomme?

Im obigen Log ist zu sehen, dass ich 2 Varianten für die Erstellung von LetsCrypt-Zertifikaten installiert habe, das muss ich mal noch fixen. Wieso meine IP-Adresse angeblich nicht in ifconfig ersichtlich sein soll, kann ich nicht nachvollziehen, denn dort ist sie vorhanden.

Vielen Dank schonmal für weitere hilfreiche Tipps.

Mfg
 

Till

Administrator
An welcher Stellschraube kann ich denn hier noch drehen, damit ich phpmyadmin wieder zum Laufen bekomme?

Das msste das mod_php sein, dass Du auf 7.4 umstellen musst.

Nein, der Fehler bestand darin, dass unter "PHP open_basedir" noch ein falscher Eintrag vorhanden war, nämlich auf eine alte nicht mehr vorhandene PHP-Version.
Du meinst die Einstellung in ISPConfig, oder in der php.ini?
 

speedy8

Member
Hallo,

Das msste das mod_php sein, dass Du auf 7.4 umstellen musst.
mmhh, wie soll ich das machen?
Ich habe eben mal geschaut, welche Module unter Apache so installiert sind, mit "apache2ctl -M".
Die Ausgabe davon sieht wie folgt aus:
Code:
AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.vhost:7
Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 actions_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 auth_digest_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_groupfile_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 cgi_module (shared)
 dav_module (shared)
 dav_fs_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 fastcgi_module (shared)
 fcgid_module (shared)
 filter_module (shared)
 headers_module (shared)
 include_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 passenger_module (shared)
 php_module (shared)
 proxy_module (shared)
 proxy_fcgi_module (shared)
 python_module (shared)
 reqtimeout_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)
 suexec_module (shared)
Und dann habe ich entsprechend der Upgrade-Anleitung auch noch folgendes gemacht

Code:
update-alternatives --config php

Es gibt 5 Auswahlmöglichkeiten für die Alternative php (welche /usr/bin/php bereitstellen).

  Auswahl      Pfad             Priorität Status
------------------------------------------------------------
  0            /usr/bin/php8.1   81        automatischer Modus
  1            /usr/bin/php5     50        manueller Modus
  2            /usr/bin/php7.3   73        manueller Modus
* 3            /usr/bin/php7.4   74        manueller Modus
  4            /usr/bin/php8.0   80        manueller Modus
  5            /usr/bin/php8.1   81        manueller Modus


update-alternatives --config php-cgi

Es gibt 3 Auswahlmöglichkeiten für die Alternative php-cgi (welche /usr/bin/php-cgi bereitstellen).

  Auswahl      Pfad                 Priorität Status
------------------------------------------------------------
  0            /usr/bin/php-cgi7.4   74        automatischer Modus
  1            /usr/bin/php-cgi7.3   73        manueller Modus
* 2            /usr/bin/php-cgi7.4   74        manueller Modus
  3            /usr/bin/php5-cgi     50        manueller Modus

update-alternatives --config php-fpm.sock

Es gibt 2 Auswahlmöglichkeiten für die Alternative php-fpm.sock (welche /run/php/php-fpm.sock bereitstellen).

  Auswahl      Pfad                      Priorität Status
------------------------------------------------------------
  0            /run/php/php7.4-fpm.sock   74        automatischer Modus
  1            /run/php/php7.3-fpm.sock   73        manueller Modus
* 2            /run/php/php7.4-fpm.sock   74        manueller Modus

a2disconf php7.3-fpm
a2enconf php7.4-fpm
systemctl restart apache2
Aber phpmyadmin zeigt mir noch immer nur eine weiße Seite an.

Du meinst die Einstellung in ISPConfig, oder in der php.ini?
Ich meinte in ISPConfig, da hatte ich unter open_basedir entsprechend ein "/usr/share/php5" stehen, und das habe ich einfach zu "/usr/share/php" geändert.

Also offensichtlich habe ich irgendwas noch nicht so richtig konfiguriert!?
 

Werbung

Top