Zertifikat läuft immernoch ab

Hey,

ich habe immer noch das Problem das daß die Zertifikate ablaufen.
Ich hänge mal zwei Bilder meines Mailclienten (Thunderbird) an.

Wenn ich das neue Zertifikat annehme können zwar weiterhin Mails versenden jedoch werden diese nicht mehr gespeichert (siehe Screenshot)
Erst nachdem ich in Thunderbird das Emailkonto gelöscht und wieder neu erstellt habe funktioniert es wieder tadellos (zirka drei Monate).

Viele Grüße
Ronny
 

Anhänge

Till

Administrator
Was für ein Zertifikat ist es, Let#s encrypt? Wenn ja, welcher client, certbot oder acme.sh? Hast Du mal Postfix und Dovecot neu gestartet und dann geschaut, ob das Zertifikat danach von Thunderbird richtig angezeigt wird?
 

florian030

Active Member
Wenn sich ein Zertifikat erneuert, musst Du Dovecot neu starten, damit der das mitbekommt. Postfix ist da etwas intelligenter und bekommst das selbst mit.
 
Ich habe die Emailkonten beim Mailclient gelöscht und neu erstellt. Ich benutzte immer SSL/TLS.
Ich versuche mal STARTTLS zu benutzen.
 

Till

Administrator
Hab mir gerade nochmal Deinen ersten screenshot angesehen, ich vermute mal Du hast eine falsche Domain in Deinem mailclient als smtp oder imap server eingetragen. denn der fehler sagt ja nicht dass die Domain abgelaufen ist, sondern dass Du Dich mit der falschen Domain verbindest, also nicht den Hostnamen des Servers nutzt, aufd en das Zertifikat ausgestellt ist. Du musst also im mail Client den Hostnamen des Servers eintragen und nicht eine subdomain der Emaildomain. Ruf auf dem server mal auf:

hostname -f

und exakt die subdomain die Du dort angezeigt bekommst, musst Du im mail client verwenden.
 
Ok. Das teste ich mal.
Der Hostname ist natürlich sehr schwer merkbar.

Gibt es eine andere Lösung bei der das Zertifikat auf die Domain ausgestellt wird?
 

Till

Administrator
Naja, so wie ich sehe hast Du vergessen einen 'vernünftigen' Hostnamen vor der Installation zu setzen, sowas wie server1.meinedomain.tld. Der nächste Schritt wäre also dass Du den Hostnamen änderst, damit Du dann einen vernünftigen Hostnamen im SSL cert hast.

Der Hostname steht in:

/etc/hosts
/etc/hostname
/etc/mailname

ggf. auch in /etc/postfix main.cf

Hostname musst natürlich im DNS existieren. Danache system neu starten und dann:

ispconfig_update.sh --force

und vom Updater das SSL Zertifikat neu erstellen lassen.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.