Webseite wird nicht angezeigt - ERR_ADDRESS_UNREACHABLE

#1
Hallo

nachdem mehrmals (min. 5 x) die Installation nach Anleitung von The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache (lokal unter v-box, host ist auch ubuntu)… installiert habe, läuft zwar ISPConfig 3 unter server.meine_domain.local:8080/ bzw. http(s)://locale.ip:8080/. Leider funktioniert, nach dem Anlegen von Webseiten unter ISPConfig, das Aufrufen der Webseite mit dem Browser nicht.
Meldung unter Chrome ist ERR_ADDRESS_UNREACHABLE, unter Firefox das übliche „Fehler: Verbindung fehlgeschlagen“, auch ping auf die ip der angelegten Webseite: „Destination Host Unreachable“
Kurz und gut dachte ich mir, du übersiehst was! Habe mir dann voller Erwartung das .ova von howtoforge heruntergeladen… das gleiche… Webseiten sind nicht erreichbar!
Nun bin ich ratlos, ich habe gegooglt und gesucht vieles auch mit dem gleichen Problem gefunden, jedoch sehr wenige, wenn überhaupt irgendwelche Lösungen die mein Problem lösen könnten!

Jede Hilfe wäre willkommen … und folgend ein paar logs:

The authenticity of host '192.168.178.50 (192.168.178.50)' can't be established.
ECDSA key fingerprint is SHA256:xxxxxxxxxxxxxxxxxxxxxx…….pw.
Failed to add the host to the list of known hosts (/home/mpa/.ssh/known_hosts)←?? sollte evtl. daran liegen?

apachectl configtest
AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
Syntax OK

root@server:/etc/apache2/sites-enabled# ls -l
total 0
lrwxrwxrwx 1 root root 39 Apr 26 18:22 000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
lrwxrwxrwx 1 root root 35 Apr 26 17:42 000-default.conf -> ../sites-available/000-default.conf
lrwxrwxrwx 1 root root 43 Apr 26 18:22 000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
lrwxrwxrwx 1 root root 44 Apr 26 18:23 000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost
lrwxrwxrwx 1 root root 50 Oct 6 09:54 100-datamedia.local.vhost -> /etc/apache2/sites-available/datamedia.local.vhost


root@server:/etc/apache2/sites-available# ls -l
total 28
-rw-r--r-- 1 root root 1332 Oct 23 2017 000-default.conf
-rw-r--r-- 1 root root 1354 Oct 6 11:56 apps.vhost
-rw-r--r-- 1 root root 2421 Oct 6 11:58 datamedia.local.vhost
-rw-r--r-- 1 root root 6338 Oct 23 2017 default-ssl.conf
-rw-r--r-- 1 root root 2161 Oct 6 11:56 ispconfig.conf
-rw-r--r-- 1 root root 3267 Oct 6 11:16 ispconfig.vhost

root@server:/etc/apache2/sites-available# apachectl configtest
AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
Syntax OK

root@server:/etc/apache2/sites-available# apache2ctl -S
AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
VirtualHost configuration:
192.168.178.52:80 datamedia.local (/etc/apache2/sites-enabled/100-datamedia.local.vhost:7)
*:8081 server.isp.local (/etc/apache2/sites-enabled/000-apps.vhost:9)
*:80 server.isp.local (/etc/apache2/sites-enabled/000-default.conf:1)
*:8080 server.isp.local (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"

/var/log/apache2/error.log
[Sat Oct 06 12:36:45.901866 2018] [ssl:warn] [pid 1177] AH01909: server.isp.local:8080:0 server certificate does NOT include an ID which matches the server name
[Sat Oct 06 12:36:45.901996 2018] [ssl:error] [pid 1177] AH02217: ssl_stapling_init_cert: can't retrieve issuer certificate! [subject: O=Internet Widgits Pty Ltd,ST=Some-State,C=AU / issuer: O=Internet Widgits Pty Ltd,ST=$
[Sat Oct 06 12:36:45.902007 2018] [ssl:error] [pid 1177] AH02604: Unable to configure certificate server.isp.local:8080:0 for stapling
[Sat Oct 06 12:36:45.913688 2018] [mpm_prefork:notice] [pid 1177] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.15rc1 OpenSSL/1.1.0g configured -- resuming normal operations
[Sat Oct 06 12:36:45.913757 2018] [core:notice] [pid 1177] AH00094: Command line: '/usr/sbin/apache2'

das war es mit meinem Latein.

Jede Hilfe wäre schön!

*edit:
root@server:/etc# a2ensite datamedia.local
ERROR: Site datamedia.local does not exist!

auch ein ping vom Server selbst auf die 192.168.178.52 funktioniert nicht, ich weiß nicht ob diese neue Konfiguration des Netzwerks die jetzt über „netplan“ gesteuert wird, evtl. bei mir nicht klappt!? Bis Debian 8 hatte bislang bei mir alle funktioniert. Dort konnte ich aber noch auf den ISPConfig Reiter Serverkonfiguration eth0 einstellen und auch der Standard Gateway war damals richtig übernommen worden... weiss wirklich nicht mehr weiter.. ob evtl. besser wäre netplan zu deinstallieren und ifupdown wieder benutzen!?
 
Zuletzt bearbeitet:

Till

Administrator
#2
Wenn Du nicht einmal die lokale IP Deines servers anpingen kannst, hast Du ein Netzwerk Konfigurationsproblem. Das ist also technisch sozusagen noch eine eben Unter der webserver config die ISPConfig anlegt, daher brauchst Du im bereich Apache erstmal nicht weiter nachd em fehler suchen, das problem liegt im netzwerk. Du musst die Ip anpingen können und bei eingabe der IP im Browser sollte die apache default page oder die seite einer angelegten website kommen und kein netzwerk Fehler. Handelt es sich beid er Ip denn um eine zusätzliche Ip die Du in der VM eingerichtet hast oder die Haupt IP? da Du sagst dass Du ISPConfig erreichen kannst, muss es sich ja um eine zusätzliche IP handeln?
 
#3
Hallo Till. Danke erstmal für die Antwort.
Nein die Server IP 192.168.178.50 selbst kann ich pingen. Die in ISPConfig angelegte IP 192.168.178.52 die kann ich nicht pingen. Ja folglich ist das die zusätzliche IP. Muss man denn nicht eine neue IP Anlegen um die Webseiten dann einrichten zu können?

Was ich sagen wollte ist, dass wenn ich auch die 192.168.178.52 vom server selbst an pinge funktioniert die nicht.
 

Till

Administrator
#4
Muss man denn nicht eine neue IP Anlegen um die Webseiten dann einrichten zu können?
Nein, Du brauchts keine neue IP. Einfach * im IPv4 feld der Website auswählen und die Domain der website auf die haupt IP zeigen lassen. Wenn Die Domain der website nicht im DNS existiert (z.B. weil es eine interne Domain ist), dann musst Du sie in der hosts Datei Deines Desktops eintragen, das geht unter Windows, Linux und MAC.
 
#5
Alles schon ausprobiert. Hat früher mit Debian8 auch so funktioniert, einen DNS habe ich selbst nicht eingerichtet. Dafür wie Du schon sagtest die hosts im Desktop mit der extra angelegten IP. Wie erwähnt, früher hat das so funktioniert. Wenn ich die http://192.168.178.50/ in die url eingebe, ja dann kommt apache default page bei http://192.168.178.52/ die übliche Fehlermeldung.
 
#6
Oje, jetzt nachdem ich die hosts im Desktop von 192.168.178.52 auf die 192.168.178.50 für datamedia.local gesetz habe und * im IPv4 feld, funktioniert es *happy now*. Ich verstehe es zwar noch nicht ganz, weil wie erwähnt früher hab ich das immer so eingestellt ohne DNS und es funktionierte... hätte nicht gedacht, dass so auch funktionieren kann!? Da ja in der hosts vom Desktop nun zwei Domain namen auf die gleiche IP zeigen? Somit wäre die domain der angelegten Webseiten nicht mehr über ip in url erreichbar... nun gut, ohne DNS.. fürs erste ist das eine Lösung.
HERZLICHEN DANK FÜR DEINE ZEIT!
 
Zuletzt bearbeitet:

Werbung

Top