warning: connect #1 to subsystem /var/spool/postfix/private/proxymap: Permission denied

Laubie

Member
Hallo zusammen,
da meine Server in letzter Zeit super laufen, war ich ja ewig nicht hier ... Jetzt habe ich aber ein merkwürdiges Problem:
Code:
postfix/smtpd[22356]: warning: connect #1 to subsystem /var/spool/postfix/private/proxymap: Permission denied
..
..
postfix/smtpd[22356]: fatal: connect #11 to subsystem /var/spool/postfix/private/proxymap: Permission denied
Der Server ist relativ frisch (2 Monate) und läuft nach dem Perfekten-Server-Setup auf Debian 10.

Der Fehler tritt immer mal wieder auf. Mal stundenlang nicht, dann 3-4 mal pro Stunde.

Ich habe schon eifrig gegoogelt, aber kein Tipp hat bislang geholfen.
(postfix neustart, proxymap in der master.cf)

Viele Grüße
Laubie
 

Laubie

Member
Da ich 2 gleiche Server laufen habe (den einen von Debian 9 auf 10 upgedatet - der andere von Anfang an auf 10) habe ich mal verglichen.

Alter Server - ohne Fehlermeldung master.cf
Code:
smtps      inet  n       -       y       -       -       smtpd
    -o syslog_name=postfix/smtps
    -o smtpd_tls_wrappermode=yes
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
Neuer Server - mit Fehlermeldung master.cf
Code:
smtps     inet  n       -       -       -       -       smtpd
  -o syslog_name=postfix/smtps
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
Man beachte das fehlende y beim neuen Server.

Ich habe noch mal im how-To nachgeschaut, da ist das y auch nicht enthalten...

Könnte das der Grund sein? Ist dann das HowTo falsch?

Edit:
Bei der submission-Einstellung fehlt auch das y.

Auch komisch: Im Howto hier: https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/
fehlen die "y" - im howto hier: https://www.howtoforge.com/perfect-server-debian-10-nginx-bind-dovecot-ispconfig-3.1/
Sind die "y"s gesetzt...
Dabei ändern sich da doch nur die Webserver...

Grüße
Laubie
 
Zuletzt bearbeitet:

Laubie

Member
Ich habe mal gerade gelesen.
Die Standardeinstellung für Chroot hat sich von postfix 2 auf postfix 3 von y auf n geändert.
Könnte es sein, dass das Apache-howTo vor dem Sprung von 2 auf 3 geschrieben wurde und das NGINX-HowTo danach?
Laut Changelog war der Versionssprung im Februar 2019

Grüße

PS: Ich muss mal kurz raus, werde es danach aber mal ausprobieren.
 

Laubie

Member
Huhu,
Leider habe ich den Fehler immer noch nicht abstellen können. Er erscheint mal ne Stunde lang nicht, dann wieder alle 4-6 Minuten ... ganz willkürlich.
Es muss also tatsächlich was mit einem manuellen Ereignis zu tun haben.
Da im Log ja postfix/smtpd steht, kann es gar nicht der o.g. Eintrag sein, der müsste ja postfix/smtps heißen ... wie kann ich denn jetzt besser nach dem Fehler suchen, bzw. was würde euch helfen, mitzusuchen :)

kann ich an jeden Eintrag in die master.cf ein "-o syslog_name=hier_suche_ich_richtig" eintragen?

Grüße
Laubie
 

Laubie

Member
Hallo zusammen ...
mittlerweile rate ich mehr ins blaue hinein, was noch falsch sein könnte ...
Ich habe gerade die Ausgaben beider Server von postvonf -M verglichen.
Da ist alles soweit identisch. Lediglich beim neuen Server gibt es den Eintrag
Code:
postlog    unix-dgram n  -       n       -       1       postlogd
Wofür ist der gut?

Edit: OK. Habs schon ... ist für das postfix-eigene Logging
 
bei mir kommt das auch vor.
Und zwar wird das ausgelöst, wenn ich von Nextcloud eine Mail versenden will, z.B: neuer Benutzer oder Passwort vergessen etc.
Leider habe ich keine Lösung

Edit: beim 11. Mal wird dann fatal :)
Code:
fatal: connect #11 to subsystem /var/spool/postfix/private/proxymap: Permission denied
 

Laubie

Member
spannender Hinweis!
Auf meinem Server laufen 2 Nextcloud-Instanzen.
Es ist ein Server, den 2 Schulen nutzen. Aktuell findet sich der Fehler nicht in den Logs. Ich habe aber gesehen, dass bei einem der Mailversand falsch konfiguriert war (über den mail-Befehl, statt über SMTP).
Das habe ich jetzt geändert. Bin gespannt. Danke für den Tipp.
Viele Grüße
 
in meiner mail.err tauchten auch sehr viele
Code:
fatal: proxymap service is not configured for table "mysql:/etc/postfix/mysql-virtual_sender-relayhost.cf"
auf.

Das Update auf ISPconfig 3.2.5 hat letztendlich geholfen.

Beim Update wurde ich gefragt, ob der deaktivierte Dienst mail_server aktiviert und konfiguriert werden soll (OMG?!?!?).
Also natürlich ja und danach lief alles wieder. Leider kein wirklichen Plan, was da schief gelaufen ist. /etc ist leider immer noch nicht in einem git... Schande über mich.
 
Welches OS? Falls Debian 10, hast Du dich via 'sudo' oder 'sudo -' als root angemeldet? Ab Debian 10 geht nur noch 'sudo -', ohne den '-' läd er die PATH variable nicht und findet somit alle mögliche Software nicht mehr als root.
Ja Debian 10 (nach Upgrade seit Debian???). Ich verwende den root ohne Passwort...
Wurde ich übrigens auch für den web_server und so weiter gefragt. Nur nach dns und db vserver wurde ich nicht gefragt. In der Konfiguration ist alles außer vserver und XMPP aktiviert. Kein Multiserver-Setup. Läuft seit Jahren prima, bis eben jetzt auf das Email-Problem. Aber wie gesagt, jetzt läuft es wieder :)
 

Till

Administrator
Merkwürdig, dann weiß ich auch nicht warum er das nochmal gefragt hat. macht er an sich nur, wenn er mittels 'which' Befehl die entsprechenden programme wie postfix/dovecot nicht auf dem Server findet.
 

Laubie

Member
spannender Hinweis!
Auf meinem Server laufen 2 Nextcloud-Instanzen.
Es ist ein Server, den 2 Schulen nutzen. Aktuell findet sich der Fehler nicht in den Logs. Ich habe aber gesehen, dass bei einem der Mailversand falsch konfiguriert war (über den mail-Befehl, statt über SMTP).
Das habe ich jetzt geändert. Bin gespannt. Danke für den Tipp.
Viele Grüße
Moin! Mal ein Update von mir:
Ich habe noch mal über alle NextCloud-Einstellungen akribisch drüber geschaut. Tatsächlich stand in einer Instanz noch als Mail-Option der mail-Befehlt. Diesen habe ich durch einen gültigen SMTP-Account ersetzt.

Nun bleibt der Fehler weg.

Danke für den Hinweis!!
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.