Verzeichniss Schutz

vpns2000

Member
Hallo alle,
seit meinen Update auf die 2.2.25 habe ich das Problem das ich plötzlich keinen verzeichniss schutz mehr erstellen kann und auch wie mir gerade aufgefallen ist auch in den stats verzeichniss keine abfragen mehr kommen.

Wurde das ganze tool entfert.

Danke
 

Till

Administrator
Also stats und Verzeichnisschutz sind ja twei unterschiedliche Sachen.

Also,

1) bei Dir ist im Web-FTP Programm keine Option für Verzeichnisschutz mehr zu sehen?
2) Es werden keine Webalizer Statistiken mehr aktualisiert? Oder benutzt Du awstats?
 

vpns2000

Member
Hallo Till,
sorry für meine vielleicht etwas verwirrende schreibweise.

1.) Also es ist so das die stats also Statitken serwohl genneriert werden es aber früher immer so was wenn ich domain.com/stats aufgerufen habe ich mich mit username und Password anmelden musste.
Jetzt ist das nicht mer der Fall und ist somit für jederman öffentlich zugänlich.

2.) Ich habe heute via ISP versucht ein Verzeichnis auf meinen Host zu Schützten. Ich habe zwar die Möglichkeit dafür und ich werde auch beim erstellen nach Usernamen und Passwird gefragt doch wenn ich dann wie Web den unterordner aufzufufen steh ich in dem als wäre nichts gewesen. Also ohne User und PW abfrage.

Eigenartigerweise kann ich auch kein .htaccess file finden.

LG
 

vpns2000

Member
Hallo Till,
ich habe jetzt mal den Server mehrmals neu gestartet und nun siehe da ich habe eine .hteccess datei.

Code:
insgesamt 92
drwxr-xr-x  2 ispweb65_admin web65  4096 22. Sep 04:00 .
drwxrwxr-x  5 ispweb65_admin web65  4096 23. Sep 21:38 ..
-rw-r--r--  1 ispweb65_admin web65  2296 23. Sep 04:00 ctry_usage_200809.png
-rw-r--r--  1 ispweb65_admin web65  2678 23. Sep 04:00 daily_usage_200809.png
-rw-r--r--  1 ispweb65_admin web65 12288 22. Sep 04:00 dns_cache.db
-rw-r--r--  1 ispweb65_admin web65  1732 23. Sep 04:00 hourly_usage_200809.png
-rw-rw-r--  1 ispweb65_admin web65   126 23. Sep 04:00 .htaccess
-rw-r--r--  1 ispweb65_admin web65  3707 23. Sep 04:00 index.html
-rw-r--r--  1 ispweb65_admin web65 43415 23. Sep 04:00 usage_200809.html
-rw-r--r--  1 ispweb65_admin web65  2132 23. Sep 04:00 usage.png
-rw-r--r--  1 ispweb65_admin web65  2595 23. Sep 04:00 webalizer.current
-rw-r--r--  1 ispweb65_admin web65    31 23. Sep 04:00 webalizer.hist
ich habe auch im web verzeichnis auch eine .htpasswd gefunden.

Doch wenn ich nun die Domain aufrufe funkt der verzeichnisschutz dennoch nicht. Weder im stats noch im unterverzeichnis welches ich schützen möchte.

LG
 

Till

Administrator
Doch wenn ich nun die Domain aufrufe funkt der verzeichnisschutz dennoch nicht. Weder im stats noch im unterverzeichnis welches ich schützen möchte.
Ok, dann können wir es schonmal soweit eingrenzen, dass es nicht an ispconfig oder den statistik scripten liegt. Vermutlich ist irgendwo in Deiner apacheKonfiguratíon (apache2.conf) der .htaccess schutz abgeschaltet.
 

vpns2000

Member
Hallo Till,
und wo kann ich den wieder einschelten?
in /etc/httpd/conf/httpd.conf oder in der /etc/httpd/conf/vhost/ispvhost.conf

Danke
LG
 

Till

Administrator
Wie ich oben geschrieben habe, hat das nichts mit ISPConfig zu tun, also bleibt ja nur die httpd.conf Datei.
 

vpns2000

Member
Hallo Till,
also ich google heute schon einige zeit nach htaccess aber finde scheinbar den wald vor lauter bäume nicht. komme einfach nicht drauf was da stehen sollte oder wo ich etwas geändert haben könnte. Zumal ich seit fast 2 Jahren nichtsmehr geändert habe ausser das ich die Udates eingespielt habe. Aufgefallen ist mir das beim Update von 2.2.23 auf 2.2.25.


Danke
LG
 
Zuletzt bearbeitet:

vpns2000

Member
Hallo,
also irgend wie werde ich aus dem ganzen nicht wirklich schlauer.

um .htaccess zu aktivieren soll doch in der httpd.conf

Code:
AllowOverride All
stehen.
Aber bei mir steht überall

Code:
<Directory /var/www/sharedip>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>


###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

<Directory /home/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /home/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>                                                       

Include /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf
Soll ich das alles ändern damit .htaccess wieder funktioniert???

Danke
LG
 

Till

Administrator
Die Folgende Zeile erlaubt bereits den htpasswd Schutz:

AllowOverride Indexes AuthConfig Limit FileInfo

Das Problem bei Dir ist aber nicht, dass der .htpasswd schutz nicht erlaubt ist, sondern dass er nicht aktiviert ist. Wenn er nur nicht erlaubt wäre und es somit am AllowOverride liegen würde, dann würdest Du einen 500er Fehler bekommen, sobald Du die Statistik aufrufst.

Poste bitte mal die Ausgabe von (muust Du im Verzeichnis der httpd.conf ausführen):

grep AccessFileName http.conf
 

vpns2000

Member
Hallo Till,
der Output ist

Code:
# AccessFileName: The name of the file to look for in each directory
AccessFileName .htaccess
Also -htaccess ist eingetragen

LG
 

Werbung

Top