suPHP - PHP in den Sub-Benutzerwebspaces

Till

Administrator
Die User sites können keine Scripte ausführen, das ist unabhängog ob Du su_php oder mod_php nimmst.
 

daben

Member
danke für die Antwort.
seltsam ist, auf meinem Testsystem mit mod_php funktioniert das...

Hier ein paar Werte wenn ich im Userspace phpinfo() aufrufe:

Loaded Modules core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_include mod_mime mod_negotiation mod_php5 mod_rewrite mod_setenvif mod_ssl mod_status mod_suexec

safe_mode Off
safe_mode_exec_dir no valueno
safe_mode_include_dir no valueno
SCRIPT_URL /~web17_test/index.php
SCRIPT_URI http://testvm.test.test/~web17_test/index.php
DOCUMENT_ROOT /var/www/web17/web
SCRIPT_FILENAME /var/www/web17/user/web17_test/web/index.php
 

Till

Administrator
Dann hast Du Dich wohl nicht ganz an die Installationsanleitung gehalten. Deshalb ist PHP bei Dir jetzt immer aktiv, was unter umständen ein Sicherheitsrisiko ist.
 

daben

Member
Das würde ja dann bedeuten, dass sobald ich PHP für die Webseite <web17webseite.de> trotzdem PHP noch funktionieren müsste oder?
Ist aber dann nicht der Fall...

Ich denke mal dass du diese Einstellungen meinst:

/etc/mime.types
<code>
##ISPConfig INSTALL## application/x-httpd-php phtml pht php
##ISPConfig INSTALL## application/x-httpd-php-source phps
##ISPConfig INSTALL## application/x-httpd-php3 php3
##ISPConfig INSTALL## application/x-httpd-php3-preprocessed php3p
##ISPConfig INSTALL## application/x-httpd-php4 php4
</code>

/etc/apache2/mods-enabled/php5.conf"
<IfModule mod_php5.c>
# AddType application/x-httpd-php .php .phtml .php3
# AddType application/x-httpd-php-source .phps
</IfModule>


sind so gesetzt
 
Zuletzt bearbeitet:

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.