[SOLVED] Problem nach Update auf 3.1.15p3

michl70

New Member
Hallo,

Ich bin etwas am verzweifeln, kurzer Überblick was bisher geschehen ist.

Hetzner Root Server - komplett neu installiert mit debian 10.5 minimal alle updates gemacht
und ISPconfig nach dieser Anleitung installiert https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/

Lief alles perfekt, ich konnte ohne Probleme meine Domains anlegen, lief alles perfekt.
Dann machte ich das Update auf 3.1.15p3 und plötzlich kann ich bei "Webseiten" im ISPConfig nichts mehr einstellen bei der betreffenden Domain.

Also bei UMLEITUNG, SSL, STATISTIKEN, BACKUP und OPTIONEN kommt immer die gleiche Fehlermeldung "Unknown column 'fastcgi_php_version' in 'field list' "
Komischerweise funktioniert PHP aber https://www.bitandbyte.org/info.php

Beim Update selber sind bereits diese Fehlermeldungen gekommen

PHP Warning: fopen(/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter): failed to open stream: Operation not permitted in /tmp/update_runner.sh.RBRgQOFasM/install/lib/install.lib.php on line 466
PHP Warning: fwrite() expects parameter 1 to be resource, bool given in /tmp/update_runner.sh.RBRgQOFasM/install/lib/install.lib.php on line 469
PHP Warning: fclose() expects parameter 1 to be resource, bool given in /tmp/update_runner.sh.RBRgQOFasM/install/lib/install.lib.php on line 470
chmod: changing permissions of '/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter': Operation not permitted
chown: changing ownership of '/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter': Operation not permitted

Habt ihr einen Tipp für mich damit ich das ohne Neu-Installation wieder hinbekomme ?

lg
Michael
 

Till

Administrator
Das Problem ist dass Du vermutlich aus Versehen ein Downgrade gemacht hast, was natürlich nicht gehen kann da die Datenbank jetzt nicht mehr zum Sourcecode des Programms passt, denn wenn Du stable installiert hättest, wäre kein Update auf 3.1.15p3 möglich gewesen, da stable 3.1.15p3 ist.

Du musst jetzt also wieder zurück auf die ursprüngliche neuere Version updaten:

Code:
cd /tmp
wget -O ISPConfig-3.1-dev.tar.gz  https://git.ispconfig.org/ispconfig/ispconfig3/repository/archive.tar.gz?ref=stable-3.1
tar xfz ISPConfig-3.1-dev.tar.gz
cd ispconfig3-stable-3.1*
cd install
php update.php
 

michl70

New Member
Ok Super, danke für die rasche Antwort. Nein war mir nicht bewusst das ich ein Downgrade gemacht habe, denn ich habe nur "php update.php" gestartet. Der Rest lief von selbst und bei der Frage ob Stable etc. hab ich "Stable" gelassen .. komisch.

Aber Danke Till, ich probier das dann gleich aus.
Versteh ich das richtig, das man da einfach "drüber installieren" kann ? bleiben dann die bestehenden VHOSTS eingerichtet oder muss man das dann neu machen ?

lg
Michael
 

Till

Administrator
Ok Super, danke für die rasche Antwort. Nein war mir nicht bewusst das ich ein Downgrade gemacht habe, denn ich habe nur "php update.php" gestartet. Der Rest lief von selbst und bei der Frage ob Stable etc. hab ich "Stable" gelassen .. komisch.
Du hast ja jetzt auch stable installiert, nur hattest Du vorher nicht stable sonder 3.1dev, also eine viel neuere Entwicklerversion installiert.

Aber Danke Till, ich probier das dann gleich aus.
Versteh ich das richtig, das man da einfach "drüber installieren" kann ? bleiben dann die bestehenden VHOSTS eingerichtet oder muss man das dann neu machen ?
Du installierts ja nicht drüber, Du machst ein Update auf die richtige Version.
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.