[solved] missing virtualhost for 443

Sunghost

Member
Hi,
i have a installation of isp (latest) on an testenvironment.
- I add a new testsite but notice that the virtualhost for 443,
- SSL self sign Option, is not created.
- I have on all testsites * for ip configured,
- ssl is for all sites enabled too.

i have restart the server, deactivate the site and activate, but the virtualhost 443 is not added to site-available / site-enabled. The Logs seems normal, i cant find a error. As a result the first alphabetic site is shown ... i checked faq ...

Any idea what to check ?

Thx
 

Till

Administrator
Schön wäre es erst mal im Forum zu schauen bevor man postet, das wurde schon oft beantwortet und es gibt sogar ein FAQ mit Checkliste dafür. Siehe sticky post oben in diesem Forum:


Jedem Schritt folgen und prüfen, dann weißt Du am Ende woran es liegt, denn spätestens wenn Du den Debug output postests falls alle anderen schritte ok waren, ist klar woran es liegt. Da Dein Post den dbug output nicht enthält, bist Du dem FAQ auch nicht vollständig gefolgt.
 

Sunghost

Member
Hi Till,
das ist ein Testsystem ohne Zugriff von außen. Dh. es wird kein Let's Encrypt verwendet, sondern ein Self-Signed-Cert, Option SSL. Hilft oben also nur bedingt. Alle anderen zuvor eingerichteten Seiten laufen ohne Probleme.

Debug zeigt:
Code:
# /usr/local/ispconfig/server/server.sh
25.05.2022-14:17 - DEBUG [plugins.inc:155] - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
25.05.2022-14:17 - DEBUG [server:217] - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished server.php.
[gelöst] - Sorry für die Aufregung - nachdem ich alle Schritte wieder und wieder geprüft hatte, viel mir auf, dass ich das grundlegendste vergessen hatte. Ich hatte schlicht unter SSL, das Cert nicht erstellen lassen :duck und weg:
Sorry Jungs :) - evtl. sollte der Haken bei SSL, wenn kein Cert vorhanden ist, nicht aktiviert bleiben oder ...
 
Zuletzt bearbeitet:

Werbung

Top