SMTP über SSL nicht möglich

faulix

New Member
Hallo,

ich habe folgendes Problem, wenn ich versuche eine E-Mail zu versenden:
Mail konnte keine SSL-Verbindung zum Server „mydomain.tld“ über den Port 587 herstellen. Vergewissern Sie sich, dass dieser Server SSL unterstützt und dass ihre Accounteinstellungen korrekt sind.
Folgende Konfiguration habe in in /etc/postfix/sasl/smtpd.conf gemacht:
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: ispconfig
sql_passwd: sqlpw
sql_database: dbispconfig
sql_select: select password from mail_user where login = '%u'
In der auth.log habe ich folgendes gefunden:
Apr 13 12:01:11 hostname postfix/smtpd[4166]: sql auxprop plugin using mysql engine
Scheinbar erreicht die Anfrage auch den Server und der Server macht eine Datenbankabfrage.

Ansonsten finde ich in keiner Log-Dateien irgendwelche Hinweise, hoffe jemand kann mir weiter helfen.

Liebe Grüße,
Stefan
 

faulix

New Member
Ich muss mich korrigieren: Auch das Versenden ohne SSL-Verschlüsselung funktioniert nicht, dann werde ich nach einem Passwort gefragt und das korrekte Passwort wird im E-Mail-Client nicht angenommen.

Vermutung: Irgendetwas stimmt nicht mit der Abfrage der Benutzerdaten per mySQL?

Hintergrund: Ich habe vor kurzem einen Serverumzug vorgenommen.

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_enforce_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mydomain.tld
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = mail.mydomain.tld, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
inet_protocols = all
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $se$
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_client_message_rate_limit = 100
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
owner_request_special = no
html_directory = /usr/share/doc/postfix/html
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0
 

faulix

New Member
Entschuldigung, mein Fehler. Da hab ich nicht genau genug gelesen :D

Ich hab direkt gesehen, dass die entsprechenden Zeilen auskommtiert waren, jetzt erhalte ich jedoch den gleichen Fehler wie ohne Verschlüsselung: Die Authentifizierung funktioniert nicht.

Nun erhalte ich jedoch eine entsprechende Fehlermeldung in der mail.log:
Apr 14 11:52:50 hostname postfix/smtpd[3298]: connect from xxxxxxxx.adsl.alicedsl.de[85.XXX.XXX.18]
Apr 14 11:52:51 hostname postfix/smtpd[3298]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Apr 14 11:52:51 hostname postfix/smtpd[3298]: warning: SASL authentication failure: Password verification failed
 

Till

Administrator
Poste bitte mal die master.cf Datei. Nach welchem Tutorial hast Du den server installiert? hast Du seitdem ein Linux distributions upgrade gemacht?
 

faulix

New Member
Auf dem alten Server läuft/lief folgender Kernel: 2.6.34.6-xxxx-grs-ipv6-32 (OVH build)
Auf dem neuen Server läuft folgender Kernel: 2.6.32-5-amd64
Ansonsten sind auf beiden Servers die aktuellen Pakete.

Für den neuen Server habe ich folgende Anleitung verwendet:
The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3] | HowtoForge - Linux Howtos and Tutorials
Für den Umzug der Daten/Einstellungen habe ich folgende Anleitung verwendet:
http://www.howtoforge.de/forum/inst...ckup-bzw-serverumzug-und-kundentransfer-3186/

Meine master.cf sieht derzeit wie folgt aus:
smtp inet n - - - - smtpd
submission inet n - - - - smtpd
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject
-o milter_macro_daemon_name=ORIGINATING
#smtps inet n - - - - smtpd
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o smtp_fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
retry unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
#
# ====================================================================
#
# Recent Cyrus versions can use the existing "lmtp" master.cf entry.
#
# Specify in cyrus.conf:
# lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
#
# Specify in main.cf one or more of the following:
# mailbox_transport = lmtp:inet:localhost
# virtual_transport = lmtp:inet:localhost
#
# ====================================================================
#
# Cyrus 2.1.5 (Amos Gouaux)
# Also specify in main.cf: cyrus_destination_recipient_limit=1
#
#cyrus unix - n n - - pipe
# user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
#
# ====================================================================
# Old example of delivery via Cyrus.
#
#old-cyrus unix - n n - - pipe
# flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
#
# ====================================================================
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}


amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,reject
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
 

nowayback

Well-Known Member
hi,

Code:
#smtps inet n - - - - smtpd
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
ändern in:
Code:
smtps inet n - - - - smtpd
 -o smtpd_tls_wrappermode=yes
 -o smtpd_sasl_auth_enable=yes
 -o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
Grüße
nwb
 

faulix

New Member
Okay, das ändert nun die Fehlermeldung:
Apr 14 23:14:55 hostname postfix/smtpd[5019]: warning: XXXX.adsl.alicedsl.de[85.xxx.xxx.18]: SASL PLAIN authentication failed: generic failure
Apr 14 23:14:55 hostname postfix/smtpd[5019]: warning: SASL authentication failure: cannot connect to saslauthd server: Connection refused
Apr 14 23:14:55 hostname postfix/smtpd[5019]: warning: SASL authentication failure: Password verification failed
 

faulix

New Member
Das ist sehr komisch, denn die Datei im init.d Verzeichnis ist leer. Auch das neu installieren über "apt-get install --reinstall sasl2-bin" hat nicht geholfen.
 

faulix

New Member
Fehler behoben:
Es haben einfach jegliche Konfigurationsdateien gefehlt. Ich habe /etc/init.d/saslauthd und /etc/default/saslauthd per Hand erstellt und nun geht alles.

Vielen Dank für Eure Hilfe!
 

Werbung

Top
Unsere Website wird durch die Anzeige von Online-Werbung für unsere Besucher ermöglicht.
Bitte ziehe es in Betracht, uns zu unterstützen, indem du deinen Werbeblocker deaktivierst.